1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Captivate won't turn on - permabricked?Support


  1. tcv

    tcv Well-Known Member

    While using the phone today the battery ran out, and as soon as I got home I plugged it in. I don't get the green battery charging screen and it won't turn on. I didn't do anything unusual other than run GPS in the background with Mytracks.

    Is there anything to do other than take it back? Force start? Battery fix? etc, etc?

    Advertisement
    :
  2. jonE5

    jonE5 Well-Known Member

    let it charge for 30-45 mins or so, should come up then
  3. tcv

    tcv Well-Known Member

    But it should still indicate that it is charging, no? With the green battery screen?
  4. BigCiX

    BigCiX Well-Known Member

    Should indicate that it's charging
  5. c2k

    c2k Well-Known Member

    Did you try pulling the batter out and putting it back in?
  6. tcv

    tcv Well-Known Member

    Yes, I took out the battery, tried plugging it in at other outlets, used different adapters. All to no success.

    This blows.
  7. novagator

    novagator Well-Known Member

    Not necessarily. It shouldn't take 30-45 minutes for it to indicate it, however. Maybe a minute or two.
  8. TDQuiksilver

    TDQuiksilver Well-Known Member


    How long did you leave the battery out of the phone for? Try some extended length such as 30 minutes. Sounds odd, but typically simple oddities like this work.
  9. pearts

    pearts New Member

    after having hit this thread on three different ocassions looking for the why's of my battery problem, I've decided to add my two cents...

    this has happened to me three times now, on three phones, the others were exchanged at the store i bought it from, when the battery hit red during the day, then when I got home, it would not charge the battery, instead the battery level went down, and down till the phone would not turn on any more

    Now on my 3rd phone, which has just started to have this problem.

    I know theirs external chargers on ebay, but I don't think I should have to use them to charge the battery, when the phones own charger fails to function..
  10. eDrizzlee

    eDrizzlee New Member

    I signed up specifically to post this. I had the same problem happen to me. Open the back of your phone and check to see if the sim card and sd card are pushed all the way back in. I did this and it worked. Although, I also took out my battery a second time and put it back in. Just a though.
Loading...

Share This Page