[CDMA] 3G data connection keeps dropping.


Last Updated:

  1. TabulaVicious

    TabulaVicious Member

    I'm rooted via the HTC HBOOT 1.5 method running Olympus Trinity 3D Rom. Everything works great except the 3G data connection--it drops randomly every 10-15 minutes up to an hour interval.

    Most of the time I can't tell, but every time the data connection drops, my AIM instant messenger app will tell me I am signed on in two places. Also it makes downloading any file a race against the clock.

    Help? :confused:

    I should add that my Sprint Evo 3D never did this on stock rom and running PDANet.

    Advertisement
  2. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Does that ROM use a custom kernel and did you flash the kernel using the fastboot method or the FlashGUI method?

    Have you tried another ROM? A lot of users here like the Xplod ROM and CleanROM.

    How recently have you rooted? Have you taken the most recent OTA?

    Have you cleared out your cache and dalvik cache? Did you clear them out before flashing the ROM?
  3. TabulaVicious

    TabulaVicious Member

    I only used whatever came inside the .zip file. I used the Fastboot method.

    Only Revolutionary and I couldn't get Tether to work at all, even though I am paying for Sprint Hotspot service. ;)

    I rooted 2 days ago, I'm not sure what the most recent OTA I had was.

    No, I didn't do that. What does clearing the cache do and what is the difference between the regular cache and the dalvik cache?

    If I sound like a n00b, it's because I am a n00b. :eek:

    Thanks for your assistance. :D
  4. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Ok good, so that's not the problem.

    Is revolutionary a ROM? I know revolutionary is a S-Off method and wouldn't work with HBOOT 1.5. I don't think it would screw anything up, though. But give the Xplod ROM or CleanROM a shot. Just remember to clear cache and dalvik before you flash the ROM.

    The most recent OTA would have asked you to accept it and only have been available in the last week. I'll assume you don't have it.

    This explanation is simplified, but for now it should do: Cache stores Android's regularly accessed files, for quicker loading. The dalvik cache stores the cache files for the dalvik virtual machine. The dalvik VM is a security measure to make it so apps can't directly modify the system.

    The reason why you clear both the cache and the dalvik cache before flashing a ROM is that different ROMs use different caching techniques, names the files differently, etc. If you don't clear them out, the flashed ROM may have installation problems. Or you may have problems while running the phone...like your noted problem. Or apps constantly force close. Or any number of issues.

    Hey, we were all noobs at some point. You only stop being a noob by asking questions and reading up on stuff.

    You're welcome! It's what these forums are for :)
    Frisco and ocnbrze like this.
  5. TabulaVicious

    TabulaVicious Member

    My bad, the name of the ROM I tried and discarded because WiFi & USB tether did not work was called Android Revolutionary HD.

    [ROM] Android Revolution HD™ 1.1.3 | High Quality & Performance | O/C | Legendary - xda-developers

    I will try Xplod and Clean ROM and report back...
  6. jerofld

    jerofld Fixing stuff is not easy VIP Member

    ocnbrze likes this.
  7. devinEVO

    devinEVO Well-Known Member

    download msl reader and write your msl down.

    go to phone and type in ##3282#

    enter your msl as the password

    go to evdo and change from cdma only to automatic... and it should be fixed
    ocnbrze likes this.
  8. TabulaVicious

    TabulaVicious Member

    Tried that... My EVDO was already set to automatic mode.
  9. mteezey

    mteezey Well-Known Member

    Myself and some other users have our 3vos flashed to metroPOS and have problems with our evdo connection while running Olympus.
    I would go with the suggestion above of cleanrom. Curious to hear back too. I need a stable 3g ROM.
  10. TabulaVicious

    TabulaVicious Member

    Ok, finally had time to play with this again.

    Rebooted into USB Fastboot.

    Fastboot flash unlocktoken Unlock_code.bin

    fastboot boot twrp-shooter-2.0.0rc0.img

    Wipe cache, wipe dalvik cache.

    Install CleanROM 2.9.5.

    Wipe cache, wipe dalvik cache again...

    So far I've gone about 30 minutes without a momentary dropped 3G connection. :D

    I'll still need a few more hours of continuous use to test things out, but so far, it looks like CleanROM 2.9.5 did the trick! Olympus rom was a POS. :eek:

    Thanks for all the commentary guys, I've learned alot in rooting my phone. I've owned the Evo 3D since the first week it came out in June 2011 if I remember right--it replaced an ancient 2003 vintage (color screen!) flip phone... :eek: I kinda wish I started messing with this stuff earlier but going from a phone that just makes phone calls to an Android phone is a big learning curve. :cool:
  11. TabulaVicious

    TabulaVicious Member

    Ugh.... spoke too soon. 3G connection is still dropping on the phone. Maybe it's time to try a Wireless tethering app instead of Sprint Mobile Hotspot. :confused:
  12. jerofld

    jerofld Fixing stuff is not easy VIP Member

    It couldn't hurt. CleanROM should have WirelessTether app installed.

    (Please note that TabulaVicious is a paying member of tether, so use of alternate tethering apps is OK. For anyone reading this, if you're not paying for it, use of these apps are in violation of http://androidforums.com/sprint/455520-sprints-official-tethering-policy.html)
    agentc13, devinEVO and Frisco like this.
  13. TabulaVicious

    TabulaVicious Member

    I've using the WirelessTether app... it seems to work but there is some wierd DNS issue. I can open up Google.com but not any other site. Ideas? :confused:
  14. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Ok, I'll PM you the rest of the details.
  15. rishidoshi

    rishidoshi Member

    My solution and experience:
    Solution: Give yourself a missed call from another phone, (or send in an sms). Somehow this 'establishes' some connection and viola! data connection is back in 5 seconds. (i know, for calling yourself u need to ask someone for his phone.. lol)

    Also: I got a dual sim phone. I use Vodafone and Uninor (India).
    Data is always connected and fine when on Vodafone, but drops when i use data on Uninor. So I use the above method to re-establish data.
    Hope it works for you!
    Regards

Share This Page