[CDMA] Can't Install Superuser?


  1. K927A

    K927A Well-Known Member

    I'm sitting down getting ready to root, and I thought to try the old temp root method to back some things up first. The script seems to work until it gets to installing superuser.apk where it throws and insufficient storage error.
    So I got curious and tried installing from the market. Same error. From SD, same story. I tried a few superuser apps, all the same error. I tried installing superuser from the market on a different non-rooted phone and it worked fine (but of course it didn't have root permissions). I can't figure out why it won't install. I installed a number of other apps (for testing purposes) with no issues.

    This has halted me in my tracks a bit. I'm wondering if this issue will persist after I run revolutionary. Does anyone have any ideas?
    Stock Evo3d 1.30hboot

    Advertisement
  2. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    I don't have this device any longer, but I am no sure you can still do a temp root, with the latest exploit on this device. You would have to do the permanent root option, then you will be able to have SU and also make a Nandroid before you flash a custom Rom.

    Not sure how current this still is, but I am sure either Brian or Scotty will be in to check in on you, but you can check this thread out here

    http://androidforums.com/cdma-evo-3...shing-evo-3d-roms-kernels-using-fastboot.html
    scotty85 and Brian706 like this.
  3. Brian706

    Brian706 Moderator Moderator

    I don't think you need to temp root. You haven't taken any updates and you're still on hboot 1.30.

    Revolutionary gives you s-off without the need to unlock the bootloader, which in turn means you don't need to factory reset the phone. In fact, with s-off, you never need to unlock the bootloader if you so choose.

    Once you are s-off, you can add custom recovery through the bootloader.

    Instructions:
    Once recovery is installed, make a full backup of the phone.

    After you have a successful backup, flash the latest superSU via recovery and voila!, rooted.
    scotty85 likes this.
  4. K927A

    K927A Well-Known Member

    Yeah I figured it all out. I finally did S-off with revolutionary. It took maybe two minutes. Afterwards I used fastboot to boot into TWRP and took a nandroid with everything (save for hboot) still stock. Left stock recovery for now.
    Finally I got SuperSU on there by installing zip from TWRP. I couldn't install any rooting apps from the market. TWRP gives the option to install SuperSU if it detects you don't have it, tried that too and it didn't work right. Only installing the zip seemed to do it. All root functions work now.

    Still having the issue though, I tried to install Adfree (not from the market) and I get the same out of space error even though I have space. I caught whiffs from another thread that it may be an error with package installer or something?

    Thanks for everyone's help btw. Brian our year old thread on rooting helped refresh my memory before jumping in. Still working on a disappearing space on /data issue I mention in another thread
    DonB and scotty85 like this.
  5. K927A

    K927A Well-Known Member

    I'm still not able to install several root apps, I get an insufficient space error. Is there an alternate way to install these apps? Anyone have an idea how I might correct the error?

    Seems to affect root type apps. So far I've tried: wifi tether, adfree, and all of the superuser apps.

Share This Page