[CDMA] Complete Newbie's Guide to rooting and flashing Evo 3D ROMs/Kernels using fastboot


Last Updated:

  1. dmcfirestar500

    dmcfirestar500 New Member

    Joined:
    Jul 6, 2012
    Messages:
    1
    Likes Received:
    0
    Hey Guys looking for some help.

    I am trying to root my 3d. I get to step 4 go to http://htcdev.com/bootloader select my model and click begin unlock bootloader button but nothing happens next. No screen to enter the identifier.
     

    Advertisement
  2. DeZxDiLLiNGeR

    DeZxDiLLiNGeR New Member

    Joined:
    Jun 30, 2012
    Messages:
    4
    Likes Received:
    0
    When i enter fastboot the cmd says the command is not recognized
     
  3. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    I think I might have just solved my own problem thinking back when I had to stop the process after I unlocked my boot loader, never turned fast boot back off through power settings nor re enabled usb debugging. Though I did notice one thing when you was helping another. You said they need to place recovery.img in the fast boot directory and not just in the sdk-tools folder unless I read that wrong? Will update if it works for me tomorrow :)
     
  4. jerofld

    jerofld Fixing stuff is not easy VIP Member This Topic's Starter

    Joined:
    May 10, 2011
    Messages:
    7,688
    Likes Received:
    4,273
    What error does it give you? It'll be key for figuring out your problem.

    HTC dev's site has a lot of problems. It does this often. Try again later.

    I think it's time you and I try a different tactic, I'm going to PM you.

    fastboot should be in the sdk-tools folder if you installed mini-sdk. If you installed the full Android SDK, then the fastboot executable will be in the Android SDK folder in Program Files.
     
  5. ymmie

    ymmie Well-Known Member

    Joined:
    Aug 25, 2010
    Messages:
    126
    Likes Received:
    44
    I had the same problem. Try a different browser. It didn't work for me on either Mozilla Firefox or Google Chrome for some reason, but worked just fine on Internet Explorer.
     
  6. dgrobe2112

    dgrobe2112 Well-Known Member Contributor

    Joined:
    Jan 11, 2010
    Messages:
    462
    Likes Received:
    76
    just curious.. at what point am i rooted.. is that as soon as it shows unlocked? i havent flashed a rom yet..
     
  7. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    Oh okay well I may try re installing all the software and hoping I just picked up a bad file or fastboot being
     
  8. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    Oh okay well I'm going to try re installing all software and hoping i just picked up a bad file or fast boot being on or usb debugging not on is the trick
     
  9. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    I actually questioned that but no as I did a root check after i unlocked flashing recovery and ROM roots you I'm pretty sure still in the process myself
     
  10. dgrobe2112

    dgrobe2112 Well-Known Member Contributor

    Joined:
    Jan 11, 2010
    Messages:
    462
    Likes Received:
    76
    finally got it.. thanks for this thread.. i have allready flashed a rom..

    BTW.. Just FYI.. as soon as you unlock bootloader.. it automatically does a factory reset on the phone..
     
  11. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    as far right now im at step flashboot flash recovery.img "cannt determine image filename for "recovery.img"
     
  12. dgrobe2112

    dgrobe2112 Well-Known Member Contributor

    Joined:
    Jan 11, 2010
    Messages:
    462
    Likes Received:
    76
    rename the file 'recovery-twrp-shooter-1.1.1.img' to 'recovery.img'. Place this file in your sdk-tools folder.

    If you did like me.. that file will be on your desktop. move it to the sdk-tools folder.. and your good to go.
     
  13. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    Had already did that and still was unable to root via this guide which hate to say led me watching a guide on YouTube which I was successfully rooted via revolutionary with mean ROM
     
  14. Relax196

    Relax196 New Member

    Joined:
    Dec 25, 2010
    Messages:
    2
    Likes Received:
    0
    im stuck at step four. My phone ignores the unlock token bin from the command prompt. i did every right. my phone is on 2.17 1.50 s off
     
  15. dgrobe2112

    dgrobe2112 Well-Known Member Contributor

    Joined:
    Jan 11, 2010
    Messages:
    462
    Likes Received:
    76
    u must have been at 1.4 hboot.. i think that root method is for 1.5 hboot
     
  16. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698

    No I'm on 1.5
     
  17. TurboS81

    TurboS81 Well-Known Member

    Joined:
    Jul 17, 2012
    Messages:
    117
    Likes Received:
    44
    Hey everyone! I just got to say how awesome the complete guide to rooting is! I successfully rooted my phone last night in under two hours (would have been quicker had I not been doing other things). I was on the fence about rooting, considering the fact that I felt like information about the entire process was too scattered across the Internet. I read through this guide and decided to take on the task. I am glad I did! I went with MEANRom ICS 2.4 and have not been able to put my phone down. I had complete success on the first try; no looping of boatloader at all. Great job jerofld and any other contributors to the guide!

    My next task is going to S-Off. I am thinking about doing the wire trick, but the information I find states that I must have the stock ROM loaded before going S-Off. Is this true, or is there a way to leave MEANRom loaded and still do S-Off? If so, how exactly?

    Also, I downloaded 4Ext (the paid version) last night, but haven't quite had a chance to explore its features. If I understand correctly, I can use this app to load new ROMs at any time without having to use the FASTBOOT method. Is this right?

    I'm still learning all the terminology, so forgive me if I made a mistake.

    Cheers to rooting!

    Steve
     
  18. invince

    invince Active Member

    Joined:
    Aug 21, 2011
    Messages:
    25
    Likes Received:
    0
    I received ics 4.0.3 official ota recently...It was never rooted...Now i want to root it...hboot 1.53.0007 s-on...GSM...Will this method work...:confused:
     
  19. invince

    invince Active Member

    Joined:
    Aug 21, 2011
    Messages:
    25
    Likes Received:
    0
    ^^Anyone ?!?
     
  20. TurboS81

    TurboS81 Well-Known Member

    Joined:
    Jul 17, 2012
    Messages:
    117
    Likes Received:
    44
    I'm no expert, and I'm sure your looking for exactly that, but it would seem that the GSM process on page 1 would work just fine. The only difference might be that you find the stock ICS ROM or the previous factory ROM. Everything else should be the same.
     
  21. invince

    invince Active Member

    Joined:
    Aug 21, 2011
    Messages:
    25
    Likes Received:
    0
    HOW DO I ROOT MY STOCK OTA ICS ROM (GSM) ??????????!?
    i want to keep the original ics and be rooted !:confused:
     
  22. ccortez831

    ccortez831 Member

    Joined:
    Jan 4, 2012
    Messages:
    5
    Likes Received:
    0
    does this work for the evo 3d if it has ICS?
     
  23. bowhunt2005

    bowhunt2005 Active Member

    Joined:
    Jul 4, 2012
    Messages:
    36
    Likes Received:
    5
    When I try to show any of the steps by clicking show, all that pops up is %1$s. Why is that?
     
  24. dphilly

    dphilly Member

    Joined:
    Nov 20, 2011
    Messages:
    13
    Likes Received:
    0
    why do i get %1$s when i click "show" on page 1 of this thread? Every single one does the same thing
     
  25. dphilly

    dphilly Member

    Joined:
    Nov 20, 2011
    Messages:
    13
    Likes Received:
    0
    Yes but i didn't flash the ROM that was rooted, instead just flashed the su-2.3.6.3-efgh-signed.zip. This worked great because I didn't want to change my current stock ICS.
     

Share This Page

Loading...