[CDMA] HTCDEV.com bootloader unlock: s-on with CWM + root access


Last Updated:

  1. EarlyMon

    EarlyMon The PearlyMon Moderator

    I saw this in a Phandroid comment -

    I have no idea if this is really true.


    EDIT - Update - it's totally for real.

    HTCdev - Unlock Bootloader

    STATUS August 19, 2011 -

    OK - this will leave you with S-ON -- but you can install Clockwork Mod recovery v4.0.1.4 -- and then superuser permissions from there.

    What follows is a history of confusion that begins to clear up at the posts beginning here:

    http://androidforums.com/evo-3d-all...r-unlock-s-cwm-root-access-2.html#post3099849

    Advertisement
    SamuraiBigEd and chrisedwards12 like this.
  2. jerofld

    jerofld Fixing stuff is not easy VIP Member

    How convenient of them to update the HBOOT the same day they release the S-OFF tool.
  3. EarlyMon

    EarlyMon The PearlyMon Moderator

    It's officially there for the Sensation in Europe - but I'm reading that it works for the 3D.
  4. I hope it works Im getting ready to try it :|


    I am at work... Got yelled at for using too much bandwidth downloading the sdk :/ .. Ill have to get back to this when I get home. Sorry for the delay..

    Chris
    EarlyMon likes this.
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    Best luck... (waiting waiting...)
  6. Doomstang

    Doomstang Well-Known Member

    I'm about 3/4 of the way through the process...phone restarting now
    EarlyMon likes this.
  7. z50king

    z50king Well-Known Member

    watching for pics of what it says on hboot when it's unlocked via htc

    maybe it says this:

  8. JD_from_da_80s

    JD_from_da_80s Well-Known Member

    How does this affect those of us already rooted?

    How is this gonna affect development of roms? If devs make roms based on the hboot update, will we have to unlock through HTC & register our phones to use their roms? Or is their hboot update basically the same as TWRP exploit since the end result is the same?

    S-Off tool = maintenance update released today or is that something different?


    @50King, lol
  9. Doomstang

    Doomstang Well-Known Member

    ;)

    *** UNLOCKED ***
    SHOOTER XC SHIP S-ON RL
    HBOOT - 1.50.0000
    eMMC-boot
    Aug 7 2011,10:21:40
  10. Doomstang

    Doomstang Well-Known Member

    Ok now that I've done that...what do I do lol. I guess I basically just want root access to have wireless tether.
  11. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Whiskey Tango Foxtrot?

    Ummm....I guess you could try flashing something. First you need a recovery from the sticky thread in this forum.

    Then grab a ROM from here: http://forum.xda-developers.com/showthread.php?t=1192661 A bunch to choose from. Get one that says "basic" in it. SteelRom is pretty good, but adds more flavor than you may want.

    But with S-ON...who knows if it will actually work.
  12. jerofld

    jerofld Fixing stuff is not easy VIP Member

    The patch installs a new HBOOT (AKA the bootloader). The new unlock tool is the web tool that unlocks the bootloader on htcdev.com
    JD_from_da_80s likes this.
  13. Doomstang

    Doomstang Well-Known Member

    Just finished flashing clockworkMod recovery. I'll update this post when I get farther
  14. Jackietreehorn

    Jackietreehorn Well-Known Member

    :confused: Weird that the S-ON apparently means nothing if you've got "Unlocked" above it. Doesn't it seem like it would have been more appropriate for them to both say "Unlocked" and toggle to S-OFF? Oh well, interested to see how this will go for you, but it looks like you've cleared the biggest hurdles.
  15. Doomstang

    Doomstang Well-Known Member

    Yeah...only thing I can think of is that it said 'SHIP S-ON'. Is it trying to let me know that it came with S-ON but it is now 'unlocked'? Idk...just had to do a battery pull when it wouldnt reboot. Got it to boot up fine now so I'm restarting again and heading to my new Recovery
  16. Doomstang

    Doomstang Well-Known Member

    Ok so when I press power button with Recovery highlighted it goes to a white screen with hTC...waits a while, goes to a black screen, then comes back on to the same screen and continues with a normal reboot sequence. -scratches head- I'm no pro at this so I don't know what it's supposed to do but I'm guessing it isn't this.

    Edit:
    The first time I did it through fastboot and it said "OKAY" and then "finished". When I tried it through the bootloader after placing it on the SD card it searches through and tries to load something and then quickly says something about being the wrong file (it goes so quick I'm not positive about the exact wording). So my guess is that I have an alleged unlocked bootloader but can't flash my own recovery (if I'm understanding that correctly).
  17. blingeorkl

    blingeorkl Well-Known Member

    It should go straight to CWM if you do that. I'd suggest reflashing CWM.

    Here's a thread on XDA about some people talking about it: http://forum.xda-developers.com/showthread.php?t=1224485

    It appears that there are some issues with the recoveries (people saying that TWRP doesn't load at all)
  18. Doomstang

    Doomstang Well-Known Member

    Just tried flashing TWRP as well and got the same results described in my post right above yours that I just edited as you posted. :(

    Edit: Just looked over at XDA and at least one other guy is at the same step as me and is stuck.

    http://forum.xda-developers.com/showthread.php?t=1224485&page=2
  19. jerofld

    jerofld Fixing stuff is not easy VIP Member

    1) Pull the battery out.

    2) Put battery back in and put the battery cover on

    3) Hold Volume Down

    4) Hold down Power button.

    5) When the HBOOT appears, go to recovery.

    What happens?

    And btw SHIP is on all of our bootloaders, unless they got the engineering bootloader, which would be ENG S-OFF
  20. Doomstang

    Doomstang Well-Known Member

    Thanks jerofld but when I go to Recovery it goes to a white screen with hTC...waits a while, goes to a black screen (assuming this is the 'off' part of a reboot), then comes back on to the same screen and continues with a normal reboot sequence until I'm at my normal home screens.
  21. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Ok, I'm willing to bet that CWM and TWRP just are not compatible with some wonkiness they included in HBOOT 1.50. If the HBOOT didn't allow you to flash anything, stock recovery would be there.

    Or the HBOOT allowed you to flash the recovery, but the HBOOT won't load the custom recovery because it doesn't have the right key. That would be a major fail on HTC's part.

    Edit: What that means for you is that you might be screwed if something goes haywire on your phone. You don't have any recovery options. So either HTC has to make it so the HBOOT doesn't look for a specific recovery or CWM/TWRP have to figure out a way around it. But it definitely looks like it's in HTC's court.
  22. Doomstang

    Doomstang Well-Known Member

    I don't know what the stock recovery would look like, nor did I try to load it before I had tried to put CWM recovery on there (through both methods). Team Win's recovery is what I tried most recently so I guess that's the one that's currently failing. I'll just keep watching this board as well as XDA until I hear one of the really smart people has a solution lol
  23. EarlyMon

    EarlyMon The PearlyMon Moderator

    If you have fastboot installed on your PC, please issue this command from a DOS window -

    fastboot oem unlock

    Report back s-on or s-off please.
  24. Doomstang

    Doomstang Well-Known Member

    c:\Android>fastboot oem unlock
    ...
    (bootloader) [ERR] Command error !!!
    OKAY [ 0.006s]
    finished. total time: 0.007s

    Any other ideas while I'm here?
  25. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Stock recovery looks identical to the HBOOT screen, except it gives different options.

    But yeah, it looks like either HTC or a dev will have to roll out a solution. I'm hoping CWM and TWRP can be updated to work with the new HBOOT.

Share This Page