[CDMA] Waiting for network...


  1. Android_Ascend

    Android_Ascend Well-Known Member

    Ok so this started the other day, I've been trying to download an app and update my apps but all I get is "Waiting for network..." What does that mean? I had Viper Rom now I have MikVirgin 1.1, yes I've rebooted taken out the battery, I wiped everything twice before I installed MikVirgin... So can anyone give me any clues to this? It's really annoying. Everything else works texts, picture messages, facebook, calls, even torrents.... So what's the issue here?

    Advertisement
  2. flacraker

    flacraker Well-Known Member

    It's happening to me also, only on 4g, something is wrong with the sprint store, network,
  3. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    I would start with the basic, try updating PRL and Profile and reboot and try again, if the problem persist then create a Nandroid, and restore your Stock Rom, see if it happens there, then try a different Rom, like Zred ICS 2.1, I am assuming you are on HBoot 1.5 ?? What recovery are you using ??
  4. ymmie

    ymmie Well-Known Member


    I am on a different ROM and have the same issue. I think even non-rooted users are experiencing this also. I'm pretty sure it is not specific to the OP or his setup.


    http://androidforums.com/sprint/580666-play-store-not-working-4g.html
  5. Android_Ascend

    Android_Ascend Well-Known Member


    No I took the challenge of downgrading to 1.4 and rooting, now how would I go about updatating the PRL and PROFILE
  6. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    If you are on a Sense Rom, hit Menu/Settings/System Updates



  7. dgrobe2112

    dgrobe2112 Well-Known Member Contributor

    mine was doing the same thing.
  8. Android_Ascend

    Android_Ascend Well-Known Member

  9. Android_Ascend

    Android_Ascend Well-Known Member


    Ok I updated but still nothing :( it won't work.
  10. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Well mine works of 4G, but I am on Zred ICS 2.1, I would post in the Mik Rom thread over at Miks, and see what they say



  11. Android_Ascend

    Android_Ascend Well-Known Member


    Yea ill do that but it started with ViperRom, how good is Zred ICS 2.1?
  12. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    I love it and have no issues, give it a shot, Nandroid is your friend



  13. Android_Ascend

    Android_Ascend Well-Known Member


    Ok I will give it a try :)
  14. ymmie

    ymmie Well-Known Member

    I found this on Google's tech support site

    Android Apps Known Issues
    Welcome to the Android Apps on Google Play Known Issues page - by clicking on an issue, you can see details. Use the Report this issue button to let us know if you're experiencing the problem.

    If you're experiencing an issue that is not listed here, please feel free to contact us.

    New Issues
    [#6789539] "Waiting on network" error over 4G
    We're aware that some users (in particular Sprint users) are receiving a "Waiting on network" error when downloading from Google Play over the 4G network.

    This issue is a problem with the configuration of your carrier network, but we're currently working with carriers to get it resolved, so thanks in advance for your patience.

    In the meantime, as a temporary workaround, please:

    Use 3G instead of 4G to download from Google Play or
    Use WiFi instead of a network connection
    Issue first reported on: July 9, 2012

    Last updated on: July 11,2012
  15. AngryTeddyBear

    AngryTeddyBear Well-Known Member

    Try uninstalling the Play Store updates.
  16. Corpse11

    Corpse11 Well-Known Member

    Its a problem with how Sprint 4G WiMax connects to the newest Play Store...uninstalling the Play Store updates will only fix it for a short period of time, once the Market/Store updates on its own to the newest one again, it will give you the same "waiting for network" issue. 3G and WiFi are the only solutions right now, until a new Play Store comes out that supports 4G WiMax again...
    EVOlution91 likes this.
  17. EVOlution91

    EVOlution91 Member

    Very true, I guess the waiting time she comes... Btw guys I'm Android_ascend, something happened with my other account and I couldn't get on so I made this new one
  18. EVOlution91

    EVOlution91 Member


    How would I go about and uninstalling the updates?
  19. Rammsteinnener

    Rammsteinnener New Member

    Even i had the same error while using 4G and Internet Pass through.But it worked fine in 2G(EDGE),3G.
  20. Corpse11

    Corpse11 Well-Known Member

    problem has been fixed with newest market update
  21. ymmie

    ymmie Well-Known Member

    Yup, works for me now too.

Share This Page