[CDMA] What is boot.img?


  1. ggrimaldi

    ggrimaldi Well-Known Member

    Sorry for the noob question, but what is boot.img? Where can I find it and what does it do?

    I

    Advertisement
  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    With the bootloader unlock solution from HTC, you can't write to certain paritions of the phone via clockwork, one of those is the boot partition which is where the boot.img resides.

    It's relatively easy to do, do you still have the fastboot files you downloaded from HTC.dev when you unlocked your bootloader?
    ggrimaldi likes this.
  3. ggrimaldi

    ggrimaldi Well-Known Member

    Yep, every file I used to unlock my phone is still on my desktop. What do I need to do?
  4. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    The process is generally the same across all ROMs, but it might differ slightly so if you give me a link to the ROM you're installing, I can take a look and give you step by step instructions.
    EarlyMon likes this.
  5. ggrimaldi

    ggrimaldi Well-Known Member

  6. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Did you flash a kernel via fastboot? It's basically the same thing.

    That dev hasn't given specific instructions, so this is how it's done most of the time, I can't guarantee that this is the correct method for that ROM, but

    1. Open the zip file you downloaded for the ROM install, look for a file called boot.img
    2. Copy boot.img to the folder you've got your fastboot files
    3. Reboot your handset and go into the bootloader, then using the volume keys to navigate, select fastboot.
    4. Connect the phone to your PC, it should say "fastboot USB" about a third of the way down the screen
    5. Open a command prompt and navigate to the folder where you copied the boot.img/where your fastboot files are.
    6. Type the following command and press enter:

    Code (Text):
    1. fastboot erase cache
    7. Once it's done it's thing, type the below and again press enter:

    Code (Text):
    1. fastboot flash boot boot.img
    Once done, you can now disconnect the phone from the PC. Now either head to recovery to flash your ROM or if you've already flashed the ROM, you can just reboot.

    I'm 99% sure that will be the procedure for flashing the boot image, but as he doesn't give instructions for non S-OFF'd devices, I can't be 100%. That's how I've done it on all HTC handsets I've had though. However, you might want any EVO regulars to confirm/correct me before you go ahead.
    LightningBlots likes this.
  7. ggrimaldi

    ggrimaldi Well-Known Member

    Ok, I understand now why I can not flash ICS ROM.
    Let me give it a try, and I'll get back to you with the result.

    Thank you so much for the help. ;)
  8. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    You could also try changing your recovery to 4EXT, much better and more user friendly for HBoot 1.5 ;)
  9. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Also, once you get a ROM running, I'd recommend 4EXTRecovery. It makes it so you don't need fastboot to flash kernels, most of the time, and is easy to use.
    ggrimaldi likes this.
  10. flacraker

    flacraker Well-Known Member

    Just figured is throw this out there, I was on hboot 1.5 and also had problems with a lot if roms, I didnt use the junipbear method, I used the other method and it took me adout 20 minutes was fast and painless, and being on hboot 1.4 is so much better....
  11. ggrimaldi

    ggrimaldi Well-Known Member

    Sorry, I'm kinda confused here. I am using 4EXT, but how to flash boot.img with 4EXT?:confused:
  12. ggrimaldi

    ggrimaldi Well-Known Member

    Honestly, I'm a little scared to do that downgrade method. :D
    I'd prefer juopunutbear, but I recently got busy with work. Once I have a time, I'm gonna give it a go.

    Thanks anyway..
  13. ggrimaldi

    ggrimaldi Well-Known Member

    Guys,

    I tried El Presidente process, flash the ZR3DX ICS ROM, get a bootloop, pulled the battery. And now I can not get it powered on, can not get into bootloader.

    On my laptop, it says 'QHSUSB_DLOAD'.

    What should I do?
  14. ggrimaldi

    ggrimaldi Well-Known Member

    Ok, after several times removed the battery, I can get into bootloader and recovery.

    I'm trying to restore my nandroid while typing.

    So what happened there?
  15. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Computer hiccups. Sometimes you just have to pull the battery out and let it sit for awhile.
  16. ggrimaldi

    ggrimaldi Well-Known Member

    Well, it almost gave me a heart attack, man.. :D
  17. jerofld

    jerofld Fixing stuff is not easy VIP Member

    I can imagine. I bet I would, too, if I was in the same situation.

Share This Page