1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Chagne Display name on Hotmail account on ICS?Support


Last Updated:

  1. FreeRangers

    FreeRangers Well-Known Member This Topic's Starter

    Joined:
    Jun 25, 2012
    Messages:
    66
    Likes Received:
    4
    Let's say my email is FreeRangers (@) hotmail.com when I send an email the recipient sees the sender as Freerangers. On Gingerbread I was able to change this so that the display name didn't show Freerangers, but showed whatever I wanted it to (John, for example). On ICS I have my hotmail account set up as an exchange account (because that is the only way I could delete emails form my phone and they would also get deleted form Hotmail's servers). But I also tried just setting up hot mail as a normal hotmail account, but I still can't change the display name.
     

    Advertisement
  2. tawheed

    tawheed Member

    Joined:
    Jan 17, 2012
    Messages:
    19
    Likes Received:
    1
    Any luck with this? Same issue on my S3.
     
  3. tawheed

    tawheed Member

    Joined:
    Jan 17, 2012
    Messages:
    19
    Likes Received:
    1
    Did some digging and it turns out that you can't change the display name on the device. There must be something weird with Samsung because with my HTC One X it would send emails from my proper display name and with the S3 it sends as the email address account name.. Wish I could get this solved, very frustrating.
     
  4. FreeRangers

    FreeRangers Well-Known Member This Topic's Starter

    Joined:
    Jun 25, 2012
    Messages:
    66
    Likes Received:
    4
    Well that kinda sucks. I know I could do it in Gingerbread. It's not a huge issue though (more like a minor annoyance).
     
  5. tawheed

    tawheed Member

    Joined:
    Jan 17, 2012
    Messages:
    19
    Likes Received:
    1
    It's pretty damn annoying, it should just work.. I've been googling like mad and am unable to come up with any type of fix.
     
  6. vet4snak

    vet4snak New Member

    Joined:
    Jul 5, 2012
    Messages:
    1
    Likes Received:
    0
    i just bought my S3, super expensive. and i got the same problem as you guys. very frustrating..why is a phone of this caliber have such stupid issues?! i dont want to use market apps
     
  7. GVO

    GVO New Member

    Joined:
    Aug 14, 2012
    Messages:
    1
    Likes Received:
    0
    Hi,

    I had the same problem and discovered 2 solutions / work arounds.
    (I'm using a Samsung Galaxy S2.)

    The problem you mention (not being able to change the Display Name) appears when using Samsung Social Hub if you set the hotmail, gmail, or other email-account as a premium account.

    The 2 solutions / work arounds are:
    * use Samsung Social Hub and DON'T set your e-mail (hotmail, gmail, etc) as a premium account. You lose 'push' functionality. This does not apply to "Microsoft Exchange ActiveSync" e-mail.
    * use the hotmail (or gmail) app.

    These aren't the only strange things on Samsung (Galaxy) smart phones. But that's for another topic.
     
  8. gavin watson

    gavin watson New Member

    Joined:
    Aug 27, 2012
    Messages:
    3
    Likes Received:
    0
    There is a solution to this here.
     
  9. ThatOneRearEnd

    ThatOneRearEnd Well-Known Member

    Joined:
    Jul 8, 2013
    Messages:
    215
    Likes Received:
    23
    In case anyone's still interested, here's the real solution:
    You need a rooted phone and a SQL-Editor installed on it.

    Navigate to /data/data/com.android.email/databases/EmailProvider.db. Select the Account-table and search for the column "sender name". Here you can edit the value to nearly anything you want. Save, exit, stop the email-app via settings and launch it again.

    It works not only on ICS but also on JB...
     
  10. macnero

    macnero New Member

    Joined:
    Sep 25, 2013
    Messages:
    1
    Likes Received:
    0
    Thanks ThatOneRearEnd but when I navigate to the folder /data/data/com.android.email/databases it says that it is empty. I can't find EmailProvider.db anywhere. Any suggestions?

    Thanks in advance.
     
  11. ThatOneRearEnd

    ThatOneRearEnd Well-Known Member

    Joined:
    Jul 8, 2013
    Messages:
    215
    Likes Received:
    23
    It is there, at least if you created an account within the app in the first place.

    [​IMG]
     
  12. giorojasj

    giorojasj New Member

    Joined:
    Jan 20, 2014
    Messages:
    2
    Likes Received:
    0
    Any luck with this... I have the same problem and it is kind of anoying...solutions? My phone is not rooted...so I guess that is why i cannot access EmailProvider.db....answers pleaseeee!!!
     
  13. ThatOneRearEnd

    ThatOneRearEnd Well-Known Member

    Joined:
    Jul 8, 2013
    Messages:
    215
    Likes Received:
    23
    Yes, that's the problem...
     
  14. giorojasj

    giorojasj New Member

    Joined:
    Jan 20, 2014
    Messages:
    2
    Likes Received:
    0
    Is there any way I can work this around without rooting my phone?
    This is very anoying...a very expensive phone that doesnt do what is suppose to do!!!
     
  15. ThatOneRearEnd

    ThatOneRearEnd Well-Known Member

    Joined:
    Jul 8, 2013
    Messages:
    215
    Likes Received:
    23
    It's not a phone fault, it's a software one...

    I can't think of any other solution than either root your device or go and buy a different one...
     

Share This Page

Loading...