Change Screen LockSupport

Last Updated:

  1. rbw522

    rbw522 New Member

    I have a Droid X. I was previously employed by a company that used Exchange Server and Active Sync and I added my company email account to the Droid X. This forced me to use a 4 digit pin as required by the mail admin of the company. I no longer work for this company, and deleted the active sync account from my phone (and no longer have access to it by any means). The security settings for the PIN however have remained, and are a pain. When I check SETTINGS -> LOCATION & SECURITY -> CHANGE SCREEN LOCK -> CHANGE SCREEN LOCK the options, "None" and "Pattern" are grayed out and not selectable. When I look under SETTINGS -> LOCATION & SECURITY ->SELECT DEVICE ADMINISTRATORS the device administrator is listed a "Corporate Sync" and I cannot change or delete this. Does anyone know how to get rid of these?

  2. bbuck002

    bbuck002 Well-Known Member

    probably like this b/c you had security software installed on your phone to allow you into the exchange server (your four digit pin is example of this security)

    in my opinion (not an IT expert) you will probably have to reinstall stock 2.2 to erase whatever security protocols exist.

    I want my work email on my phone, but not willing to let IT touch it and install anything on it b/c it locks down your device.

    good luck!
  3. rbw522

    rbw522 New Member

    Thanks buck, I think I understand the WHY of this issue, just need some info on HOW to remove the security. I was hoping that there would be someone who would know where the data for security settings was stored and had some hack to delete it.
  4. ekyle

    ekyle Well-Known Member

    Try removing the corporate account yet?
  5. gnystrom

    gnystrom Active Member

    I just click on the Exchange Active Sync>menu>more>settings>delete account.
    Maybe then Settings>security>change lock

    good luck
  6. rbw522

    rbw522 New Member

    Thanks guys, I have already deleted the Exchange Active Sync account on my Droid X, and had the Exchange Administrator delete the device on the Exchange Server...still no luck. I am suspecting that it may be due to the fact that the Exchange account was likely already disabled when I deleted the ActiveSync account from the Droid.
  7. drduser

    drduser New Member

    I tried deleting the corporate sync account while my exchange account is still active on the exchange server but it didn't get rid of the security lock. I think a factory reset might work.
  8. rbw522

    rbw522 New Member

    Thanks to everyone who tried to help...I finally just bit the bullet and reset the phone to factory defaults and reinstalled all my apps. Not as bad as I thought it might be either!

Share This Page