Charging Port Issue - Anyone else have this problem???


Last Updated:

  1. earlgsxbusa

    earlgsxbusa Well-Known Member This Topic's Starter

    Joined:
    May 13, 2010
    Messages:
    50
    Likes Received:
    15
    Hi Fellow Evo owners.

    So it finally happened...the charging port on the EVO has come loose. :-( It has a little more "play" more than normal. Downside is i have to hold it a certain way to maintain a charge.

    Times like this i hate. So my question is should i call sprint and cash in on my insurance? or try out the Pre / Wireless charging hack?

    Heck, Im not sure if i should even take apart my evo and see if I can fix it.

    How did it get this way? Well, having a car charger that has a Coiled cord will put some tension on it, especially if you are using it (Calls, Surfing, GPS)......

    I have had my Evo since Launch with no issues at all, till now.
     

    Advertisement
  2. jamesdean

    jamesdean Well-Known Member

    Joined:
    Nov 14, 2009
    Messages:
    633
    Likes Received:
    80
    You should be able to exchange the EVO as a defect since it is less than one year old. I would do that.
     
  3. edriggers

    edriggers Well-Known Member

    Joined:
    Jun 12, 2010
    Messages:
    179
    Likes Received:
    82
    Have you tried using a different/new micro USB cable? I was having problems with my port as well, or so I thought. It would charge okay, but the cable never felt secure when plugged into the phone. If I picked up the phone while the cable was plugged in, it would typically loose or reset the connection. I have hardware version 002 and I was dreading the day when it would finally get so bad that I would have to exchange it. As it turns out, the metal plug on the cable that came with the phone was bent every so slightly. I'm using a different cable now, and it's working better than ever.
     
  4. earlgsxbusa

    earlgsxbusa Well-Known Member This Topic's Starter

    Joined:
    May 13, 2010
    Messages:
    50
    Likes Received:
    15
    Thanks all for the answers :)
    being the Techie, I had to take it apart and take a look and low and behold, there are for pins holding the port down. The soldering points were loose and the piece feel out.

    So im going to try the sprint store and see if they can repair or replace.
     
  5. JoshUng

    JoshUng Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    202
    Likes Received:
    18
    I had this problem a week or so ago, it started out not so mad, but quickly became to the point where I had to wrap the charger wire around the phone to keep it still.

    I called Sprint, according to the one tech, they won't work on that issue in store. But of course, it is under warranty. Just go back to where you bought it, they should replace it. I did this at Radio Shack with no problems. The only downside is you may need to wait for stock.

    Of course, the tech I spoke to may just have been lazy, perhaps you'll have better luck getting a tech near you to work on the phone.
     
  6. uniquenameEVO

    uniquenameEVO Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    649
    Likes Received:
    103

    If you took yours apart that far, you messed with the tamper sticker on one of the T5 screws. Look for a tiny black sticker before you bring it in...just in case.

    I vote touchstone mod :D
     
  7. BetterMost

    BetterMost Banned

    Joined:
    Apr 25, 2010
    Messages:
    1,066
    Likes Received:
    119
    When was your handset made? Check the date stamp on the inside of the battery door. Lets track this issue. Do you have a hardware version 2 or 3 phone?
     
  8. counslr2002

    counslr2002 New Member

    Joined:
    Jun 6, 2010
    Messages:
    2
    Likes Received:
    1
    I had the same exact problem. It was the cable. The male end that plugs into the phone was bent slightly. I took it to a sprint store and they gave me a new one. Problem solved.
     
    marctronixx likes this.
  9. JoshUng

    JoshUng Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    202
    Likes Received:
    18
    As I mentioned above, I had the same problem, where it was the phone, and not the cable. I don't remember the date stamp, but it was hardware version 2. It was a launch day phone.
     
  10. BetterMost

    BetterMost Banned

    Joined:
    Apr 25, 2010
    Messages:
    1,066
    Likes Received:
    119

    Well good im glad its a version 2. Maybe they fixed the issue on the version 3s we can only hope.
     
  11. JoshUng

    JoshUng Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    202
    Likes Received:
    18
    Yes, I have a 3 now, I sure don't want to go through that again. Of course, this is only the second time I heard of somebody with this problem, and when I went Radio Shack, they say "Hmm, haven't seen that before" kind of surprised-like. Hopefully its not a hardware problem, just luck of the draw and the inevitability that some units will have a problem, even if it isn't widespread.
     
  12. aznmode

    aznmode Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    424
    Likes Received:
    38
    Mines the complete opposite. I had an 002 version that no matter what charger I use it works great. My 0003 version however with some of the same chargers when I lift the connector up it stops charging. Although the charger that came with the phone works on both phones. I noticed on those ones the micro usb connector is longer than some of my other micro usb chargers. I'd like to take it in but I know they're just gonna say to use OEM chargers.
     
  13. jamesdean

    jamesdean Well-Known Member

    Joined:
    Nov 14, 2009
    Messages:
    633
    Likes Received:
    80
    If not maybe you could just glue an o-ring around it:)
     
  14. damewolf13

    damewolf13 live~laugh~love VIP Member

    Joined:
    May 14, 2010
    Messages:
    4,087
    Likes Received:
    2,667
    If you live in a fairly large city you probably have a repair center in one of your Sprints within your city. Call around and see if that's the case, and then just take it to that Sprint, and hopefully they can repair/replace that part. I live in Tucson, and we have one here, so I assume that any city of size will have one.
     
  15. J03

    J03 Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    520
    Likes Received:
    66
    I've had this problem too. Is the htc cable just a pos? I've never had a stock cable break on me before but this one just bent slightly and stopped charging. I carry around my old pre cable with me in my pocket, work bag, car, and back to the house all the time and its still as good as new. Are these htc ones just fragile?
     
  16. JoshUng

    JoshUng Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    202
    Likes Received:
    18
    For what it's worth, the HTC cable worked for me longer thatn the iGo car charger did. At first I thought it was the car charger, because it was almost a week before I noticed the same problem with the wall charger.
     
  17. NeoEVO

    NeoEVO Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    239
    Likes Received:
    58
    My daughter had the same problem a week ago. I thought for sure it was a hardware problem since I tried the usb cable from my EVO and it was also loose on her EVO. She took it to a Sprint Corporate store, the Rep looked at it, went into a back room, gave her a new cable and it fit perfectly. Go figure ... I kinda wonder if the guy pinched the jack opening or something.
     
  18. earlgsxbusa

    earlgsxbusa Well-Known Member This Topic's Starter

    Joined:
    May 13, 2010
    Messages:
    50
    Likes Received:
    15

    i have 03
     
  19. earlgsxbusa

    earlgsxbusa Well-Known Member This Topic's Starter

    Joined:
    May 13, 2010
    Messages:
    50
    Likes Received:
    15
    Went to store and they are all on back order.

    So basiclly i just took it apart and the thing is soldered on to the board via 4 contact points. Reason I know is that as soon as i touched it, it fell off!!! SUCKS! I think its a matter of time of vibrating back and forth removing from the charger and what not that loosened the port.

    The reason I know this is that his happened to my BB Tour, but survived because the tour had charging pins in the back for the cradle. Now I wish EVO had it lolol.

    So needless to say I next ordered a charger for batteries and im going to test the induction charging tonight.
     
  20. earlgsxbusa

    earlgsxbusa Well-Known Member This Topic's Starter

    Joined:
    May 13, 2010
    Messages:
    50
    Likes Received:
    15
    BTW this forum rocks thanks for the posts and ideas!!!!
     
    marctronixx likes this.
  21. xiola

    xiola Member

    Joined:
    Nov 16, 2009
    Messages:
    21
    Likes Received:
    0
    My Hero did that same thing. My Evo sometimes will lose connection, but I bought a wall charger with extra batteries, so I try not to use the cable too much, just in case.
     

Share This Page

Loading...