1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Charging port loose.Support


  1. natorade93

    natorade93 Well-Known Member

    not sure if this is up twice, i put it up and then couldnt find it, but is anyones charger loose? the chargers not loose as far as falling out, but it wiggles back and forth from left to right. im kinda concerened itwill become a future issue and im wondering if i shud return

    Advertisement
  2. Are you talking about the charger to the phone meaning the charging cable/plug? Or are you talking about the charging port on the phone?
  3. brunocali

    brunocali Member

    My charger cord connection fits very tight to the Evo, no wiggle movement. I have to remind myself to grasp the connector part (rather than the cord itself) when disconnecting the cord.
  4. natorade93

    natorade93 Well-Known Member

    the charger going into the phone. it pushes in tight, and requires the normal pull to come out. but if i hold the piece that plugs into the phone and wiggle left and right it seems to have a little bit of movement. not sure if this is normal or not

    EDIT: it doesnt seem the inside of the phone moves though. almost as if the charger has room to turn and move inside the charging port
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    Yeah - I'm pretty sure this is how their new standardized ports are on the 2011 models - I'd guessed that this prevents the strain that caused so much Evo trouble.
  6. natorade93

    natorade93 Well-Known Member

    ok thanks! thats a relief then, i can get worried easily, but after all, im only 17 (yes im a kid rooter ;)) and so these things can get very expensive to buy new after the warrentees up haha. just making sure its alright. i checked my htc hero, its similarly loose on that one also.

    thanks for the advice
    EarlyMon likes this.
  7. tsgt2007

    tsgt2007 New Member

    The charging usb cable fits very loose on Evo 3D and I looked and the metal part of the charging port is cracked is it under warranty?
  8. natorade93

    natorade93 Well-Known Member


    Im not sure but if somethings broke in the first 30 days its worth a try to bring it back
    EarlyMon likes this.
  9. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums!

    natorade93 is right - moreso if you just got it, I have to believe that was a manufacturing defect.

    I'm trying to imagine how any user could do that.

    On the other hand - if you're referring to the three slits (one on either side, one near the center) of bottom of the piece of metal on that port, those are normal cuts provided for strain relief.
    natorade93 likes this.

Share This Page