Clock off time??


Last Updated: 2014-05-02 17:52:34
  1. bcrichster

    bcrichster Well-Known Member

    Does anyone notice their time/clock almost always wrong or constantly lagging? Mine will get upwards near 20min behind within about 48hrs... I can't really say that it IS or is-NOT ROM/Root specific cuz I rooted my phone within an hr of purchase, lol. After that I spent the next few days helping test ROMs... Any help or ideas would be greatly appreciated. Ty-

    Advertisement
  2. junkie2100

    junkie2100 Well-Known Member Developer

    not really sure, it doesnt have an internal clock... so it might just be bad signal. you ever noticed how all your backups are time coded to some random date and time in the 1970s? thats because it doesnt really keep time. now, at the same time it does have a counter it seems, just not one that runs when the phone is off or keeps the time saved, so it could also be a hardware issue. anybody not experiencing this problem wanna lock their phone in a lead box for 48 hours see if it screws up? lol
    bcrichster likes this.
  3. bcrichster

    bcrichster Well-Known Member

    Yeah.. I never EVER had this problem with the Sequent.. And my reception where I'm at is wicked good. In fact... I downloaded a 187Mb file in 5 seconds flat. No WiFi - No B.S. either. About soiled myself when I noticed it, lol. Str8 4G Lte..
  4. junkie2100

    junkie2100 Well-Known Member Developer

    yea its pretty quick, i dont think the 4g is where the time sync comes from though. the sequent had a clock that kept time built in, this one doesnt, it uses network time, and network time is usually done through the phone signal not a data connection if im not mistaken. i know my 4g here is great, almost full bars at all times, 3g is only like 2 bars most of the time, sometimes none at all if the weather is bad
  5. bcrichster

    bcrichster Well-Known Member

    For some reason the data speeds are massively slowed when I switch to Deodexed test 10 for some reason... So I go back to a certain earlier test # and my speeds go thru the ceiling again, lol.
    But anyways back to subject on hand - I have to reboot to correct my time...
  6. junkie2100

    junkie2100 Well-Known Member Developer

    sounds like a bad counter then. something is just a tiny bit off seconds maybe off by .01 which doesnt sound like much i know... but .01 seconds x 60 is over half a second off every minute, 36 seconds off an hour, 14.4 minutes off a day
  7. junkie2100

    junkie2100 Well-Known Member Developer

    and as we all know zte isnt the best at quality control so the odds of having such precise equipment be a tiny bit off are rather high
  8. bcrichster

    bcrichster Well-Known Member

    That sounds about right... Thanks junkie! :cool:
  9. bcrichster

    bcrichster Well-Known Member

    Junkie's math perception of time differential on this 4G is virtually dead-on and since ya can't just go adding time keeping hardware very easily I found a kind-of workaround for it so I can wake up on time to work everyday...

    "Auto Reboot" by Asim Pereira - extremely small apk file (90k) and no ads.. I set it to reboot @ 3am everyday so that the time differential is very minor when I wake up 2hrs later for work.. I know this isn't a perfect or permanent fix but it's better than being progressively late all the time, lol.
    jimsmith80 likes this.
  10. Wizaired

    Wizaired Well-Known Member

    I had the same issue a couple days ago, woke up thinking all the clocks in the house were wrong somehow and that my son's bus driver came too early. I soon realized my phone was about 10 mins behind. :hmmmm: kinda puzzled I naturally started looking in the options at my timezone and stuff. My timezone I think was right (gmt-4:00,Eastern Daylight Time) I switched them around and changed it right. I made sure my time was network based, played around basically and then left it alone with the correct time. The time seems to be right on but I restarted my phone earlier so we'll see. :cool:

    I know since I set my time right my phone has definitely gone 24 hours a couple times without shutting down. and I can say my time seems to be sticking. try messing with your time options like I did, just do random stuff to maybe "sync" the clock back.
  11. Wizaired

    Wizaired Well-Known Member

    Guess the bad rom files explain the weird time loss we were having:sly:

Share This Page