CM4DX Gps Fix


Last Updated:

  1. yawdapaah

    yawdapaah Well-Known Member This Topic's Starter

    Joined:
    Aug 20, 2009
    Messages:
    900
    Likes Received:
    288
    Can someone the following fix for GPS on CM4DX?

    Pull gps.shadow.so from any .596 Rom and overwrite the version in /system/lib/hw

    GPS seems to work fine with the replaced .so file. I've attached it just in case you guys don't have a Rom to pull from.

    Here's the file for those that like to do stuff themselves - gps.shadow.so
    Don't forget to change the permissions to rw-r--r-- and reboot (Thanks for the reminder Kev)

    Update:
    Here's a flashable zip file for those who are as lazy as I am - CMod7 Gps Fix. Please mount system before installing.

    GL

    Note: It seems like the location service problems are a know issue the recent Cmod builds. If so, I'm confident it'll be taken care of by the time the build goes "stable".
     

    Advertisement
  2. Airmaxx23

    Airmaxx23 Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    3,142
    Likes Received:
    1,039
    I'm trying it now, I'll report back afterwards.
     
  3. Kevmueller

    Kevmueller Well-Known Member

    Joined:
    Aug 3, 2010
    Messages:
    766
    Likes Received:
    145
    Quick question as I am trying this, did you change your permissions to the rw-r--r-- to match the other files in there? Did you reboot as well after this was done? I did both of these so I wanted to make sure.
     
    yawdapaah likes this.
  4. yawdapaah

    yawdapaah Well-Known Member This Topic's Starter

    Joined:
    Aug 20, 2009
    Messages:
    900
    Likes Received:
    288
    Yes, I always do both. I thought that was standard. I'll add it to the OP.
     
    Kevmueller likes this.
  5. Kevmueller

    Kevmueller Well-Known Member

    Joined:
    Aug 3, 2010
    Messages:
    766
    Likes Received:
    145
    You are my hero!!!!! I was able to get in to maps and it found me with in a couple of seconds. Also on the toolbar the GPS icon showed up when it was searching and had a lock. I will have to give the navigation a try at lunch.
     
  6. Kevmueller

    Kevmueller Well-Known Member

    Joined:
    Aug 3, 2010
    Messages:
    766
    Likes Received:
    145
    It is for me, but I am thinking that since this will be a huge fix for many that there may be some people doing something like this for the first time. This was a great idea!
     
  7. Airmaxx23

    Airmaxx23 Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    3,142
    Likes Received:
    1,039
    I can confirm that this works, GPS Test is picking up lots of satellites when before it would not find any.
     
    yawdapaah likes this.
  8. keegan1014

    keegan1014 Well-Known Member

    Joined:
    Apr 27, 2010
    Messages:
    431
    Likes Received:
    72
    Can you guys step me threw this changeing permissions
     
  9. Airmaxx23

    Airmaxx23 Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    3,142
    Likes Received:
    1,039

    Long press on the file and select permissions, then change them to:

    Owner: read, write
    Group: read
    Others: read

    Then just reboot the phone.
     
  10. PlayfulGod

    PlayfulGod Well-Known Member Developer

    Joined:
    Jan 28, 2011
    Messages:
    8,109
    Likes Received:
    4,938
    umm wonder if sumtin similar would work for the camera?
     
  11. Flying_Hellfish

    Flying_Hellfish Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    612
    Likes Received:
    65
    Fantastic, thank you so much! I cross linked to this thread from RootzWiki, hope you don't mind. :D
     
  12. yawdapaah

    yawdapaah Well-Known Member This Topic's Starter

    Joined:
    Aug 20, 2009
    Messages:
    900
    Likes Received:
    288
    Do not mind at all. I should really have posted there. :p
    Also, I don't want to clutter the forums with a small thread like this.
     
  13. JrzDroid

    JrzDroid Well-Known Member

    Joined:
    Nov 30, 2009
    Messages:
    1,682
    Likes Received:
    308
    now that GPS has a fix, all I need is camera back and I'm making the cm7 jump!
     
  14. keegan1014

    keegan1014 Well-Known Member

    Joined:
    Apr 27, 2010
    Messages:
    431
    Likes Received:
    72


    In file manager? I tried long press and didn't get any fix permissions, I am new please don't roast me
     
  15. Slomies

    Slomies Member

    Joined:
    Oct 26, 2010
    Messages:
    19
    Likes Received:
    1
    Thank you for the GPS fix! I can deal with not having a camera for now. However, would it be possible to just copy over file(s) like this for the camera to get it working?
     
  16. yawdapaah

    yawdapaah Well-Known Member This Topic's Starter

    Joined:
    Aug 20, 2009
    Messages:
    900
    Likes Received:
    288
    Do you have root explorer? Try using that or a free alternative. I think Yaffs or Astro let you do it.
     
  17. Airmaxx23

    Airmaxx23 Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    3,142
    Likes Received:
    1,039
    Try using Root Explorer.
     
  18. androy

    androy Well-Known Member

    Joined:
    Apr 20, 2010
    Messages:
    308
    Likes Received:
    46
    Nice find!! Looks like I'll be jumping ship soon too!
     
  19. keegan1014

    keegan1014 Well-Known Member

    Joined:
    Apr 27, 2010
    Messages:
    431
    Likes Received:
    72
    Ok I don't get it tried it in file manager and can't change permissions, I am new at things please help.
     
  20. Trooper

    Trooper Well-Known Member

    Joined:
    Apr 11, 2010
    Messages:
    3,715
    Likes Received:
    541
    Same here man.
     
  21. Airmaxx23

    Airmaxx23 Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    3,142
    Likes Received:
    1,039
  22. Airmaxx23

    Airmaxx23 Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    3,142
    Likes Received:
    1,039
    File Manager won't let you change permissions, try root explorer.
     
  23. yawdapaah

    yawdapaah Well-Known Member This Topic's Starter

    Joined:
    Aug 20, 2009
    Messages:
    900
    Likes Received:
    288
    1. Download Yaffs file manager from the market.
    2. Navigate to /system/lib/hw
    3. Long press gps.shadow.so
    4. Select Permissions (you'll have to grant root access)
    5. Select the check the first three boxes on the first row.
    6. Check the left most box on the second row.
    7. Uncheck every other box.
    8. Reboot phone.

    GL
     
  24. sic0048

    sic0048 Well-Known Member

    Joined:
    Jun 22, 2010
    Messages:
    545
    Likes Received:
    52
    Seems to fix GPS - at least for maps and navigation which is 99.9% of what I use GPS for. Sweet fix! Thanks a lot!
     
  25. keegan1014

    keegan1014 Well-Known Member

    Joined:
    Apr 27, 2010
    Messages:
    431
    Likes Received:
    72
    Out won't let me change then in root explore
     

Share This Page

Loading...