CM7 Project for LG Ignite AS855


Last Updated: 2012-04-24 05:53:31
  1. Craptorman

    Craptorman Well-Known Member

    I have started working on building CM7 for the Ignite. Still really new at this and still running into errors. My repo is https://github.com/Craptorman

    If anyone want's to help out with project feel free.:D

    Advertisement
  2. Craptorman

    Craptorman Well-Known Member

  3. D-U-R-X

    D-U-R-X turbo drinker Moderator

  4. PlayfulGod

    PlayfulGod Well-Known Member Developer

  5. Craptorman

    Craptorman Well-Known Member

    Build enviroment got hosed up for some reason. Wiped everything out and started from scratch. Now I can't get any project to even start building. Keep getting "brunch: command not found" not matter what I do. I don't see the function brunch() in envsetup.sh. About ready to throw in the towel.
  6. Craptorman

    Craptorman Well-Known Member

    Well, I've put a hold on building from source and tried my luck at porting the LG Black P970's CM7 to the Ignite.

    Finally got it to boot into the home screen. However:

    No sound. (ALSA Module not found!!!)
    Wifi can see networks but reboots when trying to connect.
    With wifi off it rarely reboots.
    USB works, mounts SD Card, adb works.
    Camera locks up when you take a pick.
    Phone doesn't work - Anyone know of all the radio files that need to be inplace? The Black is GSM and Ignite is CDMA.

    Now to dig thru logcat output to see what I can find.
  7. Craptorman

    Craptorman Well-Known Member

    @Playful
    Ok, I commented out:
    BOARD_CAMERA_LIBRARIES := libcamera

    The camera libs and wpa_supplicant files are pulled from phone, the setup-makefiles.sh is updated and builds ignite-vendor-blobs.mk like it should.

    Is the above what you meant when you say use the camera libs and wpa_suppilcant from the stock rom?

    I notice this at the very start of the build. Not sure if this is right or not.
    Code (Text):
    1. build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/lib/hw/lights.omap3.so'
    2. build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/lib/hw/lights.omap3.so'
    3. build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/bin/rild'
    4. build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/bin/rild'
    5. build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/lib/libril.so'
    6. build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/lib/libril.so'
    7. build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/bin/wpa_supplicant'
    8. build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/bin/wpa_supplicant'
    9. build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/obj/lib/libcamera.so'
    10. build/core/dynamic_binary.mk:141: warning: ignoring old commands for target `out/target/product/ignite/obj/lib/libcamera.so'
    11. build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/lib/libcamera.so'
    12. build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/lib/libcamera.so'
    13.  
    Here's the error it stops on now:
    Code (Text):
    1. make: *** No rule to make target `out/target/product/ignite/obj/lib/libicapture.so', needed by `out/target/product/ignite/obj/SHARED_LIBRARIES/libcamera_intermediates/LINKED/libcamera.so'.  Stop.
    2.  
    Edit: I believe I figured this out.:D

    Now I'm back at the same error/errors prior to the changes above. Don't think I actually did what you asked.:confused:
    Code (Text):
    1. make: *** [out/target/product/ignite/obj/SHARED_LIBRARIES/libcamera_intermediates/CameraHal.o] Error 1
    2. make: *** Waiting for unfinished jobs....
    3. hardware/ti/omap3/camera-omap3/CameraHal_Utils.cpp:1201: error: 'IPP_ProcessImage' was not declared in this scope
    4. hardware/ti/omap3/camera-omap3/CameraHal_Utils.cpp:1208: error: 'struct android::OMX_IPP' has no member named 'hIPP'
    5. hardware/ti/omap3/camera-omap3/CameraHal_Utils.cpp:1208: error: 'IPP_StopProcessing' was not declared in this scope
    6. make: *** [out/target/product/ignite/obj/SHARED_LIBRARIES/libcamera_intermediates/CameraHal_Utils.o] Error 1
    7.  
  8. Craptorman

    Craptorman Well-Known Member

    Update. Got it to build from sources now and boots fine. Wifi is now working! Still no audio or bluetooth. Camera FC's. I guess that's progress.:D

    Ok now have audio working. Getting constant sensor errors. Still can't get Phone to work. Anyone have any ideas on what to check to get phone working?

Share This Page