cm7 wifi issue


  1. BILL88STANG

    BILL88STANG Well-Known Member

    i just flashed the latest cm7 build it all looks great, the wifi seems to go on and off every few seconds on its own has anyone run into this yet?

    Advertisement
    :
  2. nuttmeg

    nuttmeg Well-Known Member


    nope havnt had a problem, might want to put it ijn airplane mode for a minute, and afterwards try it...might want to restart your phone also.
  3. Darkd10

    Darkd10 Well-Known Member

    Yeah, I get wifi problems with CM7 as well. Not as much with the latest build, but still some issues.

    I flashed back to icarus for stability though.
  4. BILL88STANG

    BILL88STANG Well-Known Member

    ill try the air plane mode idea, everything went fine without a hitch even with the old 2.xxxx cmr. no issues except wifi
  5. PlayfulGod

    PlayfulGod Well-Known Member Developer

    not had any issues with mine.
  6. Lennatron

    Lennatron Well-Known Member

    I don't have WiFi issues either. However I have found that whenever 3G Data, WiFi, or any other wireless connections turning on airplane on and then off as PlayfulGod mentioned usually works for me.
  7. jabbawest

    jabbawest Well-Known Member

    Not sure if this applies to your issue but, after I installed CM7 I was surprised to find out that the MAC address for the phone had been changed.
    I couldn't figure out why the heck I couldn't connect to my LAN after installing CM7, the WiFi kept Scanning, Connecting and Disconnecting. My LAN is secured by MAC filtering which only allows MAC addresses I specify to connect.
    After about an hour, I finally compared the old MAC address filter entry for the phone to the after CM7 MAC address on the phone, sure nuff it had changed.
    DarkenV likes this.
  8. nuttmeg

    nuttmeg Well-Known Member


    yeah there was a mac change in new build cause alot of peoples had problems connecting to wifi...
  9. xAnthonyx123

    xAnthonyx123 New Member

    I'm Having The Same Issue. Though, I Don't Know How To Fix It. A Little Help Would Be Greatly Appreciated. Afterall, I Like I Really Seem To Like CM7, But This Issue Is A Real Turn Off.
  10. Mferrill

    Mferrill Active Member

    Same here. Goes out about every 30 sec. Tried Airplane on/off. Rebooting. Nothing helps so far.
  11. nuttmeg

    nuttmeg Well-Known Member


    what build are you on...you can also try fixing permission, tho it might not help, but when you flash cm7 did you format boot,system,data,cache?
  12. Mferrill

    Mferrill Active Member

    Mod Version:
    Cm7 - Ascend - 05212011
    Build Number
    GRj22.

    Still the same after Fixing permissions.

    I have a few days off so, I'm gonna flash back to Stock tomorrow, and try again. That failing, maybe even play around with CM6, see if that is more friendly towards my particular phone.

    Either way, still having a lotta fun with all this..:) It's like having a brand new phone every few days, lol.
  13. nuttmeg

    nuttmeg Well-Known Member

    download the newest build from wiki the link is in my siggy, and yes play around with all roms to see what you like best...new phone every other day for me!!! lol
    Mferrill likes this.
  14. Mferrill

    Mferrill Active Member

    Ya, flashed Cm6 (all 3 launcher versions) and played around with them most of the morning. I dunno why, but for some reason, they just seem a little clunky to me in comparison to CM7. (No offense to the people that put all that hard work and effort into them.) Probably just me, just like the feel of the other better.

    I can deal w no MMS Video, but not w/o WiFi, so I think I"ll just stick to CM7 - 05142011 for now, and wait a new version that doesn't hate my phone so much..:p
  15. nuttmeg

    nuttmeg Well-Known Member

    yes cm7 is a keeper for me...but you can always make a backup and try the new build, but stick to what works best!!! and again if you run into any trouble, dont hesitate to ask, we all here to help!!!;)
  16. Stikman

    Stikman Well-Known Member

    i just flashed to cm7 05212011 and now my wifi is screwed up too!:(
  17. nuttmeg

    nuttmeg Well-Known Member

    go to settings/wireless & networks tap wifi on and off and see if it fixes it, if not try airplane mode for a few sec and turn it off.
    igibi011 likes this.
  18. Stikman

    Stikman Well-Known Member

    nope doesnt work still does it:(

    EDIT: i just flashed back to 05072011 and the wifi is perfect so ill just stick with this version until that problem is fixed :D
    twstde likes this.
  19. jisep32

    jisep32 Member

    Same Wifi issue. Clean flash from 05142011 to 05212011, Wifi started coming in and out. Flashed back to 05142011....No more Wifi issue. Metro user.
  20. Mferrill

    Mferrill Active Member

    Ok, I found a temporary fix for this. It's not Ideal because you have to do it for each Wifi Network you connect to. But if you must have the new build, and don't want your wifi dropping in and out, here ya go.

    Download Wifi Buddy (free on android market.) I'm sure there are other programs you can use, but this is the one I know.

    Download Gtech Net Tools (Again Free on Market).

    Enable your wifi like usual.

    Go into Gtech, Click IP Config. Click Wifi, and write down all your settings while it's still connected. If it drops out while your doing this, just refresh when it connects again.

    Write down your connected/IP, Subnet Mask, Gateway, and DNS Server.

    Exit, and open Wifi Buddy.
    Click preferances, Wifi Networks, Hit your Menu Button, Click advanced.
    Goto Use Static IP, and plug in the info you wrote down from Gtech.
    (Netmask = Subnet Mask)

    Arrow back once the info is in place, and connect to your Wifi.

    It'll Stay stable, and no longer keep dropping, and reobtaining your Wifi.

    For any new connections, rinse and repeat.

    Cheers :)
  21. DarkenV

    DarkenV New Member

    Solved it!

    Found out the problem is caused by the router which I've allocated spefic IP for the device's MAC adress.

    Try cleaning the MAC address from the reserved IP address for your device and let the DHCP give it a leased IP and not a manual one.

    If it works.. I'm happy for you :)
  22. jayteestarr

    jayteestarr New Member

    Hi! I've been reading these forums for a while, but this is my first post... Unfortunately, like many others, I'm forced to post because I broke something, lol. Here's the deets...

    I have a MetroPCS Huawei Ascend, and it has worked since I got it in March. I found out what rooting and tethering did, and after a little trial and error I was rooted and using my 1x wifi like a pro! ("Error" meaning I deleted my gtalk and had to go through the headache of getting it back) Then, one night, all my dreams were shattered... I had my tethering connected and the phone plugged in (and running at a cool 65 degrees, because I set it up directly in from of the air conditioner vent), but I had accidentally turned off the power strip. So, the phone died. When I noticed, I simply turned on strip again and started it back up.

    When I started Wifi Tethering again, it said it had encountered errors, and the log said Wifi Driver failed, Ad-hoc failed, and like 3 others. Then I noticed that the phone could not connect to external Wifi, and the menu option was greyed out and says "Unable to start Wi-fi." I still had phone service and could browse on the in phone browser.

    Other posts said uninstalling Wifi Tethering fixed their problem, but to no avail for me. Next, I tried rebooting a few time, but no dice. Then I tried a factory reset, but that didn't work either.

    In the next phase of my adventure, I thought a complete wipe and new OS could fix it. I did a lot of research and decided iCarus sounded most like what I was looking for, something simple and fast. So, I installed it using the awesome instructions on this forum. (Must love to isaacj87) iCarus started up and worked like a dream, BUT in the wireless menu it still said "Unable to start Wi-fi!" I was flustered and flabberghasted.

    Tonight I did a fastboot recovery all the way to stock with the damn bloatware and everything and STILL can't get my wifi back on... So here I am, begging you guys for help. Please let me know if you need anymore info from me to help you figure this out! I've read SO many posts related to this and not one gave an answer that fixed my problem.
  23. Kingdrew

    Kingdrew Active Member

    How would I go bout doing this
  24. Kingdrew

    Kingdrew Active Member

    My phone keeps connecting.. connects
    then dissconects and scans again, it keeps repeating that process
  25. nuttmeg

    nuttmeg Well-Known Member


    tap your wifi connection and tap forget, than retry to connect again, and also you may need to reset your router, that usually works also, btw what build are you on?
Loading...

Share This Page