1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

CM9 for Warp Development thread


  1. hroark13

    hroark13 Well-Known Member Developer

    Rally 517, DragonDGG and Spiyder like this.
  2. DragonDGG

    DragonDGG Well-Known Member

  3. hroark13

    hroark13 Well-Known Member Developer

  4. hroark13

    hroark13 Well-Known Member Developer

    I just realized that I have been building with the CyanogenMod ics branch, and not the cm-9.0.0 branch

    I have updated the instructions in the OP, sorry everyone

    there was a commit that seems to have broken the build process, but I fixed the files, and will add them to github soon


    I am wondering if anyone here is even trying to build this, it does not seem to caught too many peoples interest
  5. QuietStorm1785

    QuietStorm1785 Well-Known Member


    bah now i gotta redownload... -_-..... ima try with the cm9.0 branch anywho, see what comes. redownloading the source takes too long and i gotta work in 2 hours... and yes, im trying to build, sorry for not replying. The only issues i was getting during build process on cm 9.0.0 branch was it needing kernel and auto.conf. was an easy fix
  6. hroark13

    hroark13 Well-Known Member Developer


    I did a repo sync today, and then my builds stopped working

    after some research, I figured out that it was this commit that messed me up

    https://github.com/CyanogenMod/andr...mmit/0853b3970b9ba809d615f1d3ae27d28651847300


    then I realized, that I was using ics branch and I was like oops
  7. hroark13

    hroark13 Well-Known Member Developer


    Im gonna download the cm-9.0.0 branch and see how that works for me
  8. QuietStorm1785

    QuietStorm1785 Well-Known Member

    well, the cm9.0.0 branch works great for me, can call people, they can hear me, and i think I can figure out whats wrong with the zte ril. I just need time to debug the radio and see where data fails. freaking work tho man... I get off at 3 pm today, soo i'll see what I can do then... on another note.... CM9 IS FREAKING SEXY... i love the sleek interface, it looks soo sweet on the warp... the prevail didnt do cm9 justice... too small...
    prmax and Rally 517 like this.
  9. joestone

    joestone Member

    Maybe you can try to build with :
    BOARD_USES_HC_RADIO := true
    QuietStorm1785 and hroark13 like this.
  10. Rally 517

    Rally 517 Well-Known Member

    Man i truely appreciate the work u guys and or gals r doing. Wish i could build dint have knowledge or the equipment . In just the pig sorta speak. Guiny that is. Thanks is not enough for yall.
  11. downthemachine

    downthemachine Developer Incognito VIP Member

    @hroark, just as a warning, when you are in settings for mobile network /cdma subscriptions, it says ruim or nv, do not touch those settings, it wiped my nam, and I had to manually reprogram it with cdma workshop. Damn near had a heart attack when it happened. Just a heads up
  12. downthemachine

    downthemachine Developer Incognito VIP Member

    Maybe update the OP as a warning
  13. joestone

    joestone Member

    You can try this for camera :
    https://github.com/rapmv78/android_hardware_qcom_camerahal
    Link against libcamera.so , on the tab it detects both camera , but in the framework need some modification.

    mod in android.mk
    #ifeq ($(LIBCAMERA_BUILD),nexus)
    CAMERA_LIB := libcamera.so
    #endif
    TARGET_GLOBAL_LD_DIRS += -L$(LOCAL_PATH) -l$(ANDROID_PRODUCT_OUT)/obj/lib/${CAMERA_LIB}
    hroark13 and DragonDGG like this.
  14. hroark13

    hroark13 Well-Known Member Developer


    hmmm, sorry about that, I wonder if there is a way we can hide that menu
  15. hroark13

    hroark13 Well-Known Member Developer


    I put a warning in the second post near the download link
  16. hroark13

    hroark13 Well-Known Member Developer


    I am getting this if I use my stock GB ROM libcamera.so, libmmjpeg.so, and liboemcamera.so, but the phone boots


    Code (Text):
    I/CameraService(  104): CameraService started (pid=104)

    E/HAL     (  104): load: module=/system/lib/hw/camera.msm7x30.so

    E/HAL     (  104): Cannot load library: link_image[1965]:   104 could not load needed library 'libcamera.so' for 'camera.msm7x30.so' (reloc_library[1314]:   104 cannot locate '_ZN7android7Overlay5setFdEi'...

    E/HAL     (  104): )

    E/CameraService(  104): Could not load camera HAL module





    I tried using the libcamera.so, libmmjpeg.so, and liboemcamera.so from your cm9_v55_0522 and I get this, and phone does not boot

    Code (Text):
    I/CameraService(  104): CameraService started (pid=104)

    E/CameraHAL(  104): CameraHAL_GetNum_Cameras:

    D/CameraHAL(  104): CameraHAL_GetNum_Cameras: loading libcamera at 0xb000e9c4

    I/QualcommCameraHardware(  104): getCameraInfo: IN

    F/libc    (  104): Fatal signal 7 (SIGBUS) at 0x40fc514c (code=2)

    I/DEBUG   (   96): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***

    I/DEBUG   (   96): Build fingerprint: 'ZTE/ZTE_arthur/arthur:4.0.4/IMM76I/eng.hroark13.20120602.111253:userdebug/test-keys'

    I/DEBUG   (   96): pid: 104, tid: 104  >>> /system/bin/mediaserver <<<

    I/DEBUG   (   96): signal 7 (SIGBUS), code 2 (BUS_ADRERR), fault addr 40fc514c

    I/DEBUG   (   96):  r0 40fc514c  r1 00000000  r2 00000eb4  r3 14c00000

    I/DEBUG   (   96):  r4 b000ebf4  r5 b001301c  r6 40fc4000  r7 40fc4000

    I/DEBUG   (   96):  r8 b0012fa8  r9 0000114c  10 0006d000  fp 40f57000

    I/DEBUG   (   96):  ip 0000001d  sp be8846b4  lr b0004fd5  pc b0001458  cpsr 200f0010

    I/DEBUG   (   96):  d0  0000000000000000  d1  0000000000000000

    I/DEBUG   (   96):  d2  0000000000000000  d3  0000000000000000

    I/DEBUG   (   96):  d4  0000000000000000  d5  0000000000000000

    I/DEBUG   (   96):  d6  0000000000000000  d7  0000000700000000

    I/DEBUG   (   96):  d8  0000000000000000  d9  0000000000000000

    I/DEBUG   (   96):  d10 0000000000000000  d11 0000000000000000

    I/DEBUG   (   96):  d12 0000000000000000  d13 0000000000000000

    I/DEBUG   (   96):  d14 0000000000000000  d15 0000000000000000

    I/DEBUG   (   96):  d16 6b6565736c203a5d  d17 656c696166202928

    I/DEBUG   (   96):  d18 419b998d98000000  d19 0000000000000000

    I/DEBUG   (   96):  d20 0000000000000000  d21 0000000000000000

    I/DEBUG   (   96):  d22 0000000000000000  d23 0000000000000000

    I/DEBUG   (   96):  d24 0000000000000000  d25 0000000000000000

    I/DEBUG   (   96):  d26 0000000000000000  d27 0000000000000000

    I/DEBUG   (   96):  d28 0000000000000000  d29 0000000000000000

    I/DEBUG   (   96):  d30 0000000000000000  d31 0000000000000000

    I/DEBUG   (   96):  scr 00000010
  17. joestone

    joestone Member

    You should use your libcamera.so and liboemcamera.so from stock GB rom.
    It needs some more libs :
    PRODUCT_COPY_FILES += \
    device/zte/smarttab_common/proprietary/lib/libmmipl.so:system/lib/libmmipl.so \
    device/zte/smarttab_common/proprietary/lib/libmmjpeg.so:system/lib/libmmjpeg.so \
    device/zte/smarttab_common/proprietary/lib/libmmjpeg.so:eek:bj/lib/libmmjpeg.so \
    device/zte/smarttab_common/proprietary/lib/liboemcamera.so:eek:bj/lib/liboemcamera.so \
    device/zte/smarttab_common/proprietary/lib/liboemcamera.so:system/lib/liboemcamera.so \
    device/zte/smarttab_common/proprietary/lib/libgemini.so:system/lib/libgemini.so \
    device/zte/smarttab_common/proprietary/lib/libmmmpo.so:system/lib/libmmmpo.so \
    device/zte/smarttab_common/proprietary/bin/mm-qcamera-daemon:system/bin/mm-qcamera-daemon \
    device/zte/smarttab_common/proprietary/lib/libcamera.so:system/lib/libcamera.so \
    device/zte/smarttab_common/proprietary/lib/libcamera.so:eek:bj/lib/libcamera.so \

    also these files should be needed from /system/bin:
    v4l2-qcamera-app
    mm-qcamera-daemon
    mm-qcamera-test
    mm-mpo-enc-test
    hroark13 likes this.
  18. hroark13

    hroark13 Well-Known Member Developer

    from stock GB rom I have pushed to lib
    libcamera.so, libgemini.so, libmmipl.so, libmmjpeg.so, liboemcamera.so,

    to bin
    mm-qcamera-test, mm-qcamera-testsuite-client

    and still get the
    cannot locate '_ZN7android7Overlay5setFdEi'.

    my stock GB ROM does not have libmmmpo.so, mm-qcamera-daemon, v4l2-qcamera-app, or mm-mpo-enc-test








    .
  19. joestone

    joestone Member

    does overlay and hwaccel turned on in boardconfig ?
    At least this patch should show it finds the camera .
    hroark13 likes this.
  20. hroark13

    hroark13 Well-Known Member Developer

  21. joestone

    joestone Member

    hroark13 likes this.
  22. hroark13

    hroark13 Well-Known Member Developer


    I dont have the libqcomui for some reason, I do have the rest of them


    the stock GB does not have libQcomUI.so, but I do have a prebuilt one that I got from the CAF ROM I have made
  23. joestone

    joestone Member

    These libs should be compiled with CM9 . Add them to product packages in device config makefile.
  24. hroark13

    hroark13 Well-Known Member Developer


    wait, sorry, I do have that file
  25. hroark13

    hroark13 Well-Known Member Developer


    I was using adb shell to look for the file and since the file had a capital letter in it, it was not where I expected it, but when I scrolled up I did see it

    sorry about that
Loading...

Share This Page