CM9 Wi-fi issuesSupport


Last Updated:

  1. sleepingseason

    sleepingseason Well-Known Member

    Does anybody have any insight as to why my wifi runs slowly when I use Android on my TP? I'm running CM9, Alpha 2, but IIRC the issue has been there since I was using CM7. Browsing's not too bad now for some reason, but market downloads, ReadItLater and Dropbox are all pretty sluggish (dial-up type speeds).

    Advertisement
  2. colchiro

    colchiro Well-Known Member

    Wifi runs slowly for just your TP or all devices using it?

    Have you tried Speedtest?
  3. sleepingseason

    sleepingseason Well-Known Member

    Just the TP - my laptop, netbook and HTC Sensation all run fine on my network. Haven't tried speedtest.
  4. sleepingseason

    sleepingseason Well-Known Member

    Just ran speedtest on my TP: ping was 94ms, download was 86kbps, while upload was 1161 kbps.
    For comparison, I ran it on my HTC Sensation immediately afterwards, using the same connection, and got a 59ms ping, 1156kbps download speed and 900kbps upload speed.
  5. colchiro

    colchiro Well-Known Member

    sleepingseason likes this.
  6. sleepingseason

    sleepingseason Well-Known Member

    I flashed the nightly and did 5 tests:

    Download (in kbps) - 77, 102,76, 248, 34
    Upload (in kbps) - 1229, 1231, 1125, 1182, 79
    Pings - 60, 74, 57, 68, 59

    Those results are in reverse chronological order - I wonder what got me that 248 reading.
  7. colchiro

    colchiro Well-Known Member

    Did you flash the nightly? or the patch I sent in the link?

    They are completely different. The nightly build is the latest version of CM9, where the link I sent was just a wireless patch from Sullins.

    EDIT: I moved this to it's own thread. :D

    When you updated to CM9, did you wipe data (ie factory reset)?
  8. Cashmachine

    Cashmachine New Member

    Registered just to post this in the hopes your issue can be solved.

    I had the same problem. I use my TouchPad almost exclusively at home, on my own private network, through an ASUS Wireless-N router running DD-WRT.

    Since installing Android [specifically CM9's 3/29 official nightly], I was consistently getting dial-up speeds while all other devices in the house screamed.

    I searched for days for an answer, installed alternative wifi drivers, tried FXR Wifi from the Market, and nothing helped or hurt the situation. For consistency, I restored back to original nandroids after each attempted fix.

    What finally DID work, and was suggested for a similar but unrelated problem on a different site, was changing my router's network mode from "Mixed" to "BG-Mixed." Suddenly, even though I had ostensibly disabled the faster Wireless-N protocol, my CM9 TouchPad boasted near-instant page loads across all apps.

    The best part is that I have since restored the router to "Mixed" [i.e. reactivated Wireless-N], and the high speeds remain. Apparently performing this momentary switch was the toilet handle-jiggling that this problem needed.

    Good luck, OP.

Share This Page