Coby Kyros MID9742Support

Last Updated:

  1. SonySony

    SonySony Well-Known Member

    ----- THIS FIX DID NOT WORK ----
    BusyBox doesnt seem to be comunicating with Superuser and Root Explorer

    Try to download the app "BusyBox Installer"
    Download BusyBox Installer,BusyBox Installer 2.0 Android download |
    And install BusyBox to the /System/xbin Folder,
    Restart Tablet RootExplorer and see if anything changes.

    If no changes, try to reinstall the SuperUser App
    Then Restart tablet and open RootExplorer Again. ???? Any Changes

    Finally, if all else fails
    Download and Reinstall RootExplorer from here:
    See if anything changes

  2. SoCoolAZ

    SoCoolAZ Member

    returned this evening, looking at the Asus Transformer tabs...I'd pay an extra $ 180 not to fugh with it...

  3. SonySony

    SonySony Well-Known Member

    Give the Samsung Galaxy Tab2 a try first. $249 Just try it?

    ALSO: The new ASUS Transformer TF300 sellling on Amazon for $393
    Try the Tab2 first.
  4. stef234237

    stef234237 Active Member

    downloaded busy box but when i try to move it says the it is a bad zip file tried it several times tried taking existing busy box and moving to xbin . but it says your phone isnt rooted
  5. SonySony

    SonySony Well-Known Member

    Well that settles the notion that the Coby ICS Tabs (Allwinner A10) are Pre-Rooted when shipped.
    It seems that most solutions require rooting. While there are some rooting scripts out there, none seem to be stable (each has some residual problems). Too Risky. May Brick Tablet.
    That might not be a problem if we could figure out how to get the Coby ICS Tabs (Allwinner A10) into Recovery Mode in order to revert back to the original if the rooting goes bad.
    Ill keep trying to find out how to put the Coby ICS Tabs (Allwinner A10) into Revovery Mode OR find a stable Rooting solution.

    I found this site with some more information on Allwinner A10 tablets:
    Allwinner A10 General FAQ (non tablet specific)

    ----- THIS FIX DID NOT WORK ----


    When Using This MID9742 FORUM START: HERE
    Then find the right thread
  6. stef234237

    stef234237 Active Member

    Well dang the devil. I might just have to return it and get something else. I hate that its really a cool tablet .
  7. SonySony

    SonySony Well-Known Member

    Please hold on as long as you can. This appears to be a really good tablet and a great price. I'm willing to keep trying, if you are willing to hold up before you return.
    How much time to you have before you have to Return?
  8. stef234237

    stef234237 Active Member

    may 25th is last day through amazon ...

    Id rather not send it back. I like it. I just hate the restraits google places on Coby
  9. Fors78

    Fors78 New Member

    Hi all, new here. Was thinking of picking up one of these tablets but doing research to see if I can get google play first. I found this article. It may help some of you get it working, let me know if it does! Also has anyone played netflix on this tablet, does it play well?
  10. Fors78

    Fors78 New Member

    mugso1 likes this.
  11. SonySony

    SonySony Well-Known Member

    Your link refers to a generic process for Coby Tabs that exixted before the new Ice Cream Sandwich _ _42 Tablets. The only reply says that process did not work. I would not try it.
    Also, on the first page of this thread, HexDogbone, said the z4root did not work on the Mid9742.
  12. Fors78

    Fors78 New Member

    I found this on another forum, about getting the tablet into recovery mode.

    "I also am having trouble with google play.
    Managed to get tablet into recovery mode while plugged in. Any way to root it from there?

    Hold volume up button and home button while pressing down power on, released on coby splash screen."
  13. SonySony

    SonySony Well-Known Member

    Some older (pre-ice cream sandwich) tablets had physical buttons for Home, Menu, Back. The MID9742 has Back, Vol & Power buttons. So that older recovery method wont work --no physical Home button.
    -------------------- Try This :
    Press and hold .. Back, Power & VolUp for 15 seconds. Recovery mode?
    Press and hold .. Back, Power & VolDown for 15 seconds. Recovery mode?
    Other combinations ???
  14. cyrius

    cyrius Member

    I created a new thread about 9742 boot issue... my tablet seems to be dead : do you think there is a way to get out this state ? is it possible to boot from a external sdcard ?
  15. SonySony

    SonySony Well-Known Member

    @Cyrius --- Call or email Coby to ask how to Revive your dead MID9742. 877-302-2629 or 800-727-3592 --- EMAIL:
  16. Fors78

    Fors78 New Member

    Hmmm odd. I don't actually have the tablet yet as I am waiting to buy it if it's able to get playstore working. Anyways the thread I got that from is here, and he says it was for the MID7042. I assumed the MID 9742 would be the same just with a bigger screen.
    How To Roor Android 4.0.3 Ice Cream Sandwich? - xda-developers
  17. SonySony

    SonySony Well-Known Member

    @Fors78 -- The person doesnt actually mention the tablet name in his/her response. The MID7042 does not have a Home button. See Manual . Only Pwr, Vol & Back buttons.
  18. SonySony

    SonySony Well-Known Member

    Test To Figure Out How To Place MID9742 or MID7042 Into RECOVERY MODE.

    @stef234237 and @cyrius and Others -- TRY THIS on MID9742: (Turn Tablet Off First)
    1) Press and Hold.. VolumeUp & Back button ...
    2) while still holding above .... Then Press & Hold Power button.
    3) When COBY Splash Screen shows, Release all buttons. .... Are you in Recovery Mode ???
    (Try other combinations -- But you must PressHold Power Button LAST)

    Please post your results. Does any button combination work? ???
  19. stef234237

    stef234237 Active Member

    tried it several times volume up and down with above doesnt do anything
  20. huangm777

    huangm777 New Member

    I got recovery mode to work! The button sequence is as described (volume up + back, whilst holding down power until Coby logo shows up).

    Here's a screenshot for proof:


    Hopefully now we can proceed!

  21. huangm777

    huangm777 New Member

    Netflix does work. Until Google Play works, what you can do is email the APK for the Amazon App Store to yourself. The Amazon App Store contains Netflix and lots of other common apps, though of course the Google Apps are missing, as well as Facebook and a number of big ones. But I was able to pick up 80% of what I needed through there.

    Good luck!

  22. stef234237

    stef234237 Active Member

    i got it to work finally
  23. SonySony

    SonySony Well-Known Member

    WOW --- Can't Believe Something Finally Worked. Great News
    Thank You for hanging in there While I came up with all those Crazy ideas.
  24. SonySony

    SonySony Well-Known Member

    Turn the MID9742 Off before you try this procedure:

    1) Press and Hold.. VolumeUp & Back button ...
    2) While still holding above .... Press & Hold Power button. (20 Seconds)
    3) When COBY Splash Screen shows, Release all buttons. .... You are in Recovery Mode

    REMEMBER: you must PressHold Power Button LAST)

    You will see the following Menu:

    Android system recovery -- Android system recovery utility

    - Apply update from external storage
    - wipe data/factory reset
    - wipe cache partition
    - apply update from cache

    The 2nd option (wipe data/factory reset) should restore to factory condition.

  25. SonySony

    SonySony Well-Known Member

    How To ReBirth your Bricked Coby Tablet: MID9742

    @cyrius --- Hopefully, you can Use precedure Above to Un-Brick your Coby Tablet ( MID9742.)
    (You Bricked your MID9742 while trying to root, Now it Just hangs when trying to start)
    1) See RECOVERYAbove: Try option 2 (wipe data/factory reset) should restore to factory condition.

    2) If that doesn't work, you need to replace your Damaged System Image. (Operating system Files)
    Hopefully someone can figure out how to Back up the system image from their Healthy MID9742 tablet. Then Email it to you (or upload to temp storage site) (its only about 3MB in size). ...
    Then you can move the BackUp image "Restore Image" ( restore.img ) to your tablets internal SD Storage or MicroSD card. --Then boot into Recovery Mode, select the restore.img on the External Storage and the tablet should Replace your Damaged System Image with the Healthy System image and start normally.

    ALSO: Contact Coby and ask them to email you a copy of the stock System Image file for the MID9742. -- Call or email Coby. 877-302-2629 or 800-727-3592 --- EMAIL:

Share This Page