1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

COM and USB port questions. Help. :/


  1. Fuzzy13

    Fuzzy13 Well-Known Member

    I'll try to keep this short and to the point but at one time about a year ago, my LG phone at the time would show up in Device Manager (Vista 32 bit) under COM#. Several LG programs were required to know which COM port it was hooked up to so it could connect otherwise I wouldn't really know about this.

    Flash forward to now and I have a S3 (D2att) and while trying to use a couple of programs like ODIN and a NV backup program, it looked to see what COM port the phone was hooked up to and there's nothing there. Not even the COM ports tab. So I've gone through and manually added various COM ports including "Samsung" which was listed in the options to add but every port added has a yellow ! beside it. Keep in mind that the PC recognizes the phone just fine and I'm able to do all your normal debug tasks and ADB stuff. So there's no issue there. It just doesn't show under Ports with a COM#.

    I've tried reinstalling different types of Sammy drivers as well as reinstalling the USB drivers. Pulled the computer open to make sure nothing came unhooked as I have an extra Internal HD ran inside the housing. Turned off firewalls and other programs to ensure nothing is blocking it. Just thougha bout this but I haven't tried booting into safe mode and trying it that way. Not sure if it would even matter. :/



    I know nothing about "PORTS and COM" etc.... I only knew about it like I said from have to use LGNPST or ODIN. I do keep certain services disabled in services.msc but mainly just basic ones. But I've tried turning them back on to no avail. Does any one have any suggestions? This isn't really a big deal but it's just one of those things that bugs the hell out of me mainly because "it needs figuring out and I am failing to do so". 3


    Thank you in advance. Any help will be greatly appreciated.

    Fuzz

    Advertisement
  2. Fuzzy13

    Fuzzy13 Well-Known Member

    Switching back to original rom solved the problem.
  3. Joelgp83

    Joelgp83 Well-Known Member

    That's weird. In my experience, a Samsung phone would only expose its COM port functionality to Windows Device Manager when in Download / Odin mode. That could have been the cause of your confusion.
    Fuzzy13 likes this.

Share This Page