com.android.gallery3d has stoppedSupport


Last Updated:

  1. Hopkins132

    Hopkins132 Member

    FIXED, READ POSTS

    Hey, I ran into a problem with my LG Optimus L5, running android 4.0
    Whenever I try to view my pictures they appear all black in the gallery, and even when I click on them they don't show.
    The only way I got them to show was by rotating them...
    Also, when I click edit on a photo it brings up the message "unfortunately com.android.gallery3d has stopped."
    Lastly, the photos from gallery view show if i swipe my finger across the screen (you know how the pictures turn as your finger turns, if I do that they show).

    I have rooted the device, but unfortunately I lost all my original backups because my PC broke and I had to do a clean reinstall of windows 7...=/

    If there is no solution, is there a way I can flash a vanilla ICS ROM to get the device back to factory settings?
    Thank you very much.

    Advertisement
  2. Digital Controller

    Digital Controller The Real Bass Creator Guide


    First off after the root did you factory reset the device?

    If not you should of done that and it can iron out any issues the ROM might of caused, because honestly, it is sounding just like a botched install. I would suggest either:

    A. Factory resetting the device if you haven't done so already

    or

    B. Installing the ROM again for a new ROM, because it sounds like it could be the issue.
  3. Hopkins132

    Hopkins132 Member

    No, I didn't factory reset it after the root.
    These are the instructions I used for rooting:

    1. Download the archive and unpack it (create a folder on desktop named L5_root or whatever you like): Root kit (http://forum.xda-developers.com/atta...8&d=1345457528..

    2.Download "IS11LG_SystemBackupTest.signed.apk" attached below and copy to root of your phone (internal storage)

    3. On the phone in the "Options -> Security" enable "Unknown sources"
    In the "For Developers" enable "Debug on USB"

    4. Install "IS11LG_SystemBackupTest.signed.apk"

    5. Then open the installed "SystemBackupTest" and not closing
    Hold down the power button and reboot the device.

    6. When phone completely rebooted connect your phone to your computer via USB (note: must be charge only option)

    7. In the folder you've created (L5_root)
  4. Hopkins132

    Hopkins132 Member

    Thank you for the help, it all works now =)
    All I had to do was reset it to factory settings, and according to rootcheck (app) the phone is still rooted.
    Unfortunately all my settings/apps/pics/music is gone, but I have pics and music saved on my PC.

    Thanks again!
  5. ripukabir

    ripukabir New Member

    Last night, I was in an app and hit the Home button, but didn't exit the app, and lock button i also not working. Only way I could get out of the app was to keep hitting the Back button.Then i reset my phone, but still having the problem. Any idea what's going on? I've had the phone for a few months and never had any trouble

    Please help!:confused:

Share This Page