Compass, Accelerometer, Caller Lookup - Not FunctioningSupport


Last Updated:

  1. robsclone

    robsclone Member This Topic's Starter

    Joined:
    Dec 17, 2008
    Messages:
    19
    Likes Received:
    0
    I had a previous thread saying that my compass wasn't functioning (http://androidforums.com/support/6561-compass-not-responding-all.html#post39695), but now I'm realizing that there are many things not functioning:

    1) Compass is not functioning. Apps that use compass (streetview, skymap, compass, new horizons) hang at a "loading..." type screen
    2) Accelerometer not functioning - games/auto-rotation are not receiving input from the accelerometer
    3) Caller-lookup is not functioning. Every call received shows up as "Unknown", no matter who the caller is.

    I'm running JF-1.5, and things have been working for a long time, but only suddenly stopped.

    At first, this seemed like a hardware issue, but now i'm wondering: are there any software type issues that could cause these issues?

    Thank you all very much for any input!
     

    Advertisement
  2. Finbar

    Finbar New Member

    Joined:
    Jul 13, 2009
    Messages:
    2
    Likes Received:
    0
    Not sure if this helps but I am experienceing the exactly same thing. I am running the current version of cupcake t-mobile is punting out (1.5 Kernel ver 2.6.27-00393-g6607056 san@sandroid #1 CRB43) and noticed the problem occurring over the weekend. (11/July/09) Although I have just been using it as a mobile for the last week so may have hit me at the same time. Sounding like a dodgey update. I've been trying to get mine working as a test bed for an android app but not had much success so far so that can't have hit me.

    Apps confirming are the same, streetview is as lame as an iphone, GPS Status showing me the satellites but no compass. Skymap is not opening, and steel is not autorotating as are all other apps which usually do. Weird thing is the magnometer is working. I have the silly Metal Detector app and it was reading correctly.

    Fin
     
  3. robsclone

    robsclone Member This Topic's Starter

    Joined:
    Dec 17, 2008
    Messages:
    19
    Likes Received:
    0
    Well, "glad" to hear it's not just me!

    I still have not gotten the phone working, but did call T-Mobile support.

    Support had me delete my contacts, browser cache, and remove applications until the phone's "available memory" was above 20meg - this did NOT work.

    Support said the next step was to do a factory reset on the phone, but I have a lot of things to back up before I do that.

    If your phone's in a state where you can do a factory reset on it, then you may want to try that, since that's the next step support suggested.

    Good luck!
     
  4. robsclone

    robsclone Member This Topic's Starter

    Joined:
    Dec 17, 2008
    Messages:
    19
    Likes Received:
    0

    Just curious; have you happened to install the early versions of the Qik application? I started having a lot of issues when I first used it, since it grew uninhibited and ate up all the memory on my phone and sd card.

    Just a thought.
     

Share This Page

Loading...