Compass not working.Support


  1. Datun Walnut

    Datun Walnut Member

    Hi. A bit of a strange one this:
    I've had a galaxy S2 for about a month and I downloaded star chart. This worked well for a bit then stopped reacting to the movement of my phone. I downloaded a compass and google to sky map and they were the same. It looks like the compass isn't working.
    Samsung suggested a factory reset but this didn't cure it. My service provider agreed to a new phone and sent it out yesterday.

    I loaded star chart and the compass sensors worked. Then proceeded to put all my backed up data back on. After the reload, it didn't work again and no ammount of factory resets helps.

    I assume it's a setting or app that is in the data backup that is causing it but I would expect a factory rest to erase it. Any ideas?

    TIA

    DW

    Advertisement
    :
  2. ironass

    ironass Well-Known Member

    The compass, maps, latitude, location, etc; are all controlled by GPS.

    It could be that you are not getting a quick and accurate lock on your phone for whatever reason.

    See this post for ways of improving it:-

    http://androidforums.com/2918122-post88.html

    Hope this helps. :D
  3. Datun Walnut

    Datun Walnut Member

    I'm afraid that didn't make any difference. Everything seems to work fine withte GPS, it aquires quilckly enough but still can't see movement.

    DW
  4. ironass

    ironass Well-Known Member

    From what you say it would seem that restoring your backup has caused the problem.

    Therefore a Factory reset and a piecemeal rebuild of the phone without using backup seems to be the only answer.
  5. Gearu

    Gearu Well-Known Member

    Go into the applications list, select the downloaded column, then find the app, then press it and choose clear data, might work.
  6. Datun Walnut

    Datun Walnut Member

    The only problem is that a factory reset doesn't work. With only the star chart app on the phone, it still doesn't move
  7. ironass

    ironass Well-Known Member

    Nothing else I can think of I'm afraid.

    Might be worth dropping the developer a line, here:-

    starchart@escapistgames.com
  8. matttye

    matttye Well-Known Member

    Try shutting off the phone, pulling the battery, then put it back in and turn it back on.
  9. Datun Walnut

    Datun Walnut Member

    Thanks for your help,

    I've emailed the developers to see if they have an idea - nothing I've tried has changed anything.

    Thanks
  10. Hawker

    Hawker Well-Known Member

    Apart from wiping your phone and rebuilding your phone with the firmware, all I can suggest is soft/hard reset:

    Take out the battery, then press and hold the ON button for about 10 seconds or so. Replace the battery, then press ON button to start it. This is a soft reset, and wipes the temporary memory and empties all remaining power in the circuits.

    If this does not work, do as above but after inserting the battery, press and hold the ON button and the HOME button at the same time for 10 seconds or so again. This is a hard reset, and works best if done after a soft reset.

    Clutching at straws I know, but worth a try i suppose
  11. Datun Walnut

    Datun Walnut Member

    There doesn't seem to be a smiley for a really embarrassed burk, so please just imagine one.

    It was the leather case. I must have done part of the rebuild of the new phone without the case, put the case on and not realised that that's when it stopped working. I can now prove it by using star chart without any problems than moving the case near the back and it immediately stops dead.

    I would have noticed earlier but strangely, all other navigation apps work ok. In fact, i used the sat nav without problem just the other day and it was in it's case.

    Ahh well - thanks for the help guys. I only found the problem because I was following your advice about taking the battery out.

    Thanks again

    DW
    Ovets and amchi like this.
  12. amchi

    amchi New Member

    Datun Walnut, put me in the embarrassed burk category too. I was having the same problem and you have solved it for me. Thank you.

    It does raise an interesting issue about the use of case closing magnets in the Samsung approved leather case.
  13. evohicks

    evohicks Well-Known Member

    I have read about this problem also, I had the genuine Samsung case and after reading about people having problems with magnetised cases, got in touch with samsung, they advised me 'not' to use their own official case lol, so I took it back and got a refund.
  14. ironass

    ironass Well-Known Member

    This is not a new issue.

    I remember the same thing happening with the Nokia N97 and the Nokia case with a magnet fastening. Took ages to sort that one out until people all found that they had the same case in common. :(
  15. Ovets

    Ovets New Member

    Datun, I've spent the last 2 nights trying to sort out why google sky no longer worked in my new GSII (and first smartphone) - the new case! Thanks a lot
Loading...

Share This Page