Complete Guide: Root, unrEVOked, Titanium, Tether, Nandroid, AdFree, animation, and remove apps


Last Updated: 2011-12-16 21:16:33
  1. Jonamerica

    Jonamerica Well-Known Member

    With the current bug in enrEVOked3 I've made a few quick changes to the post to bring back the old method of rooting.

    Advertisement
  2. Peanutbutter_N_Jelly

    Peanutbutter_N_Jelly Active Member

    I did a nandroid backup and it seemed to go okay but at the end I got:
    "No /sdcard/ .android_secure found. Skipping backup of applications on external storage.
    Backing up cache...
    No sdext found. Skipping backup of sd-ext.
    Generating md5 sum..."

    then the backup finished. Is this supposed to happen and that's why peeps use Titanium backup in addition to backup their apps?
  3. Jonamerica

    Jonamerica Well-Known Member

    That seems odd. Do you have a stock SD card or a different one? Is it full, or is there room? You'll need about 300-400MB depending on what you have on your phone. When you boot the phone normally does the SD card get mounted?
  4. windycity

    windycity Well-Known Member

    Excellent guide!

    [​IMG]
  5. Jonamerica

    Jonamerica Well-Known Member

    windycity likes this.
  6. aust10n

    aust10n Active Member

    Before seeing your tutorial I had already installed the USB Drivers, and they are in My Documents. I'd like to follow your tut step by step, because right now:
    -Unrevoked does not do anything, so I assume it doesn't recognize the phone
    -Old method "exec
  7. 00TJ

    00TJ Member

    Nicely Done! My Inc is now rooted! woot woot
  8. aust10n

    aust10n Active Member

    Amazing. I did it on another computer with the unrevoked3.exe. XP didn't want to do it.

    If I hook it up to my XP, although I rooted it using a Vista, will I lose root access?
    Also, if I were to purchase a larger SD card will I need to reroot the phone?

    I'm not the most tech savy person, so I'm learning as I go.
    I'm trying to remove some bloat and when I go to the mount /system, how do i run adb shell?
    When i type it into cmd i get ('adb' is not recognized as an internal or external command, operable program or batch file)



    Thanks again for the tut, I'll be donating.
  9. Jonamerica

    Jonamerica Well-Known Member

    Congrats on getting rooted!

    Connecting your phone to a different computer or using a different SD card will not cause you to lose root. The only way you could loose root now is by an OTA update, or if you specifically flashed your phone to return to stock.

    You have to install the android sdk. In the downloads section of the guide you can get the first link (the zip file) or download it directly from Google:
    Android SDK | Android Developers

    If you download from google, unzip the directory "android-sdk-windows" to c:\ and rename it "sdk." Then run sdk-setup.exe

    adb is in the sdk\tools directory.
  10. Peanutbutter_N_Jelly

    Peanutbutter_N_Jelly Active Member

    I have an upgraded card. 16gb sandisk class 2. There's plenty of room on it for the backup so that's not the issue.
    Since I got this card it's been a little inconsistent. Sometimes when I reboot the phone the card won't read properly and I'll have to remount it. Or after the phone has been connected to my computer used as a disk drive the card will take forever to read after i unplug it. The other day I reformatted the card and restored all my data on it and that seemed to help but it still doesn't seem like it should all the time. You think I should try the nandroid backup again and see if the results change?
  11. Jonamerica

    Jonamerica Well-Known Member

    It sounds like the card is flaky. Now that you've formatted the card try doing a backup again. If it doesn't work, try it on a different card.

    If it works on a different card I'd exchange the one you have for a new one.
  12. Sean1208

    Sean1208 Well-Known Member

    This is what I'm waiting to find out before I root.
  13. Jonamerica

    Jonamerica Well-Known Member

    It comes with Superuser Permissions. Wireless Tether can be found in the market and installed post root.
    Sean1208 likes this.
  14. Sean1208

    Sean1208 Well-Known Member

    Thanks man. This is my first smart phone, so it's my first time rooting. I wanted to be sure it was worth it before going in.
  15. aust10n

    aust10n Active Member

    Have sdk installed. How do I now run adb in the cmd prompt? it is giving me errors. everything i try is no recognized.
  16. Jonamerica

    Jonamerica Well-Known Member

    You have to get to the tools directory from the command prompt.

    If you put the sdk folder in the C:\ drive you get there by typing

    cd\

    Then your prompt will say "C:\"

    type "cd sdk\tool"

    Then your prompt will say c:\sdk\tools\"

    Remember "sdk" is the directory where you put the sdk that you downloaded. If you put it somewhere else you need to go to that directory, and then tools.

    In other words, if you saved the SDK directory to your desktop it would be

    c:\users and settings\username\Desktop\sdk\tools

    If you saved it to you program files directory it would be

    c:\Program Files\sdk\tools

    etc.

    You need to know where you saved the sdk folder that you pulled out of the zip file.
  17. Jonamerica

    Jonamerica Well-Known Member

    Now that unrEVOked v3.1 has been released, which fixes the communication error with windows systems, I've removed the old method of rooting from the guide.
  18. Jonamerica

    Jonamerica Well-Known Member

    If you're looking for the hydra kernel, here's one version you can try while the site's down.

    drop.io - hydrav07
  19. woop

    woop novacane (OFWGKTA) VIP Member

    Now that Unrevoked has released a simple root process, the "complete guide to rooting" methods are not needed. With that reasoning, I am unsticking them and resticking this thread in its place as this now holds more value.

    Enjoy.
  20. windycity

    windycity Well-Known Member

    woop woop
  21. tifozi

    tifozi Well-Known Member

  22. wh1t3f34th3r

    wh1t3f34th3r New Member

    However, at the moment your page that the link goes to doesn't work. Any help or a mirror link would be great for those occasions when this happens. Thanks.

    Hunter
  23. Mezmryz03

    Mezmryz03 Well-Known Member

    Don't forget guys, donating is the best way to say thanks. I got $5 on it. Thanks for the work.
  24. Jonamerica

    Jonamerica Well-Known Member

    Sorry if it was down - I'm supposed to have redundant servers and cached backup service as well...
  25. Jonamerica

    Jonamerica Well-Known Member

    tifozi likes this.

Share This Page