Complete solution/guide for Unbricking x10Tips


Last Updated:

  1. beau420

    beau420 Well-Known Member This Topic's Starter

    Joined:
    Nov 10, 2010
    Messages:
    1,104
    Likes Received:
    173
    Thought this is a pretty helpful thread that could help answer a lot of poster questions:

    [GUIDE] Complete solution/guide for Unbricking x10 - xda-developers

    If you have any questions along the way, don't hesitate in creating a new thread on here and asking for help.

    PS. Thank you window7 from xda
     

    Advertisement
  2. katihex

    katihex Member

    Joined:
    Apr 6, 2012
    Messages:
    6
    Likes Received:
    0
  3. katihex

    katihex Member

    Joined:
    Apr 6, 2012
    Messages:
    6
    Likes Received:
    0
    okay... so i've downloaded the flashtool and the firmware stuff.
    But i can't locate a 'flash' button
     
  4. katihex

    katihex Member

    Joined:
    Apr 6, 2012
    Messages:
    6
    Likes Received:
    0
    OKAYYYY! i'm so sorry for all this! but i'm starting the flashing process...on flash mode... preparing to flash...then my phone suddenly disconnects?!
    I'm getting really angry...
     
  5. RogS

    RogS Member

    Joined:
    Mar 29, 2012
    Messages:
    16
    Likes Received:
    0
    Hey, I'm a bit new to this sort of thing but my X10 seems to have died so it seems worth giving this a go. However, when I hold 'back' and plug in the USB I it won't connect to PC Companion (or my pc at all), so will this make 'flashing' impossible?

    Having gone through phases of restarting itself lately, it got very hot last night and now will not switch on or connect. I have tried different batteries and leads, the holding down 'back' approach and the 'start+left+right' to reset it but the screen will not come to life. The best I can get is a blinking red light.

    I've not been able to try flashing out as of yet, as all the "stock links" in point 3 are now dead (as megaupload is no more). Tried a bit of searching but most other discussions I've found appear to assume more technical knowledge than I have and I've struggled to find a suitable .ftf file.

    Thanks for the help I've read on here so far.
     
  6. hathaer1

    hathaer1 New Member

    Joined:
    Sep 15, 2012
    Messages:
    2
    Likes Received:
    0
    I had the same problem, I had to update my java to get it to work.
     

Share This Page

Loading...