Computer can't recognize my deviceSupport


Last Updated:

  1. Cj2ymail

    Cj2ymail New Member This Topic's Starter

    Joined:
    May 22, 2013
    Messages:
    1
    Likes Received:
    0
    I need help, my computer won't recognize my ASUS Memo pad when i try to connect it using a USB cable, it is the one that came with my device when i bought it, it use to recognize my device but now it doesn't

    BTW: i turned on my USB debugging setting when i connected it and it worked fine, but after that it won't recognize it. i tried turning the setting off, and i also tried rebooting it, and it still doesn't work

    And another thing: i also tried to root my device but it didn't work, and after that, that's when my computer can't recognize my device
     

    Advertisement
  2. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,225
    Hello Cj2ymail. Welcome to the forums.

    It could be a driver update issue.. here's the Asus website where driver downloads are offered (just follow the prompts for info as you go along):

    ASUSTeK Computer Inc. -Support- Drivers and Download

    I've placed your question/thread in the Asus Memopad sub-forum for the benefit of more input etc. ;)
     
    Cj2ymail likes this.
  3. saleemxaman

    saleemxaman New Member

    Joined:
    Jan 5, 2014
    Messages:
    1
    Likes Received:
    0
    i have tried to do the same thing but it is not happening. driver is not updating. i tried doing it manually but pc cant recognise my device.
     
  4. ali2k4

    ali2k4 New Member

    Joined:
    Feb 3, 2014
    Messages:
    3
    Likes Received:
    0
  5. Gene67

    Gene67 Member

    Joined:
    Mar 4, 2014
    Messages:
    17
    Likes Received:
    0
    Can the device see the router?
    without the computer,
    Can it update directly?
    Reset to factory settings?
     
  6. ClaireClinton

    ClaireClinton New Member

    Joined:
    Jan 5, 2014
    Messages:
    3
    Likes Received:
    0
    Do you mean that you have turned on USB debugging, installed an Asus Android USB driver and updated the one in your PC with it? If so, connect the USB cable to another USB interface and see whether the cable or interface is still available. If not, go to androidicloud.blogspot.com/2014/04/asus-android-usb-drivers.html where several commonly-used drivers are offered, download and install a suitable one, and update the driver in Computer Management/Device Manager/Other devices first.
     
  7. anclop

    anclop New Member

    Joined:
    Jul 6, 2014
    Messages:
    1
    Likes Received:
    0
    you need to system-update your phone... the update took about 2 hours for me. :)
     
  8. Tom2001

    Tom2001 New Member

    Joined:
    Apr 7, 2015
    Messages:
    1
    Likes Received:
    0
    Hi there,
    I contacted Asus about this and their first suggestion worked in getting my PC to recognise my Memo Pad. Go into settings, storage, touch top right hand USB icon (looks like a trident), turn on 'Media device (MTP). This instantly let my PC recognise the tablet as a media device.
    If you have any further issues the Asus team were extremely helpful.
    Hope this helps you.

    Regards,
    Tom
     

Share This Page

Loading...