Computer recognizing the Droid removable disk but its not working?

Last Updated:

  1. jdphenom316

    jdphenom316 New Member

    When I plug my new Droid into my computer (vista home), it is showing the H: removable disk but I can not do anything with it. It just says "Please insert a disk into Removable Disk (H:)" when I click on it. I was able to sync all my music on Friday, what could possibly be going on now? I am using my roommates Droid USB (don't think that would have anything to do with but thought I would mention).

    Please help?


  2. iamloco724

    iamloco724 Well-Known Member

    when doing this..are you going into the notifcaitons on the droid and selecting mount need to do that for it to connect
  3. jdphenom316

    jdphenom316 New Member

    Nevermind, Fixed. let me know if your having the same problem and I can troubleshoot it for you.
  4. CnA

    CnA Member

    Just got a Droid this weekend and am having the same problem. What's your fix?
  5. When you connect to your computer, go to the notifications panel and drag it down. Touch the USB Connected line. Then select mount. Autoplay should come up for Removable Disk (X), where X is the name of the drive your computer has assigned to your droid.

    Now you should be able to transfer files.
  6. Kuhlmann03

    Kuhlmann03 New Member

    What if you are connecting usb to comp and droid and not recieving any notification that you are connected to a usb and are not able to mount?

    having that problem as we speak
  7. Timaphillips

    Timaphillips Well-Known Member

    Make sure windows has installed the usb device. You should have seen the notification pop up at the task bar on the bottom left. It's all automatic. No searching for drivers needed.

    If that doesn't help, try another USB port and mount like the above reply said.
  8. netkrzyn8

    netkrzyn8 New Member

    turn off the usb debugging!
    worked for me
    i am not sure what the USB debugging is but when you pull down your notifications, it is there under usb connect, click on usb debugging and then uncheck the box that says run usb debugging when usb is connected.
    and it works perfect!
  9. netkrzyn8

    netkrzyn8 New Member

    turn off usb debugging!
    worked for me!
    what is that any way?
  10. CookieMomster

    CookieMomster Well-Known Member

    It is for development purposes. Since you are not familiar with it and you are shutting it down, I would make the suggestion that you go into your settings and uncheck it so it doesn't start again. In normal circumstances you won't need it. To stop it from automatically starting go to home>menu>setting>applications>development then uncheck usb debugging.

Share This Page