Computer won't recognize Galaxy S2Support


Last Updated:

  1. jj5959

    jj5959 New Member This Topic's Starter

    Joined:
    Nov 20, 2012
    Messages:
    2
    Likes Received:
    1
    I'm trying to update my phone(galaxy s2 skyrocket) using Kies. When i plug in my phone via USB, however, the computer doesn't recognize it at all. My phone charges, but that's it. Kies doesn't recognize it, computer doesn't acknowledge i plugged it in, and i don't get that little USB notification on my phone.

    So far, all i've tried is restarting kies, my phone, and my computer. but that didn't help. Any help would be greatly appreciated.
     

    Advertisement
  2. jj5959

    jj5959 New Member This Topic's Starter

    Joined:
    Nov 20, 2012
    Messages:
    2
    Likes Received:
    1
    Alright, i fixed the problem. If this happens to anyone else, it might be an easier fix than you think.

    Turns out the USB cable I had was an at&t cable and only charges the phone, but doesn't connect it to USB. That's some bullshit, but I got my dad's official galaxy USB cable and it worked.
     
    Ryuks2 likes this.
  3. davidlb512

    davidlb512 Active Member

    Joined:
    Jun 7, 2011
    Messages:
    35
    Likes Received:
    4
    Good job on figuring out the fix! What were up upgrading to?
     
  4. mikalji

    mikalji New Member

    Joined:
    Apr 28, 2013
    Messages:
    1
    Likes Received:
    0
    I tried also using the original cabel that came with my phone and still no joy.
     

Share This Page

Loading...