Computer wont recognize Samsung Galaxy S2 Help!Support


Last Updated:

  1. lizb33

    lizb33 New Member

    My computer will not recognize my Samsung Galaxy S2 (Tmobile). This is now my third S2 and none of the three are being recognized by my computer. Can you please give me very specific directions- and simple ones too- if possible. I dont know if I am doing something wrong. I have tried a different USB cord and ports- still nothing...

    Advertisement
  2. Atma

    Atma Well-Known Member

    Welcome to the forums liz. :ciao:

    Do you have Samsung Kies installed? If not, download and install it. It will load the drivers you need for your computer to recognize your phone.
  3. Pozzdonn

    Pozzdonn New Member

    Are you using Kies Mini from Samsung? What Build (Froyo, Gingerbread, etc)?
  4. qbs

    qbs New Member

    It would help us to help you better if you also gave details about WHAT computer you have?

    If you have a Mac...are you running the correct version of iTunes...or can you even install Kies (you may need a Mac w/Intel processor...or the very last processor before Macs went to Intel processors).
  5. puchasr

    puchasr Active Member

    Even with Kies installed I had the same issue, WMP will not "see" my Galaxy when I was trying to sync a playlist, I solved the problem by closing WMP, unplug and plug the phone again, and it work.
  6. James120

    James120 New Member

    I'm having the same problem! It was saying something about a CD serial update so I installed Kies. My computer started to detect my samsung galaxy s2, and it said it was installed, but it doesn't show up in my computer. Help?
  7. Atma

    Atma Well-Known Member


    Welcome to the forums James. :hello:

    What was saying you had a CD serial update? Does your phone show in Kies?

    When you connect your usb cable to your computer, in the notification pulldown, does it say USB connected? When you tap that what happens?
  8. jdpenarand

    jdpenarand New Member

    Hi, I have Kies. But the conection does'nt work.
    Could somebody help me?
  9. Atma

    Atma Well-Known Member


    Hello and Welcome to the forums jdpenarand :ciao:


    Can you tell me what you have done so far and what is happening?
  10. zamorano78

    zamorano78 Member

    hello: guys I have exactly the same problem whit my Samsung Galaxy S2 can any one tell me if you fix this problem I really really need to root my phone I have read a lot about it now I think I'm ready to start testing on my cell but I can't start doing it because KIES doesn't see my galaxy s 2 I even downloaded the drivers for this cell phone but nothing seemed to work. any help I really really appreciated.
  11. Atma

    Atma Well-Known Member

    Hi zamorano :wavey:

    Are you using a PC or Mac? Does your computer see your phone so you can copy files back and forth?

    How long do you wait when you start Kies? It can take several minutes before it finally sees your phone. Try a different cable if you have one and a different usb port. Reboot your computer and phone.

    You don't have to have Kies to root. Read through this guide. Do you have the T-Mobile Galaxy S2 SGH-T989?
  12. zamorano78

    zamorano78 Member

    Hello: Atmazz thanks a lot for your reply I have windows xp Pro,. I'm not able to copy files back and forth. I wait 10 minutes after I plug the usb wire from phone to pc but it doesn't see my phone I only want to back up my data with KIES so I can root my phone following the guide you posted I already have the programs that I need to do that.
    I also tried to back up my data with TItanium backup but my phone says can't install it because your phone is not rooted. that's why I need to backup my data first using KIES I also read that when we install KIES it install the drivers as well but it just doesn't recognize my samsung galaxy S2 . thanks bro and have a good one.
  13. Atma

    Atma Well-Known Member


    Do you have usb debugging checked? Uncheck it and see if that helps. Download these Samsung drivers. See if that works. Unplug your phone. Uninstall and reinstall Kies. Reboot your computer, start Kies and plug in your phone.

    What kind of data do you need to backup?
    zamorano78 likes this.
  14. zamorano78

    zamorano78 Member

    yes boss usb debuggin in checked I unchecked it and nothing, I would like to backup all my pictures and videos as well that's all I care about it,. any way I'm going to use dropbox to backup my info, but to be honest whit you I wanted to do a backup from the firmware as well in case something goes wrong.

    Now I tried a different usb wire and the computer says this , we found a new device samsung galaxy s 2 your device is install but it might not work properly; I don't know what else I should try ,. I'm going to try this in a different computer I hope it works . haaa something else I also installed the drivers that you posted before but nothing . thanks bro for your help .
  15. zamorano78

    zamorano78 Member

    Hello: Atmazz how have you been I hope you are doing o k , well after I bought another USB wire I was able to have my galaxy s 2 rooted and also I install super user app, thanks a lot for all your help and tips that you have post . I just followed all directions from your post and Bingo I dit it , I did it thanks man keep up helping the community. But I wander what's next now that my Galaxy S 2 is rooted . Have a good one
    Atma likes this.
  16. Atma

    Atma Well-Known Member

    Hi zamorano. You're welcome and I'm happy you got it working. :)

    After you're rooted, you can use Titanium Backup, flash roms etc. Read this for a little more info.
  17. Voiceoveralan

    Voiceoveralan New Member

    As silly as it sounds... DO NOT use a cable that came with a Charger to try to sync with a computer.

    Most manufacturers do not connect all the necessary wires... (time is money).

    Buy a Quality name brand USB cable and you will see the device.
  18. N8doggy

    N8doggy New Member

    Ok I'm having problem like this but I messed up and got phone stuck in boot loop, but I can get it into odin download screen and pc won't install MTP, I need it to reconize so I can flash stock rom on my att s2 i777
  19. extracheesy

    extracheesy New Member

    this did it for me and is an easy do..copy/pasted from elsewheres...never see you again, peace n love

    Try to key in dialer:

    *#7284#
    It has 4 options:

    UART

    • MODEM
    • PDA
    USB

    • MODEM
    • PDA
    In USB section, select the PDA. If it already selected to PDA then reselect it by selecting MODEM and then PDA again.

    Only change the USB setting and then press back and try reconnect to kies again.

    --------------------------------------------
    Best opening lines like ever..

Share This Page