Connect to ADB?Support


Last Updated:

  1. d_s_klein

    d_s_klein New Member

    Can someone help me connect my Virgin Mobile Chaser via ADB?

    I've gotten other VM phones to work by adding the VID/PID to the INF.

    I'm pretty sure I have the VID/PID right (2340:0033) - but it's just not connecting.

    Windows device manager shows it as a 'unknown composite device', and ADB reports 'no devices found'.

    TIA!

    Advertisement
  2. Atma

    Atma Well-Known Member

    Hi d_s_klein and welcome to the forums. :ciao:

    I don't have this phone but it sounds like a driver problem. I found these drivers maybe you can try if you haven't already.
    chili1000 likes this.
  3. d_s_klein

    d_s_klein New Member

    It now shows up properly in the device manager. When I update the driver (it took some work to get the old driver out) it does NOT complain that the device doesn't match.

    ADB still can not find it. I've never seen this with any of the other Androids I've tried.

    It's so strange: I connected two Androids to my PC. I see two 'Android Composite ADB Interfaces' in the device manager. But the command 'ADB devices' shows only one (and not the VM Chaser).

    I tried to root it, and POOT thew an 'error 64' and quit?

    Just wondering here: Can I not ADB because it hasn't been activated?
  4. Akontostathis

    Akontostathis New Member

    D_S_Klein

    Did you find a resolution for this problem? I am having the same issue. Also have not activated. Full disclosure: this is the first android device i am trying to connect. Google USB drivers are installed according to the Android SDK screen. Installed the drivers above. Can see the drive on the phone itself, but can't see it in Eclipse.

    Thanks
    April
  5. D_S_Klein
    Just now googled this thread. Having the same problem with a Chaser I just bought yesterday.

    I just purchased a Virgin Mobil "Chaser" android phone in order to test my apps with a real phone. I can't get Eclipse (running on my Windows 7 system) to see the phone.

    I put android:debuggable="true" into my manifest file.
    I enabled USB debugging on the phone.
    I installed the "Chaser_Driver_Setup_V1.2.1"

    The phone shows up on Device Manager as "android Composite ADB Interface"
    The Driver details for that entry are:
    C:\Windows\system32\drivers\winusb.sys
    C:\Windows\system32\WdfCoInstaller01007.dll
    C:\Windows\system32\WinUSBCoInstaller.dll
    Those last two drivers were installed (I suspect) when I did the Chaser driver install



    Eclipse cannot see the device
    When I run the command prompt "adb devices" from my android-sdk\platform-tools directory nothing is listed.

    Did you ever get yours to work? Do you know of a cheap android phone that will work?
    TIA,
    Gary
  6. Atma

    Atma Well-Known Member

    Hi Gary :hello: and welcome to the forums. I know nothing about this phone, but I was having a similar problem with adb and my new Nexus 10 last night. If you don't the Java Developers kit installed, try it and see if it helps. Do you have adb actually installed or you just running it from the platform tools folder?
  7. atmazzz,
    I have the jdk et al installed. The adb is installed but it does not see the device.

    Since the founder of this thread has already experienced the same problem, I think the chaser just must be a bum phone. I know that Virgin Mobil tech support is brain dead. They know nothing.

    Since this phone doesn't work for debugging, I'm wondering if there is an approved list of phones that do work. I just need a phone that runs gingerbread and is cheap, low memory, slow cpu.

    Gary
  8. Atma

    Atma Well-Known Member

  9. I saw those two articles. They allude to HTC drivers. I don't know what HTC has to do with the Chaser phone. I tried those drivers anyway to no avail. I think I will just return the phone to Best Buy and try another phone.
    thanks,
    Gary
  10. wade2Delta

    wade2Delta New Member

    It would seem that more than a few of us are having problems with this fone. I purchased my Chaser online, haven't activated it yet. Cannot get Flashbuilder to recognize the fone. Only wanted a cheap Android fone for development testing. Installed the chaser drivers, no joy.

    Has anyone come up with a solution yet?
  11. Please let me know how you are doing with this Chaser problem. There is no support at all for this phone. PCD is just an Asian distributor offering no support and Virgin folks are brain dead.
    Gary
  12. wade2Delta

    wade2Delta New Member

    I downloaded the Chaser drivers and installed them with no problems. Since I am using Flashbuilder 4.6, i had to modify the android_winsub.inf file located in C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.6.0\install\android\usb_drivers\...

    I added the hardware id for the Chaser Fone and rebooted. My development platform is Windows 7 64 bit. After rebooting, the OS sees the additional drive on the fone via the micro SD card. However, my development environment does not see the device.

    I have a Pandigital Supernova 8" android tablet running android 2.3 gingerbread. Have already debugged and tested my apps on this device with no problems. I thought the Chaser android 2.3 fone would be fine for deployment testing. No such luck...

    Copied my apk file(s) to the SD Card and inserted it into the fone for testing... I can install my apps, but they won't run on this fone. When I launch the app, the fone displays the following dialog:

    The application myapp (process air.com.myapp) has stopped unexpectedly. Please try again.
    Force Close.

    Even the most simple app that i create which does nothing but show one screen with no widgets has this behavior. I know my apps work as I have already debugged and run them on the android 2.3 tablet.

    My guess is that this fone is not 100% compatible for all android apps. It is my intention to send it back to the Virgin Mobil for a refund and get a different fone. I only need a smart fone for testing and this is a pain in the posterior which i don't need.

    And yes, VM support is completely brain dead and has no clue on how to help. They were under the impression that the fone shipped with a CD containing USB Drivers... It doesn't...

    So, its time to get rid of this fone and get a different one and move forward... Might be a good fone for talking and texting... but if you are a developer, I would not suggest buying this fone at all...

    I may look for a few more solutions, but at this point in time, I am frustrated with this fone and just want to move on...

    Cheers
  13. Wade2delta: If you end up finding a phone that works and is running gingerbread, please post on this forum what you found. I'm, of course taking my chaser back to Best Buy but I don't know what to buy. I tried to use a friend's HTC but I couldn't find an ADB driver anywhere.
    thanks,
    Gary
  14. wade2Delta

    wade2Delta New Member

    I have receive an RMA # from Virgin Mobile... The guy i spoke with on the fone stated that there were problems with the fones firmware (as i suspected). So, I will send it back this week for a full refund.

    As for compatible fones running Gingerbread, here is a link from Adobe that list fones by manufacturer, device name, device type and device OS... Adobe Developer Connection - Flash Player Certified Devices

    There are lots of fones on the list that run Gingerbread... I wanted to test on Gingerbread for smart fones as this OS has 47% of the market of android based smart fones. Theoretically, if your app runs on Giingerbread, it should work fine on higher version of the android OS.

    The following link if a small tutorial that shows how to connect google android devices to your windows OS... It's worth having a look for reference... Adobe Flex 4.6 * Connect Google Android devices

    In the mean time, I will be looking for a gingerbread smart fone that is compatible for development with Flashbuilder 4.6 that will allow me to test my smart fone apps.

    The list I provided in the first link should give you plenty of options... from there, it shouldn't be too difficult to find one or more fones that will work. Just need to run a few searches to check for things like usb drivers for windows and firmware updates (if needed)...

    Best of luck

    If you find something before I do, I would appreciate a post on it in this forum...

    Thanks
  15. wade2Delta,
    I took the Chaser back and got an LG Optimius Elite (from Virgin Mobil) and it worked the first time with no problems. Windows 7 installed a driver that works the first time I plugged it in. I can now test with Eclipse.
    Gary
  16. wade2Delta

    wade2Delta New Member

    Cool,

    as soon as the credit has been applied on my credit card, I will purchase one of the LG models as well... Glad to hear you're up and running with no problems.
  17. chili1000

    chili1000 New Member

    These drivers solved my connection problem with Virgin Mobile Chaser ADR2090, thanks
    Atma likes this.

Share This Page