Connect via WIFI problemsSupport


  1. 1603

    1603 Member

    Hi.
    Got my Hero and my first HTC device yesterday.
    The phone connect to the WIFI signal but still dont allow me online service. Keeps saying tha "Web page not available". HTC customersupport in DK no help at all.
    Any one with good suggestions?
    Best regards
    Jesper
    P.S. It allows me to connect via 3G though. This works when I only use 2G networks.....

    Advertisement
  2. Slug

    Slug Check six! Moderator

    Are you connecting via a router? What encryption (if any) is being used? Any other security layers in place such as a firewall, access control lists etc? Are IP addresses allocated via DHCP or are you using static IPs?

    From your brief description it sounds as if the device can't route data. The first thing I would check is that the Hero has a correct IP address. In "Wireless Controls/Wi-fi Settings" tap the connection and ensure that the listed IP address corresponds to the same subnet as your router.
  3. Gogolinas

    Gogolinas New Member

    I have problem connecting my hero with wifi too. I activate wifi, then I try to connect with my network, but nothing. I have below the wifi setting it says "Unsuccesful". I have already tried connecting with 2 networks but nothing. What can do I have to do to connect to internet via wifi?:confused:
  4. 1603

    1603 Member

    Just recieved an answer from HTC. It seems that they have problems with sudden routers. The router can not be run on "modus N" if it is to be connected to any HTC-devices. They advise me to try connecting to other WIFI's to check if that works. Further more they advise me to check frequently for opdates to HTC.
    Below you'll see the answer from HTC.(In Danish). Thanks for the fast replies. Will return when/if problem is solved.
    Jesper

    Android er en meget ung operativesystem, der er ikke rigtig nogen indstillinger som kan justeres for WLAN.
    HTC enheder kan ikke k
  5. 1603

    1603 Member

    #Slug:
    Thx for the tip. I followed your adivse. It turns out that the IP-numbers on the router and the Hero do not match.
    Don't know if I can fix it myself but will try. Thx for the tip. Hope it will solve the problem.
    Be back later
  6. Slug

    Slug Check six! Moderator

    By this do you mean that the subnetting is incorrect e.g. router is on 192.168.0.xxx and Hero is on (for example) 192.168.1.xxx? Apologies in advance if I'm underestimating your knowledge..... anyway, in case you're unaware the first three octets (groups of numbers) should be the same. Only the final octet, which is unique to each device, should differ.

    There's always a way! What worked for me when I initially had problems obtaining an IP from the router was (a) double-checking that the router was acting as a DHCP server and that the handset wasn't set for static IP, (b) ensuring that the network SSID was visible, and (c) temporarily removing ALL encryption and ACLs so that the network was completely open. My handset then connected immediately and was assigned a correct IP. I then disconnected the Hero (disabled wi-fi), re-enabled WPA2 encryption and switched the Hero's wi-fi back on. It reconnected straight away. I then added the Hero's MAC address to my ACL (Access Control List) and the handset was still able to connect. I don't know if this was just dumb luck but the same sequence may be worth a try.
  7. cdmackay

    cdmackay Well-Known Member

  8. mtag

    mtag Member

    HI, I have the same problem. Just bought my Hero yesterday and have not yet been able to get internet access through wifi. It says its connected but it's not.
    The iphone has access as we speak so i'm not sure what is wrong.
    Would really appreciate help - I think the hero is a great phone but no fun without wifi :)

    @1603 (in DK, sorry guys)
    Hej, jeg er p
  9. Slug

    Slug Check six! Moderator

    If you're having issues connecting via wi-fi, can you give as many details as possible e.g. infrastructure/ad-hoc, make & model of router/AP, what security protocols are in place (WEP/WPA, ACLs etc)? This will help us find any common factors.

    I've little-to-no experience of ad-hoc wireless networking, but I've a laptop here that I'll press into service later to see if I can succeed.
  10. cdmackay

    cdmackay Well-Known Member

    It might be worth trying with a different AP, if you have one, e.g. going to a friends house. I find that mine works with WPA/PSK in my home-office, with a BT ADSL modem/router as AP, but it does not work with WPA/PSK in the house, using a Linksys WRT54G as AP (hardly an uncommon device, I'd have thought).

    Of course, that doesn't help us directly, but it's good data, for HTC, if they're listening.

    I would be able to debug a little more with proper cmdline access, but sadly the onscreen kbd bugs in ConnectBot mean that I'm struggling to type anything useful. Does anyone know of an alternative way to get cmdline access (not root) on the Hero?

    thanks again...
  11. Slug

    Slug Check six! Moderator

    Seconded. I tried a few terminal apps yesterday but haven't found one yet that plays nice with the Hero's soft keyboard. Very frustrating when the automatic reaction is to reach for ping, tracerte etc!
  12. mtag

    mtag Member

    I have a Billion 520 G r3 - it's not a router right?! - but a access point, which means that it gets it's ips from the internet provider. 5 ips are assigned.
    I have tried with no security / WPA(2) / WEP - every setting - nothing works.
    It's in BRIDGE connection with no MAC address assigned.

    The hero connects but the wifi symbol on top is only a dot even though the signal is excellent.
    Hope you guys can help - thank you.
  13. cdmackay

    cdmackay Well-Known Member

    Alternatively, is there perhaps an SSH server impl for Android? That would be even better, logging in remotely to look around.
  14. 1603

    1603 Member

    Still not able to use wifi. That goes for all WIFI I've tried. I do get connected to the WIFI but I'm still not able to get online.
    I've tried different apps from the market, but they haven't helped. A bit anoying to put it nice....
    With WIFI working I have the dreamphone. Had they only put the "back-button" on the left side instead;)

    Hej Mtag. Jeg skriver n
  15. Slug

    Slug Check six! Moderator

    Does this include public wi-fi hotspots too? If so I'd suggest that there's a hardware fault, as the Hero's radio chipset isn't that picky,

    I wish I could be of more help, but I can't think of anything else to try right now. :(
  16. cdmackay

    cdmackay Well-Known Member

    I need to get out and try some public hotspots, although I don't believe there are many free ones around here.

    I have found that even on the AP in my office, which does work, the connection drops out every few minutes. sigh. no response from HTC nor reseller, yet.
  17. emzwmz

    emzwmz New Member

    I have this problem with my wifi when connecting at work. I have connected to a few different wifi networks both with security and without which have been fine, however when connecting at work I only get the wifi symbol as a dot even though in the settings it sees it with a strong signal.

    It's trying to connect to a DWL-2200AP which I think is a wireless access point (not sure if this is different to a router to my hero)

    Any help gratefully received...
  18. mtag

    mtag Member

    I think, in general, the Hero has difficulties connecting to a AP. I've tried at home, at work and different public ones = it connects but there is no access to the net.
    Would imaging this to be a HUGE problem for all Hero owners or is it only a handful of them which would suggest a hardware malefunction ?!
    What do you guys think?
    @cdmackay, please let us know if you get a responds from HTC :)
  19. cdmackay

    cdmackay Well-Known Member

    An AP should be no different from the AP function on a router, at least as far as wireless goes...

    yup, I'll keep you updated with details. No response as yet.

    As a test, I've reflashed my old home WRT54G v1.0 with OpenWRT (was running very old Linksys f/w), and am configuring it now. If the Hero still doesn't work with it, we can rule out some issues with my old Linksys f/w, and I can try WPA2, too (not supported in the Linksys f/w).
  20. cdmackay

    cdmackay Well-Known Member

    HTC have responded, asking for further details, which I've just sent.
  21. cdmackay

    cdmackay Well-Known Member

    my responses:

    I do have two wireless APs here, and have tried both. Using WPA/PSK and MAC filtering.

    With my main one, a Linksys WRT54G running Linksys firmware, I get the problem as report: the Hero claims to connect, using WPA/PSK, and I do see the DHCP exchange working properly (so the security is working). But no packets after that.

    The Hero claims to be still connected, but nothing works. When I disabled wireless security, and MAC filtering, everything seemed to work fine. When I re-enabled WPA/PSK, the problem returned.


    With my other AP, which is a BT ADSL router with inbuilt wireless, also using WPA/PSK, things are a bit better: everything connects, and works fine, but only for a little while, from a minute or to to perhaps ten minutes. Then things stop working.

    The Hero sometimes notices the connection has "disconnected", and sometimes it still claims to be connected.


    I do see reports on the forums of some other people having wireless eth problems, which is interesting.

    ===
    One further data point: I have several other wireless eth clients here, using both APs, none of which have ever had any problems, either before, or now.
  22. cdmackay

    cdmackay Well-Known Member

    Problem solved! well, at least for me... :)

    Yesterday I reflashed the WRT54G with the Tomato firmware (after wasting several hours with OpenWRT), setup for WPA2/PSK(AES), and now all is working perfectly, no problems at all. It's not just a bit better, it's totally cured the problem.

    Looks like the Hero and the WRT54G Linksys firmware have a problem communicating for WPA.

    thanks for all the advice; anyone else seeing probs with original Linksys firmware should strongly consider trying an alternative firmware. You can backup your Linksys config and flash back to the original f/w if the new one doesn't help. But the replacements firmwares are miles ahead of Linksys in features, regardless.
  23. cdmackay

    cdmackay Well-Known Member

    Tomato is here: Tomato Firmware | polarcloud.com

    I put the latest version on my WRT54G v1.0; very easy to setup, feel free to PM me for help.

    The problem I had with OpenWRT, if anyone is intersted, is that the latest Kamikaze release has dropped support for the older Broadcom cores in e.g the v1.0 WRT54G. But they don't tell you that until you've wasted lots of time trying to get it to work, sigh.
  24. Slug

    Slug Check six! Moderator

    Glad to hear that you found the solution.
  25. michael_sch

    michael_sch New Member

    I've tried with all possible WLAN settings. No matter what the Hero can't access it.

    It connects just fine, gets a good strong signel, gets a correct IP (tried DHCP and static mac assigned) but it simply won't pull any data - eg through the browser.

    I've tried with multiple other devices, including Wii, several notebooks, WLAN pci cards, other mobile phones, ... NO problems. None.

    So for now the Hero scores Zero.

    Disappointing.

    /Michael

Share This Page