Connect via WIFI problemsSupport


  1. cdmackay

    cdmackay Well-Known Member

    yup, that sounds exactly the same as my symptoms: DHCP successful (which means that WPA worked, at least for a bit), then no further traffic.

    The only thing that cured it was a wireless access point reflash to a new OS. I suspect that something about the Hero doesn't like certain routers' WPA implementations, or vice versa. Or both.
  2. mtag

    mtag Member

    AND exactly like mine also.
    Wifi icon looks great - ip address assigned, but no real connection.
    I've tried everything and now i'm down to waiting for an update...
    When every other device works fine, how come htc/android cannot?!
  3. cdmackay

    cdmackay Well-Known Member

    Have you tried reflashing your wireless AP with something like Tomato? If your model is supported, then it's proably that you can try it out, and see, and then revert to your current OS if you prefer.

    what model of wireless AP/router do you have?
  4. 1603

    1603 Member

    OK. I've come to an interesting result. I't turn out that my internet actually do work. I'm able to use the different applications which requieres internet access. This means that I can use the weather updates and I can use the Opera Mini to browse the internet. It is the preinstalled browser which wont allow me to surf. So I guess I still have issues with the phone as I don't know how to fix the browser which was installed when i recieved the phone.
    Have any one else experienced the same?
    At this point I'm using the Opera Mini when I need the WWW.
    So if you have problems using the internet even though your are connected via Wifi try to download Opera. "Market" also works on my phone on the Wificonnection. It is "only" the preinstalled browser that don't works.
  5. ratchetjaw

    ratchetjaw Well-Known Member

    edit: odd thing is on the factory browser is can connect to google.com search a topic and come up with searches but as soon as i try to click the link to those searches i get cant connect

    Iam having the same issues with wifi. I also used the Opera and can now access internet by wifi at home. Sucks though cause no multi touch pinch zooming in opera. Also my youtube still wont work. It searchs and everything but wont play vids via wifi and they look horrible on 2g :( You have those issues also
  6. mtag

    mtag Member

    It's a BILLION 5200G R3 (or 5)
    I'll will try to check out Opera tonight.
  7. kristianw

    kristianw New Member

    I'm glad to hear I'm not the only one with this issue.

    I can connect to my AP and I get an IP but no joy after that. It says the connection i "good" or "Excelent". I have tried many settings on my AP including mode b or g only, static IP, no ecryption or mac-filtering. Noting works. I have a Zyxel Router P-2602HW-D1A (exactly the same as michael_sch - Is your ISP = Fullrate?).

    I don't think I can upgrade the firmware because the router is rented. Maybe I can talk to my ISP about upgrading the firmware. Maybe they can do it remotely.

    Before I stumbled on this thread I created a thread here:
    WiFi: Conected but VERY slow - xda-developers

    "phel21" suggests that the kernel used on the hero (2.6.27) might not be as good as more recent versions. I hope we get a fix for this soon.
  8. kristianw

    kristianw New Member

    Yesterday I wrote to HTC with my WiFi issue. I can connect, get an IP, but VERY little or no data is coming through. I have a Zyxel router.

    Well I wrote to HTC and got a support ticket. Today I got and answer but it wasn't a reply to my question.. and it wasn't for me but a guy named John. Something is not right in their support ticket system :D

    Today I tried connection with another router/AP and it worked without problems. So I guess I can confirm that there is an issue with HTC Hero and Zyxel routers
  9. coffeebeankat

    coffeebeankat Well-Known Member

    i just got my hero today unlocked white version, spent sometime setting it up, the wifi didnt even see my router but saw everyone elses in the street! i have WPA/PSK(no Server) even on a manual entry it never connected

    I have a belkin N Wireless router model F5D8321-4 my isop is virgin media cable

    I now have it connected by changing the security to WEP128 bit but i would like to get it back on the better security.

    I may ask HTC for there advice
  10. mtag

    mtag Member

    Same thing happens on mine. The connection, through Opera, seems slow and very unstable but at least there is one :)
    I hope HTC does something soon. Let's remember that all other devices connects perfectly.
  11. melmel

    melmel New Member

    I have the same problem with HTC hero.
    I can connect to my router.
    I can connect to several hotspot (neuf, sfr...)
    but at university (swistzerland) there is echec connection.
  12. michael_sch

    michael_sch New Member

    Hi

    I've just sent this message to HTC. I recommend you all to complain to HTC about this issue. Clearly sending a faulty phone on the market is unacceptable, and we must unite and require an immediate fix/solution or action from HTC.

    ---

    (Reply to thread above: Yes I'm a Fullrate customer and I can't reflash my router for the same reason.)

    ---

    My letter to HTC customer support:

    Hi HTC,

    I'm writing to you about serious wifi problems with the HTC Hero and certain Wifi routers (just about the majority of all retail Wifi AP/routers out there...).

    You really really _really_ need to address this issue soon.

    Take a look here for example:
    http://androidforums.com/htc-hero/7475-connect-via-wifi-problem.html

    Numerous users complain about IDENTICAL wifi problems on the Hero through various access points. IP gets assigned, a good strong wifi signal is displayed on the phone and then nothing. No data gets through.

    I've tried connecting with success through a cisco router/AP at work. No problems.

    But D-Link, ZyXEL and Belkin fails (need I say how common these are in the retail and ISP market??!). I get an IP address, I can see the phone in the routers DHCP client table but zero traffic comes through to eg. the browser on the phone.

    I'd expect you to test your new flag ship product against common wifi
    access point hardware - and I'm therefore quite dissapointed to find this error to be of this magnitude.

    Please advice as to how to fix this error on the phone, and if not possible at the moment, what your plans, timeline and immediate actions are for fixing it now.

    Best regards,
    Michael
    Denmark
  13. Slug

    Slug Check six! Moderator

    As someone who's old enough to remember the pain of trying to get early 14.4k modems to talk to each other, then suffered all over again first with the introduction of 28.8k modems, then 56k, and finally with 802.11 wireless networking, I have to say that my finger is pointing at the router manufacturers. The fact that a connection is made effortlessly with a Cisco box doesn't surprise me; enterprise-grade kit stands or falls on its compatibility. Consumer kit, otoh, sells mostly on stand-out features. Time and time again too many manufacturers have rushed out "draft-x" specs in a bid to beat their rivals, only to find later that a minor change during ratification has broken something vital.

    Sorry for the minor rant, but this is a pet hate of mine. Standards are there for a reason!

    Al (who still has a text file of common modem init strings filed away just in case)
  14. spiri

    spiri Member

    I'm having the exact same issue! I contacted HTC Support in Denmark, and they got back to me suggesting that it might be some DNS related problem. They asked me to try going to 74.125.45.100 in the Hero browser - it's the ip address for Google.

    It worked!

    Then I got all exited, and continued following their instructions. They asked me to go into Advanced Wifi settings (press Menu when on the Wifi settings screen) and scroll down to Static IP and set the two DNS servers to the OpenDNS ones (208.67.222.222 and 208.67.220.220).

    So I did that... and still no luck! I can't browse to regular domains, but IPs seem to work... WTF?

    So it appears to be some kind of DNS issue, but a very weird one! :(

    BTW My router is a D-Link DI-524
  15. cdmackay

    cdmackay Well-Known Member

    There are undoubtedly multiple issues; in my case it was definitely not DNS: I could not reliably ping the phone, using ICMP packets to its IP address. 50-75% packet loss. That is not remotely related to DNS.
  16. cdmackay

    cdmackay Well-Known Member

    oh, and the other failure mode was a successful DHCP exchange, and then zero packets after that. Again, that is not a failure of DNS resolution: the phone did not ever send any DNS queries out over the ethernet.
  17. spiri

    spiri Member

    Yeah, you are right it can't be a DNS issue alone. If it was, I guess setting the phone to use OpenDNS would've resolved it. It must be a weird combination of things.:confused:

    But I'm curious; is anyone else able to access websites in the browser by using IPs, like I am (try 74.125.45.100 and see if you get to Google)?
  18. spiri

    spiri Member

    OK, this is just extremely weird... Now I can't even access sites via IP addresses :eek:
  19. spiri

    spiri Member

    Ah, sorry for this spammy bahaviour guys, but just another update. I am still able to access Google via it's IP, but no other sites but Google. I tried 209.191.93.53 (Yahoo!) and It didn't work completely, though the progress bar did get further (about half way across) than when typing in a domain (only a tiny progress), before it failed.
  20. Slug

    Slug Check six! Moderator

    Works fine here via both wi-fi and HSPDA. I'm also able to reach Yahoo! the same way without a problem.

    p.s. I wouldn't call providing useful info about an issue "spamming". ;)

    /Al
  21. spiri

    spiri Member

    Heh, I'm glad you don't think I'm a spammer. I just felt a bit bad about posting again and again and again. But yeah, it was relevant information.

    Anyway, I wrote HTC support again describing what I've described here, let's see if/when they get back to me :)
  22. cdmackay

    cdmackay Well-Known Member

    they didn't get back to me, sadly, when I did the same.

    your peculiar issues could be a symptom of massive, but not total packet loss. If you have something like the UNIX ping program, on your PCs, see if you can get reliable ICMP ping response from the Hero, when it's apparently connected.

    keep on posting the relevant info; it helps others who run into this problem in the future, to know they're not alone. sadly, again, I fear it isn't going to help either of us much :)
  23. erectij

    erectij New Member

    spiri, I have the exact same router, but I can't even get the Google IP working. I have tried with all kinds of security on the router (WPA, WPA2, WEP, none) and also other routers (including several hotspots). All of the settings that did not work on my Hero worked on my old MDA III running WM.
  24. Plexus

    Plexus Well-Known Member

    I have had my Hero since a couple of weeks and one of its best features is its PERFECT wifi connection with my home router (Lynksys) and with any hotspot I happen to come nearby and I am in Denmark too; so I'm afraid that your complains could be hardware related.
    I also have another HTC , a touchHD (win mobile 6.1) and it works just as well.
    My trouble with the Hero is that I can't make it sync with XP machines (he likes only Vista). I guess the Hero has got some crap for everyone.:(
  25. spiri

    spiri Member

    I don't think it's a problem related to the phone hardware. The issue only occurs with certain routers (amongst them are apparently D-Link and Zyxel ones). If I use my MacBook Pro to share it's Ethernet connection over Wi-fi and connect my Hero to it, everything works perfectly, proving that the Wi-fi radio is working.

    So it must be something failing in the connection between specific routers and the Hero, which I would assume means some kind of software issue on the Hero (or in Android in general?).

    And, erectij, I'm not alewas able to connect to Google via the IP. Today I'v had a lot of trouble when I've been trying, whereas it worked nearly all the time yesterday :S
Loading...

Share This Page