Connect via WIFI problems


  1. chrishill16

    chrishill16 New Member

    i've looked at the specs for the router and i can't see anything which says it can be configured to wireless n mode. any idea what else could cause the phone not to connect?

    thanks again
  2. Slug

    Slug Check six! Moderator

    You say this is a work environment? Ask the admins if the router is using 802.1x authentication, as that might stop the Hero connecting. It's also possible that the HTC chipset simply isn't compatible with D-Link's proprietary "AirPlus XtremeG" protocol (if enabled).
  3. ethos

    ethos Member

  4. briankwest

    briankwest Member

    Their may be issues with some wifi routers but I can bet you the bulk of them are not 802.11 related at all.

    /b
  5. idheath

    idheath Member

    I had a problem with my HTC Hero and a different access point (AP). The AP was configured for both WPA & WPA2 (i.e. mixed mode) and in that configuration I couldn't get the Hero to connect. I reconfigured the AP to just use WPA2 and all was fine.
  6. rgrandy

    rgrandy Member

    I had a problem like this at home, and I had to reset my router for my phone to connect to it. IDK why, my other computers were connected to it fine, pretty annoying tho...
  7. webDing

    webDing Member

    I'm not sure I have the same problem as you guys have...it depends on if you
  8. Merago

    Merago Well-Known Member

  9. webDing

    webDing Member

    Nope, I haven't tried another browser yet, but I will. Been to busy and the phone is brand new...
  10. webDing

    webDing Member

    Maybe I should add that killing the task (the browser) erasing the cache, etc doesn't help.
  11. webDing

    webDing Member

    With Dolphin, no problems...
  12. Edward Turner

    Edward Turner Active Member

    My problem seemed to stem from the fact that the Hero could only remember three access points. After trying to connect to a fourth it just stopped working.
    Removing excess access points and turning off wi-fi and then back on again solved the problem.
  13. ethos

    ethos Member

    Wifi routers are using 802.11. I don't understand what you're getting at. I have the issue but I'm not on a PPPoE connection at home. If I'm correct I'm using DOCSIS.

    I'm trying to figure out why I can make a connection from my Sprint Hero to my router initially and get traffic from my cable connection but if I let it sit for more than a few seconds the traffic is unable to traverse the net. The connection is fine and the signal is strong.

    I have to cycle off/on my wifi connection on the phone to get traffic again.

    If I stream music or something it will hold a steady connection but if I try to FTP a large file from my home file server it drops after about 100MB of data.

    I have other devices connected to wifi that don't have problems at all which leads me to believe it's an Android specific issue. I believe you were on the right track with it being possibly a kernel issue.

    I'm just looking for a solution and it seems I'm not the only one.
  14. ethos

    ethos Member

    Has anybody come up with a solution or more information?
  15. GeeDub

    GeeDub New Member

    EXACTLY the same problem here.

    Didn't notice it at first as I was using mobile network even at home. Here' what else I noticed.

    1. Switch on phone (having deactivated all connections), activate wi-fi - no problems (all internet apps work AND browser works).
    2. Switch off wi-fi and turn on mobile network/3G - everything still works (internet apps AND browser).
    3. Now if i switch back to wi-fi from mobile internet/3G, with mobile network turned on, or off for that matter, that is when the problem, with browser, starts.
    At this point the progress bar does not go past 1/10th and appears to be doing nothing. All internet apps work fine thoug i.e weather, youtube. However, any app that requires the 'browser' does not. A turning off then on of the phone does solve this.

    So to summarise, the problem with 'browser', and it's only 'browser' and apps that use it, seems to manifest when switching from 3G/mobile network TO wi-fi. I'm sure it's not a router issue because I have the same results on Netgear DG834GT with latest frimware and a 'Bebox/Belkin', plus my phone is still actually connected as youtube etc works. The connection to wi-fi, as long as it is not interrupted by mobile internet/3g, remains constant and good, as long as there is no switch to mobile and back to wi-fi.

    Could this be some kind of problem with 'Browser' ability to swtich between Wi-fi and mobile internet and possibly related to firmware update that happened recently. Is i tpossible to re-install the stock browser, I do like its simple UI and layout so would rather try and make it work than switch to another browser. Apologies if this had already been highlighted or repeated. I may contact HTC with this and see what they say.
  16. 2nik

    2nik New Member

    Somehow I'm not sure this is Hero related. I have had my Hero for approximately 14 days, and a few days ago I decided to buy a wireless router to take advantage of the wi-fi, when at home. Let me add that I have installed the new Nordic ROM update.

    The router is a brand new Linksys WRT120N. So I installed it and set up my network and protected it with WPA2-Personal. I used default settings for the router i.e. it uses b,g and n protocol and nothing else was changed in the settings.

    The Hero quickly found the network, and I was happy. However, now the problems started. The Hero fell off the network all the time, and I had to reconnect ever so often. I had a long disussion with HTC, Denmark, and they finally suggested that I downloaded some 3rd party software to prevent it from falling off, when the Hero went into hibernation. I did, but that didn't help either.

    Next I figured out, that there is a menu function for this in the Hero settings. Go to Wireless controls -> Wi-Fi settings. Then press Menu and tab Advanced. In there go to Wi-Fi sleep policy and choose Never. NOW YOU MUST PRESS MENU AGAIN AND SAVE!

    Well - that was it I thought and I was happy. But soon the Hero started to fall off the network again. That was when I read this topic, and I decided to do 2 things:

    I decided to update the router's firmware and if that didn't work, I would set the router to only b and g protocol, because of a possible n issue.

    However, as soon as I had updated the router's software, the Hero stopped falling off. So with a firmware upgrade everything was fine and the Hero works perfect now. It does disconnect, when it goes into hibernation, but as soon as I use it again, it connects immediately and the connection is rock solid - on all pages. Also now I can prevent it from disconnecting, when I use the above mentioned menu function.


    Well - that was my story and contribution :)
  17. Slug

    Slug Check six! Moderator

    Mine has no problems switching between wi-fi and mobile network, but I never disable the latter. If I'm not in range of a recognised AP it uses 3G, and the browser continues to work fine when I return to a wi-fi connection. Your experience suggests that perhaps disabling the network interfaces is at the root.... will do some testing when I have time over the weekend.
  18. garrilla

    garrilla New Member

    I relaise there are answers in this thread that condrict this, but I found that changing channels from 6 to 11 worked for me.

    HTC Hero + linksys WAP54G
  19. garrilla

    garrilla New Member

    don't listen to this guy, he talks baloney ;)
  20. timwagg

    timwagg New Member

    i was having a similar problem. it seems the hero struggles when the router is broadcasting an 'n' signal, even if it is set to also broadcast 'b' and 'g'.

    if you go into the router settings, in my case the d link dir 615, click on the advanced tab, then advanced wireless and select broadcast b/g only from the drop down menu your phone should find it no problem.

    hope it works for you too!
  21. Bunjiweb

    Bunjiweb Well-Known Member

    Same fix helped me when I was having wi-fi issues. Changed my router to G only and now it works every time! I think it is router dependent as it doesn't seem to matter with the Belkin Router at work, mine however is a Thompson router provided by my ISP.

    Ben
  22. FrankTheTank

    FrankTheTank Well-Known Member

    Round a mate's last night. Being a nerd wanted to access my mate's wifi. He'd just been using his laptop to surf the net (wirelessly). Could I even see his network? Could I bollocks. Tried turning wifi on and off, tried turning Hero on and off, to no avail...:mad:

    Anyone got any idea why this may have been? Annoying fault no. 396.
  23. daffyduck

    daffyduck Well-Known Member

    Frank, I could also give annoying Comment No. xxx from your recent posts on this forum but will try to help you anyway :D

    Couple of checks off the top of my head:
    - wireless radio broadcast turned off?
    - broadcasting G signal? (hero may not be compatible with N standard?)

    Good app to download from the market is WiFi Analyser....this will detect networks, analyse them (obviously!) and connect if possible after switching on the wireless receiver.
  24. willsnz

    willsnz New Member

    Hi, for what it's worth, updating my router's firmware solved my wifi connection issues with my Hero.
    I have a Belkin N Wireless Router and updated the firmware with the latest firmware on Belkin's website. Problem solved!!
    Had endless probs connecting and maintaining a stable connection. Would work a while but then drop or would show connected but then have no internet access. Even tried some wifi apps on Android Market but nothing worked.
    But now it works like a dream and I'm enjoying my Hero more and more!
    So if possible, try the router firmware update first.
    Good luck to those still struggling - hope you find a solution.
  25. heller_barde

    heller_barde New Member

    No, not to be rude, but that is wrong. It's exactly the issue at hand, at least here on my Hero. And as far as I read this thread, most of the people seem to be able to connect to their wireless network just fine, only the transmission of data does not work. (incidentally, that would be TCP packets, which is what the linked bugfix was about)

    I happen to have investigated that bug right when it was occurring the first time. The code that introduced the bug involves a reordering of the TCP options. I believe that any of the devices in the chain of the network could be responsible for not handling that well and thus TCP packet dropping.

    That is also why with some people, changing the access point completely solved their problem, with others on the other hand, it changed nothing at all. It all depends on the device that is faulty. In my case, it's the modem.

    If you try to ping e.g. google.com or kernel.org, you will see that this actually works, since it does not need TCP packets. (to ping something from the commandline, one need not be root on android phones, I believe)

    It is not (at least not in particular) about PPPoE problems, it just happened that a lot of PPPoE modems were sloppily programmed, it seems, and that was why this bug affected a lot of PPPoE users.

    Let's hope that in the upcoming 2.1 update, there will be a more modern kernel. *hope* 2.6.28 would be enough

    cheers
    Barde

    EDIT: That came out a little incoherent. English is not my first language. Feel free to ask about any part of this post.
    EDIT2: Android 2.0 has the kernel 2.6.29, so we should be fine after the update. that's good news, phew.

Share This Page