Connected phone to computer; All apps on SD card disappeared!!!


Last Updated:

  1. JoeBloggs3

    JoeBloggs3 Member

    Hi there,

    So I connected my phone to my computer via USB using Android File Transfer to copy some photos off the camera on the SD card. Then, all my apps which were stored on the SD card, disappeared on the home screen.
    If you go onto Google Play to an already installed app (ie Dots) then it will give you the options to open/uninstall. Uninstall works, except when you click open (on Dots) it says 'Unfortunately, com.nerdyoctopus.gamedots has stopped'

    I have no idea what has happened, and want all my apps back!!! I have NOT rooted my phone.

    Thanks!!!

    Advertisement
  2. SiempreTuna

    SiempreTuna Well-Known Member

    That's because when you mount the SD as an external drive, the phone can no longer read it.

    When you disconnect from the computer (make sure you dismount it properly), the apps will magically reappear ;)
  3. Rush

    Rush {<>}~{<>}

    Hey JoeBloggs3 ...

    Welcome aboard.
    I hope you'll find our resources to be helpful. ;)
    funpig likes this.
  4. Hadron

    Hadron Well-Known Member Contributor

    Hmm, Android File Transfer is for connecting phones which use MTP rather than USB mass storage to a Mac. It shouldn't unmount your SD card from the phone, but then phones that use MTP usually don't let you move apps to SD without rooting.

    If you just mounted the SD card as a USB drive (USB Mass Storage) then SiempreTuna hit it on the head - it's to be expected, and should revert when you unmount from the computer. But you don't need AFT for that, which is what has me a bit puzzled. If I can ask, what phone model, what Android version and what computer OS are you using?
  5. JoeBloggs3

    JoeBloggs3 Member

    Hi there,

    I don't know if I'm missing a trick here, or if I should feel completely stupid, but: what do you mean??? What do I need to do to get my apps back? The apps were already on the SD card. How do I dismount/disconnect from the computer properly?

    Thanks,
    I know I sound like a whingey idiot, but I really need my apps back!
    Thanks for the quick reply though!
  6. jgreetham

    jgreetham Well-Known Member

    When you disconnect your phone from the USB cable the phone will remount the SD card. Your aps are still there on your SD card, it's just that when the SD card is dismounted from the phone, the icons are removed from the home screen. You just need to put the icons back where you want them.

    I used to have this problem with Aldiko which got installed on my SD card on my old Vibrant. The icon would disappear from my home screen when I did the USB storage connection to my PC. I finally put it together why this was happening. Now I only put apps on my SD card if I don't have their icons on one of my home screens.

    Hope this helps!
  7. Hadron

    Hadron Well-Known Member Contributor

    If it's using USB Mass Storage (which seems to be the case if apps are disappearing) then unmount from the computer the same as you would a USB flash drive. Then turn off mass storage or disk drive mode on the phone. That should do the trick.

    If you can view the SD card on the phone but you still can't see the apps on the desktop, look in the app drawer. They should still be there. If they don't reappear, reboot, and if that's not enough then as said above you can just replace the shortcuts on the desktop (the icon on the desktop is just a shortcut, not the app itself).

    (I never put app icons on my desktop, so can't remember the exact behaviour when you disconnect).
  8. JoeBloggs3

    JoeBloggs3 Member

    Hi there, thanks for the reply, but I can't seem to find my apps anywhere, and how can I put them back onto my home screen (on my phone they have taken away the 'app' page when you click on the menu buttons, so all apps are kept on the homepage).

    When I go to settings>storage and click on 'apps' in the SD card part, it has all the apps except they have no icons, and are un-openable. Also, I wouldn't be able to put them on the internal storage, because there isn't much available space. The phone says there's only 500mb available storage for apps, which would not last me for the duration of my phone usage.

    Still stuck!
    Thanks for you help though people!! Hopefully we can work this out! :eek:
  9. JoeBloggs3

    JoeBloggs3 Member

    Hi there,
    Thanks for the reply. It seems that when I plug in the phone I get 3 options:
    Media device (MTP)
    Camera (PTP)
    and USB mass storage.

    When I select mass storage, eject on my Mac and unplug it, the notification bar says 'preparing sd card' but nothing happens after that.

    I don't get what you were saying about "you don't need AFT for that", I was using AFT so I could transfer files off of the SD card...

    I'm on Android v4.1.1, Huawei Y300 and OSX 10.7.5

    Thanks for your help,
    Let's solve this... :smokingsomb:
  10. Hadron

    Hadron Well-Known Member Contributor

    If you mount it as usb mass storage you don't need AFT in order to transfer files - it behaves just like a usb memory stick, and you can just use the Finder (or, if you are like me, a terminal ;)). That's what everyone was assuming you were doing.

    AFT is to allow file transfer with devices which only offer MTP and not USB mass storage. I used USB mass storage with my previous phone without installing AFT at all, but need AFT with my current one because HTC follow Google's guidelines and do not include UMS.

    So what did you select before the apps disappeared? MTP or USB? And can you see any of your SD card's content now?

    And, you are using a phone with a MIUI-like launcher (no app drawer). So an unusual launcher and an unusual setup generally (MTP and UMS). Hmm...

    Ok, have you tried rebooting?
  11. JoeBloggs3

    JoeBloggs3 Member

    Hi there, I didn't realise that USB mass storage just treats it like a usb stick, doh! Maybe I didn't see it because it takes a while for the drives to appear.

    I could see the SD card files before (with aft) so it doesn't seem to be any different.

    So yeah, I guess my phone doesn't have an app drawer...

    I have tried restarting, multiple times. Apps still not there... I'm completely stumped for ideas of what to do. Could it possibly be an app that is causing this (or is that not the sort of thing that happens; I downloaded my apps off the playstore though, so shouldn't have any problems.

    Hmmmm...
  12. Hadron

    Hadron Well-Known Member Contributor

    We need to know whether the phone can see the card, not the computer. Does it show up in Settings > Storage, can you see media on the card, if you have a file explorer app can it browse the card? Just trying to work out whether the phone has just misplaced the apps, or whether it can't read the card at all.

    No, I don't think this is an app, it's something to do with connecting to the computer. When they disappeared had you selected USB or MTP? I've never mixed UMS and AFT so not sure what's happened here, just trying to get the sequence clear.

    How were the apps moved to SD? Did you use Settings > Apps, select app, select move to SD? That's the way it used to work on unrooted phones, but only in 2.2 or 2.3, so if you have that option it's something that Huawei have added back into 4.1.1 (Google removed the feature from Android 4). If not that way, then how? And if you can see the missing apps in Settings > Apps, can you move one back to phone? If you can that might fix it (move back again afterwards if you need to).

    As others have said, it's normal for apps on SD to be unusable when you mount the SD card as USB mass storage, but they should become available again when the card is dismounted from the computer and mounted on the phone. And unless the phone has lost the ability to read the card at all, they certainly should be back after a reboot. So something has got confused, but I don't yet know what.
  13. JoeBloggs3

    JoeBloggs3 Member

    Soooooo... I was bored, and swiping amongst my screens, until I accidentally went one page further... Most my apps were spread amongst SEVERAL pages, but I am glad to have them back.
    I have NO idea how/why/when this happened but am simply happy to have most my apps back.

    Yeah: most. Some apps didn't make it... especially my beloved Dots game, but have currently re-installed it, except lost my highscore (#firstworldproblems)

    Thanks loads everyone who helped! :D I'm really thankful, and glad to have my apps back, Esp. Hadron, thanks for your time! :D :D :D

Share This Page