1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

connected to hotspot but no internet :( help!Support


Last Updated:

  1. roybj

    roybj New Member This Topic's Starter

    Joined:
    Jul 17, 2010
    Messages:
    4
    Likes Received:
    0
    this is really weird,
    first of all i got the Nexus 1, with stock 2.2 FRF91
    my phone has an internet connection by itself (i always have the 3g icon and ability to browse the net at all times - both with or without the hotspot on).
    i also have a laptop running win7 32bit which connects to my wireless router with no problem.
    i tried setting up wifi hotspot on my nexus (both opened and secured - same result)
    then connecting with my laptop, it connects fine but then win says it has no internet connection (also when opening the "network and sharing center" it shows that the connection between the laptop and phone is ok, but phone-internet is broken).
    also, im not sure if that is related, but i tried connecting the desktop computer (win7 32bit) with usb tethering. my desktop has the nexus drivers installed (i am using adb commands here and there with no problem)
    again, it is connected and the pc is saying something about a "remote internet device" but no internet connection!

    any ideas? i am actually interested in solving the wifi issue (i wouldnt mind solving the usb, but thats a secondary issue that perhaps is related).

    thanks!
     

    Advertisement
  2. crsnwby

    crsnwby Active Member

    Joined:
    Jul 16, 2010
    Messages:
    25
    Likes Received:
    0
    If its a problem when you connect your Phone to your WiFi router for internet access like it sounds above. Check your router it may have MAC filtering enabled, I know my router requires me to add the MAC address in the list of devices before it will allow it to use the internet.

    Let me know the make and model of your router and I should be able to point you where to look for the setting.
     
  3. roybj

    roybj New Member This Topic's Starter

    Joined:
    Jul 17, 2010
    Messages:
    4
    Likes Received:
    0
    i think you misunderstood me, the problem occurs when i try setting up my phone as a hotspot to provide internet access for my laptop (for example).
    it has nothing to do with my router (i simply pointed out that the laptop CAN gain internet access via my router and NOT via my nexus)

    my laptop connects successfully to the phone which is set-up as a wireless hotspot, but has no internet access.

    any ideas?
     
  4. Tendo87

    Tendo87 Member

    Joined:
    Jun 30, 2010
    Messages:
    7
    Likes Received:
    0
    This happened to me a couple days ago, I don't know if it was a fluke or what but try this, while the laptop is connected to ur N1 through wireless hotspot, open ur WiFi hotspot settings on ur N1 then just open "configure WiFi hotspot" and then just hit save, you don't have to adjust any settings. When I did that my laptop all of a sudden connected properly and everything was all honky dory.
     
  5. crsnwby

    crsnwby Active Member

    Joined:
    Jul 16, 2010
    Messages:
    25
    Likes Received:
    0
    Ah I see so your trying to tether your laptop to the N1 for internet access. Sorry I never tried that as I always use WiFi at home or just the phone outside. I cant find any relevant info on the web as its all about 2.1 hacking and tethering..

    One thing to try... is connecting it up as normal, let it show "no internet connection"

    then release and renew your IP address..

    On your laptop

    Start->Run->type "cmd" no parentesis -> press enter
    Then on the next screen type ipconfig /release
    press enter
    Then type ipconfig /renew
    press enter
     
  6. roybj

    roybj New Member This Topic's Starter

    Joined:
    Jul 17, 2010
    Messages:
    4
    Likes Received:
    0
    Tendo87, crsnwby thanks for your help
    tried both, unfortunately still the same.
     
  7. crsnwby

    crsnwby Active Member

    Joined:
    Jul 16, 2010
    Messages:
    25
    Likes Received:
    0
    Sorry I cant even test with my phone as Vodafone are clowns and we dont have 2.2 yet.

    I will have a hunt around tomorrow I'm bound to be able to find someone with the same problem.
     
  8. techdaring

    techdaring Well-Known Member

    Joined:
    Jun 21, 2010
    Messages:
    137
    Likes Received:
    1
    If MAC address filter enable, you cannot joined that network. Please check the configuration of your modem, make sure the internet available.
     
  9. roybj

    roybj New Member This Topic's Starter

    Joined:
    Jul 17, 2010
    Messages:
    4
    Likes Received:
    0
    @techdaring: what do you mean by "check my modem config"?
    the only members of my problem scope are my nexus and my laptop - while trying to connect the laptop to the internet using the wifi hotspot function in the 2.2.
    did i miss anything?
     
  10. crsnwby

    crsnwby Active Member

    Joined:
    Jul 16, 2010
    Messages:
    25
    Likes Received:
    0
    No hes talking about the same thing I said earlier, but your not connecting the N1 to your router your connecting the laptop to your N1.
     
  11. m3mny

    m3mny New Member

    Joined:
    Nov 19, 2010
    Messages:
    1
    Likes Received:
    0
    Hi there :)

    I am writing this on my HTC desire because I can't get the WiFi Hotspots service on my phone to co operate with my pc!

    I have the network all set up.. I can see and connect to my phoned WiFi but there is no internet. Before the 2.2 update USB tethering worked too.. but none of it seems to be happening any more.

    My laptop is running the latest version of Ubuntu.

    Any fixes/advice would be awesome. Cheers
     
  12. judyeng

    judyeng New Member

    Joined:
    Aug 20, 2011
    Messages:
    1
    Likes Received:
    0
    Im having the same issue with my hotspot. I was able to use it for several months. I had no problem connecting with to my laptop, but then one day I tried disabling the google voice mail then it stopped working. I am having the same issue. My computer says that theres connection and then it says no intern connection.
     
  13. backstormer

    backstormer Member

    Joined:
    Sep 16, 2011
    Messages:
    8
    Likes Received:
    0
    hi, i read all this and thought, hey mine was working, now why isnt it? i rang up AMAYSIM and got the guy (geoff) to help me out, quite by chance i got it working.
    goto: menu->settings->Applications->Development and check 'USB debugging'

    that got mine working again, i dont know why it was switched off, i may have been playing with it
     
  14. amarmano

    amarmano New Member

    Joined:
    Jan 5, 2012
    Messages:
    1
    Likes Received:
    0
    I have internet connection enabled on my mobile and it works fine. When i try to setup my mobile as internet hotspot using WIFI, i am able to have my laptop connected to my mobile through WIFI but internet connection is not available.

    I also notice that the data packet connection gets disabled on my phone the moment my laptop & phone are connected thru WIFI, i tried enabling data packet connection on my mobile manually but i am unable to do that when WIFI connection is on btwn my laptop & mobile.

    Is there any other setting to be done on the mobile? or any settings to be enabled by the internet connection provider?

    Regds,
    Amarnath M
     
  15. AnotherJohnH

    AnotherJohnH Member

    Joined:
    Aug 15, 2011
    Messages:
    6
    Likes Received:
    0
    Not the same phone, but the same problem:

    Tethered fine (Windows 7 laptop to rooted ZTE Skate Gingerbread 2.3.5), but "no internet" on the laptop.


    In the "mobile network settings" on the phone - "Enable always-on mobile data"
    enable that...

    Worked for me :)
     
  16. N3r0

    N3r0 New Member

    Joined:
    Feb 5, 2012
    Messages:
    1
    Likes Received:
    0
    Phone: Galaxy Nexus.

    Untill some day ago I haven't experienced any problem. But now I can't connect my HP lap top to the galaxy N hotspot. I tryed to restore the PC to factory settings first, then I did the same with the Galaxy N.
    No solution.
    Neither the Mac PC can connect. But my girlfriend's ASUS PC can. I asked her in which way it could, but she doesn't know. She asked me: "Have I a lap top?"

    So I can understand that the phone is working, but I can't figure out why the oters PC can't make the connection.

    I am very sad. Help me please.
     
  17. azafarus

    azafarus New Member

    Joined:
    May 19, 2012
    Messages:
    1
    Likes Received:
    0
    Its possible that you have messed up APN settings. Go to your settings in android, go to wireless & networks>mobile networks> apns>click the menu button and select "reset to default apn".
     
  18. tiffanyeliza

    tiffanyeliza Member

    Joined:
    Jun 8, 2013
    Messages:
    14
    Likes Received:
    0
    so it must be the mac computer network settings.
     
  19. nervegear02

    nervegear02 New Member

    Joined:
    Aug 29, 2013
    Messages:
    2
    Likes Received:
    0
    hi can you help me ?
     
  20. micronome

    micronome New Member

    Joined:
    Dec 19, 2014
    Messages:
    1
    Likes Received:
    0
    Update manually your wireless network adapter drivers to the latest version. Don't use automatic update. It always claims that your drivers are up to date. That is bulls**t. Driver update resolved my connection problems in all devices that are older than my android phone. Now the internet works fine using android hotspot. :)
     
  21. MikeInMexico

    MikeInMexico Member

    Joined:
    Nov 11, 2013
    Messages:
    12
    Likes Received:
    1
    I had this problem. Found out that I had the (Windows) adapter configured with fixed DNS addresses. when I changed this to automatic everything worked
     
  22. vijaykumarcirigimi

    vijaykumarcirigimi New Member

    Joined:
    Jul 16, 2015
    Messages:
    3
    Likes Received:
    0
    After searching so many days. i found the solution accidentally.
    My simple answer is disable your LAN on Desktop
    How to Do That?

    open network and sharing center >> change adapter settings >> Local Area Connection (Right Click to Disable)
    then sync your desktop with your htc hotspot
    See the magic. :)

    Like my answer if it work for you as well
     
  23. vijaykumarcirigimi

    vijaykumarcirigimi New Member

    Joined:
    Jul 16, 2015
    Messages:
    3
    Likes Received:
    0
    After searching so many days. i found the solution accidentally.
    My simple answer is disable your LAN on Desktop
    How to Do That?

    open network and sharing center >> change adapter settings >> Local Area Connection (Right Click to Disable)
    then sync your desktop with your htc hotspot
    See the magic. :)

    Like my answer if it work for you as well
     
  24. vijaykumarcirigimi

    vijaykumarcirigimi New Member

    Joined:
    Jul 16, 2015
    Messages:
    3
    Likes Received:
    0
    After searching so many days. i found the solution accidentally

    My Simple Answer is "Disable LAN" on Your Desktop...

    How You Do That?

    open network and sharing center >> change adapter settings >> Local Area Connection (Right Click to Disable)

    then sync your desktop with your htc hotspot

    See the magic. :)

    Like my answer if it work for you as well
     
  25. BohoChic

    BohoChic New Member

    Joined:
    Jul 11, 2016
    Messages:
    1
    Likes Received:
    0
    So...I know this reply is very late, but I wanted to post here in case anyone else runs across this like I did in my search to fix a similar issue. I had been able to access and use my mobile hotspot using my Galaxy s5 on Simple Mobile with no problems for months. I connected my ps4, my tablet, my pc, streamed movies, watched Netflix, etc. I have the Simple Mobile $60/month unlimited everything plan (best bang for its buck IMHO) Anyway, a few days ago it quit working. It would show that the Hotspot was connected but when I would open an app or try to go to a Web page on my browser it would show no connection. I first thought it was my tablet not connecting but soon realized it was all devices. I tried connecting to my Hotspot via USB and got the same results, showed connected but no Internet, just like the OP.. I did a ton of digging and Google searches, I tried the time/date update, I tried adding DUN to the APN, I cleared the cache, I downloaded multiple apps, I even did a hard reset.. All to no avail! Nothing worked.. It was driving me insane! I kept running across posts mentioning an app called FoxFi, it was one I used before but it didn't seem to work for me. I thought I'd give it another go, and this time I read all of the fine print and instructions completely before downloading. I noticed that the wireless tethering ability was only available on certain device models with certain carriers. But it said that USB and Bluetooth tethering should work on most all devices. Once connected to a pc or laptop they give you the option to make a wireless hotspot connection from there. Genius! First, I had to download PdaNet onto all devices I was wanting to connect with. For my tablet I did need wifi to do this, but for pc you can download the file to your phone and transfer it via USB. There's another thing.. With a Bluetooth connection you're not able to access any apps, generally you can browse the Internet but it would more than likely be limited .. Maybe.. For me it didn't work, but luckily there's a workaround. Connect the device to any Hotspot, it doesn't have to have Internet connectivity to work, so I turned on my broken mobile hotspot on my phone, connected my tablet to it, and Bam!! It worked! I know it seems like a lot of steps to get to the end result but after days of searching for an answer, I've never been so happy to see AOL news . There's even an option to hide tethering usage. This won't change the amount of data you use, it merely hides the way the data being used by the tethered device looks to the carrier. Some carriers( T-Mobile*cough cough*) monitor tethering usage and throttle data after a you reach a certain cap so this function can be quite handy for some.
    P.S. PdaNet is free, FoxFi has a free version and a paid version for an $8 one time fee. The free version bumps you off every few minutes and you have to reconnect, that's the only difference. My take on that is $8 is well worth it. Some people pay $25+/month for tethering plans! Plus, I still don't have to pay for wifi at home!
    Hope this helps someone who is dealing with the same issues!
     

Share This Page

Loading...