Connected to Wifi but can't load anythingGeneral


  1. brucewayne5

    brucewayne5 Member

    Hi guys.

    There is a problem with my phone. I have had it for around 3 weeks. For the past few weeks everything was fine until today. My phone says its connected to wifi (my home internet) but NOTHING is loading (webpages, news, fb, twitter etc). It is not a problem with my home internet because my laptop loads stuff fine. I didn't tweak anything on my phone. My phone is able to load things using mobile data connection though.

    I have tried: restarting, turning off phone, taking off battery, disconnecting and connecting, but they dont seem to work.

    Anyone able to help? Thanks!!!

    Advertisement
  2. RamOG

    RamOG Well-Known Member

    Reset/Restart the router?? Not sure what the problem could be, but that is worth a try too
  3. brucewayne5

    brucewayne5 Member

    nah i did it, it doesn't work.
  4. RamOG

    RamOG Well-Known Member

    I'm not the most advanced person when it comes to fixing phone stuff, so not sure what the problem can be. But I can suggest one more thing.

    I would try to go over to a friends, neighbors, or even a restaurant/starbucks with wi-fi. If you can connect and can't browse there as well. It might be something with the phone and you might need to exchange/get it fixed. However, if it is the opposite, then you know it is something with the way your phone and router are interacting. From there you can maybe google the solution. Hopefully this gives you some type of an idea. Just trying to think what I would do next in this situation.
  5. moyni

    moyni Member

    Did you upgrade your firmware by any chance?

    I'm having exactly the same issue, i called Samsung who told me that its a known issue with the latest firmware.

    Was told id be called back today but alas I wasn't!!
    jerofld likes this.
  6. jerofld

    jerofld Fixing stuff is not easy VIP Member

    I would try forgetting the network and then reconnecting it. I doubt it fixes it if it's been confirmed to be a firmware problem, but it's worth a shot.
  7. moyni

    moyni Member

    Just want to add that for me the internet works for a while and then says no connection. I then have to stop and restart the wifi to get a connection.
  8. brucewayne5

    brucewayne5 Member

    jerofld - tried it already :/

    I might have updated the firmware but it was a few days ago. Some extra info: My phone is able to connect to my computer for kies via wifi. The only problem is that it just can't seem to connect to the internet, even though it says it is.
  9. XplosiV

    XplosiV Master X is Watching You VIP Member

    Check your router to make sure you have a free ip available within the ip pool. Also check to see if you need to allow your phones mac address on the wifi setup in the router. Finally check to see if you need to add the phone to your routers firewall.

    Oh and try assigning either a static ip or a reserved ip within your router (static ip needs to be set on router & phone, reserved just in router)
    brucewayne5 likes this.
  10. brucewayne5

    brucewayne5 Member

    XplosiV - Ok, I will try to figure out how to do it. I think my router has to be configured through my bro's computer but im still trying to find the file. I'm gonna go to a public wifi later to try if there's internet access. Hopefully it doesn't work there then I can conclude that its a problem with the phone and not my configurations because when I first used it I didn't need to configure anything :/
  11. brucewayne5

    brucewayne5 Member

    ^ whoops I figured out how to configure the router from my comp haha, tinkering now..
  12. brucewayne5

    brucewayne5 Member

    XplosiV - THanks, problem solved!

    Well i didn't know what to do when configuring the router. So under IP & MAC Binding > Binding Settings, i realised that under the IP address that my phone was using, the MAC address didn't tally! Does this mean that another device is using my IP address? Then I just modified the MAC address to that of my phone's, and hey presto! It worked! :D

    Thanks guys for the help!
  13. XplosiV

    XplosiV Master X is Watching You VIP Member

    Happy to help, more so that it's fixed.

    Now.... You just need to figure out what device the old mac address belonged to so you can add a new bind to a new ip :p
  14. Ultimatereza

    Ultimatereza New Member

    can you give me a screenshoot for configuring your routuer ,i have a wifi but my phone can't load image from playstore ,facebook ,path i can't send a massages from chaton :( ,i can't load socialhub fb&twitter... i don't know why ,but i try another wifi it's work fine ..but in my home wifi it can't
  15. DRepain

    DRepain New Member

    I have had the same issue when upgrading to jellybeans on my galaxy Y without clearing the cache. Solution is simple restart your phone in recovery mode and clear the cache, then restart your phone.
  16. JIQ

    JIQ New Member

Share This Page