1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Connected to Wifi but not internetSupport


  1. berryracer

    berryracer Well-Known Member

    Just bought an S4 for my wife to upgrade her from her S3

    She has a data package but once she connects to our Linksys E4200 Wireless Router at home, if she tries to browse or go to the Google Store it says no internet connection. We tried connecting / reconnecting, turning off the phone and router and restarting them but no luck.

    This problem never happened with the S3. She has a full 5 bar signal on the WiFi but no internet

    please help

    Advertisement
    :
  2. allanlaw

    allanlaw Well-Known Member

    Check the security settings on the router and make sure you've got them tracked on the S4 (also consider if you have MAC filtering engaged on the router).
  3. berryracer

    berryracer Well-Known Member

    i dont have mac filtering enabled and what security settings you mean? I am using a WAP2 Personal password and it's 100% right on the S4

    this problem never happened on the S3 :(


    BTW, I tried connecting on the 2.4 GHz. and 5 GHz. channels of my router but same result
  4. WonderFull

    WonderFull Active Member

    Did you tried connecting the S4 to any other wifi network? This way you will know whether the problem is in your S4 device or router. As you mentioned you have data package and you must have tried browsing through that.
  5. SirEagle

    SirEagle Well-Known Member

    Can you connect over 4G?
  6. Canesfan

    Canesfan Well-Known Member

    The S4 (at least mine and its replacement) have definite WiFi connectivity problems which I've ranted on, ad infinitum, on the WiFi threads. One of my complaints is that it repeatedly will show that I am connected to WiFi when I have "no internet connection". This is indeed maddening.
  7. berryracer

    berryracer Well-Known Member

    problem solved. It appeared my DNS settins in the router were in correct. As soon as i corrected them and rebooted the router the phone connected and now it has internet
Loading...

Share This Page