Connected to wireless but no internet.Support


Last Updated: 2011-09-09 15:57:39
  1. Samsung_gs2

    Samsung_gs2 Member

    Hi there, I am having a "the light are on but noone is home" issue with my Samsung galaxy SII:

    At home, in my apartment, my phone can connect to my router in 2 ways. First I can deactivate "static IP" and it has no problem connecting, secondly I can activate static IP and simply type in the following information:

    IP Address:192.168.1.1
    Gateway:192.168.1.1
    Netmask:255.255.255.0
    DNS1:
    DNS2:

    I do not type anything into the DNS areas, If I do then I cannot connect at home. However at work no matter what I do I cannot connect. I can get "connected" to the wireless by activating static IP and typing:

    IP Address:192.168.1.1
    Gateway:192.168.1.1
    Netmask:255.255.255.0
    DNS1:192.168.1.3
    DNS2:192.168.1.1

    I can acctually type pretty much anything as long as all feilds are filled out with the appropriate amount of numbers. But even though I get connected to the wireless I do not have connection to the internet. I am a consultant where I work so I cant really go around telling them to restart routers or all this nonsense just so i can use my phone. So I was wondering if there was anything anyone would recommend me doing? If I cant use the wireless internet then so be it, just annoying to have a "smart" phone that isn

    Advertisement
  2. Slug

    Slug Check six! Moderator

    It's rare for a wireless AP to require static addressing; I doubt all your patients are using static IPs as that would mean handing a new IP address out to every new patient.

    Try using the default settings as you do at home but remove all wireless connections except your home router and then reboot the handset at work. The office router should then show up as available.
  3. Hawker

    Hawker Well-Known Member

    Try looking in your router settings for an option similar to IP header checksum and disable it.
    Also what security setting is your router?
  4. Samsung_gs2

    Samsung_gs2 Member

    Hi,

    So I did as you said, removed all the wifi connection by "forgetting" them, reset everything to default setting without static IP, rebooted the phone and now I just hangs in "Obtaining IP address from <network name>"

    As I stated in the original post, I am a consultant working in a large building I dont have access to the router information at work, at home I have no problems connecting. I cannot do anything with the router from work, unless it can be done from my PC.

    Any other suggestions?
  5. Hawker

    Hawker Well-Known Member

    What is your DHCP server at work? is it the router itself or a windows server on the network?
  6. Samsung_gs2

    Samsung_gs2 Member

    I have no idea, All I know is that I have access to a wireless connection in the building and the secretary gave me the password to connect to it. I get this same problem alot of other places though. My other job same thing happens, on the train same thing. I connect to the wireless but I cannot get internet access at all.
  7. Hawker

    Hawker Well-Known Member

    It may be unrelated to your particular problem but what version firmware are you on, as i seem to remember reading on here some of the older versions had wifi problems.
  8. Samsung_gs2

    Samsung_gs2 Member

    im on 2.3.3 as far as I understand 2.3.4 isnt launched offically yet but is available as a leak?
  9. DaveSyd

    DaveSyd Well-Known Member

    This happens to me every once in a while (I have separate DSL Modem netgearDG834 + rounter DIR-655) and it is usually the DSL modem not the phone or any other device which is connected that has the problem. It looses track of the DNS server which is actually relayed from your ISP ie. even though windows sees DNS server as the primary PC IP address, if you go into the router settings the DNS server will have an address that corresponds to your ISP's server. Suggest you reboot the modem and router and verify all wired connections are working first. After that it may have something to do with the wireless channels the router is using that may need changing to a different one but this is usually automatic.
  10. Screech

    Screech Well-Known Member Contributor

    I was having an issue with my SGS2 running 2.3.4 connecting to my Linksys WRT160N running DD-WRT v24-sp2 (08/07/10) vpn-small firmware that use to not have a problem. In the wireless settings I had both Wireless Channel and Channel Width on Auto and the security was WEP. I would see the phone loop from scanning -> connecting -> obtaining IP -> disconnected -> (repeat and repeat). I set the Wireless Channel to 8, the channel width to 20 Mhz and the security to WPA2 (TKIP+AES) and it is now working.
  11. Slug

    Slug Check six! Moderator

    The OP has already stated that he has no access to the router's setup, unfortunately. :(

    It may be something fixable with a firmware update, but it could also be that the router is using the TKIP rather than the AES encryption algorithm. Trying to connect to my own router when it was set to use TKIP showed exactly the same symptom - handset would connect but not complete authentication and therefore not obtain a valid network address.

Share This Page