1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Connecting through USB - ProblemSupport


Last Updated:

  1. nkim

    nkim New Member This Topic's Starter

    Joined:
    Dec 21, 2011
    Messages:
    2
    Likes Received:
    0
    Hi all.

    Problem is I cant get the phone to connect to any computer (It did work before untill recently) It charges fine with the wall charger using the same USB but wont charge or recognize the phone when I plug it into a PC or MAC. So at the moment I cant access the internal mass storage and also write to it.

    Tried USB Debugging but that doesn't do anything either. I'm really lost and would appreciate any help. It's still under warranty so I could return it if it turns out to be faulty.

    Motorola RAZR XT910 / Droid

    Thanks :)
     

    Advertisement
  2. Grey1001

    Grey1001 Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    538
    Likes Received:
    91
    Try using the cable that came with the phone, seems to "fix" this for some people, all USB cables aren't the same as far as phones go.
     
  3. nkim

    nkim New Member This Topic's Starter

    Joined:
    Dec 21, 2011
    Messages:
    2
    Likes Received:
    0
    I have been using the USB that came with the phone, even tried another one. Still doesn't work.
     
  4. AndroidGreg

    AndroidGreg Well-Known Member

    Joined:
    Jun 8, 2011
    Messages:
    99
    Likes Received:
    6
    Sorry to revive a dead thread bit I am having the same problem. Can you day how you might have fixed your problem?
     
  5. lobstah24

    lobstah24 Member

    Joined:
    Jan 3, 2012
    Messages:
    14
    Likes Received:
    0
    Was having trouble with mine...I did two things to fix it.


    1. I loaded the correct USB drivers on my Laptop.

    2. When I connected my phone to my laptop I ensured it was configured for mass storage. Do this by swiping down from the top of the screen and choosing "USB Connection"...then "USB Mass Storage."

    After I did that it worked fine.
     
  6. AndroidGreg

    AndroidGreg Well-Known Member

    Joined:
    Jun 8, 2011
    Messages:
    99
    Likes Received:
    6
    I will tap USB mass storage, it will not activate though.
     
  7. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    What about other modes?

    What laptop is it?
     
  8. you2

    you2 Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    930
    Likes Received:
    125
    Hum. I'm not having this problem on linux; also I did not have to install any sort of driver on the linux box. Hum.
     
  9. AndroidGreg

    AndroidGreg Well-Known Member

    Joined:
    Jun 8, 2011
    Messages:
    99
    Likes Received:
    6

    All modes do not work from the select menu for me. Tried with 5 diff cables including the original on 3 different computers, a HP laptop, HP desktop and a Acer I believe on the usb 3 and 2 ports.

    I did manage to get connection through activation usb mass storage with a widgetzoid custom widget. I simply selected the widget for usb stuff and it worked great fast, it took a sec to get connected at first but after it was perfect.

    Built in menu still does not work
     
  10. AndroidGreg

    AndroidGreg Well-Known Member

    Joined:
    Jun 8, 2011
    Messages:
    99
    Likes Received:
    6
    Its not a computer, os, or cable problem. Its a problem with the phone's built in menu system or the phone itself. It is solved by using a 3rd party activator toggle.
     
  11. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    So it was a problem with the mode as I suspected.
     
  12. AndroidGreg

    AndroidGreg Well-Known Member

    Joined:
    Jun 8, 2011
    Messages:
    99
    Likes Received:
    6

    Its a problem with all modes, Ive now downloaded some apps that force all of them to work. 2.3.6 or ICS better fix this problem though.
     

Share This Page

Loading...