Connecting with usb to xp.Support


Last Updated: 2010-12-29 04:30:32
  1. mophead

    mophead New Member

    Hi all,
    Had my Galaxy portal for a few months and only just found out about 2.1, so I thought i'd try and update it. I've never plugged my phone in with usb, haven't put any music etc on it. When I plug it the usb in, it makes the notification sound and starts charging, but nothing after that, the computer doesn't pick up the phone and there's no indication on the phone that it's connecting either.

    Any help would be appreciated, this is driving me mad!

    Thanks

    Edit- Forgot to add, i've already done some of the usual things - rebooted phone, taken battery and put back in, factory reset, and that sort of thing. Thanks!

    Advertisement
  2. Beerkan

    Beerkan Well-Known Member

    Whenever you hear the notification sound, press

    Menu
    Notifications
    USB Connected
    Mount

    This will mount the SD card, and as long as you have the USB drivers installed, the phone should be visible.

    Also enable this, on your phone.
    Menu
    Settings
    Applications
    Development
    USB Debugging [x]
    mophead likes this.
  3. blueporsche

    blueporsche New Member

    Same kind of problem, where can I get the usb drivers as my computer tells me that no drivers installed for this device. Frustrating innit
  4. Beerkan

    Beerkan Well-Known Member

    Your phone came with a CD. Install NPS (New PC Studio) software. Failing that, download it.

    N.B. Download is 165Mb.

    See NPS 1.5 Download link
  5. mophead

    mophead New Member

    I've known about the usb connected in notifications as it used to come up on my G1, but it never comes up in the notifications in this phone? I've tried the New PC Studio as well, but the computer still doesn't see it. It's quite confusing, i've tried all the usb ports on this computer as well as my to no avail!
  6. Beerkan

    Beerkan Well-Known Member

    OK. Sounds like you might have corrupted your USB driver install.

    Try this.

    Add Remove Programs and remove NPS or KIES Software. If it asks to remove Samsung Drivers say yes.
    Also remove any other Samsung software or Drivers

    Now try this

    1. Click on Start
    2. Right Click on My Computer, click on Properties
    3. Click on the Hardware tab
    4. Click the Device Manager button.
    5. Expand Universal Serial Bus controllers section.
    6. Look for any Samsung Android USB Composite Driver
    7. if found Right-click device and then click Uninstall to remove it.
    8. Restart the computer, and re-install software controllers etc.
    9. Plug in the removable USB storage device, and test.

    [​IMG]
  7. mophead

    mophead New Member

    I've uninstalled nps and Kies, however under device manager there was nothing for samsung at all, in add/remove programs there is one called Samsung usb driver for mobile phones, I tried to uninstall it and it says it has but there has been no difference (I have restarted the computer). I haven't plugged the phone in yet incase that's the offending item, it does seem reluctant to shift though.
  8. Beerkan

    Beerkan Well-Known Member

    OK of you're happy you've un-installed everything, re-install the latest NPS. Then after installing it, and after a fresh re-boot, plug in the phone and see what happens.
    drm likes this.
  9. drm

    drm Member

    It works! Many thanks. By the way what benefit will I get from upgrading the firmware in NPS?. Isitworth it?
  10. Beerkan

    Beerkan Well-Known Member

    It's better to upgrade to 2.1, as it's faster, more stable and compatible. Bluetooth works as it should.

    If you need to back up anything before you upgrade, check out my root guide, as I include details on how to backup.
  11. drm

    drm Member

    Whoops. Tried to uprade the firmware from NPS and it failed. Instructions for emergrncy recovery failed. took the battery out and the handset seemed to revert to normal. now cant access random web adresses. Any ideas?? please. Wish I'd never tried to upgrade
  12. Beerkan

    Beerkan Well-Known Member

  13. hemosou

    hemosou New Member

    i also have this problem there was no samsung android composite usb device in my dev mgr, i did wat , beerkan said to do, uninstall nps/kies, install updated version, reboot, connect spica ( usb debugging ON) but it is just charging..... not even "device not recognized" popped up.... pls help... i wanna root and hack my phone!!!

Share This Page