Support Consolidate widget list? - I know there was an app

Discussion in 'Android Devices' started by mortymouse, Jul 30, 2011.

  1. mortymouse

    mortymouse Well-Known Member
    38

    Jun 29, 2010
    246
    24
    38
    I remember an app that would bunch up your widgets and clean up that whole area. So instead of several options of the one widget choice, you would see the name of the widget and then you could touch there and it would show you all of the size options.

    Can anyone jog my memory or let me know where I can get it? Thanks!
     

    Advertisement

  2. bouchigo

    bouchigo Well-Known Member
    313

    Aug 10, 2010
    3,756
    1,026
    313
    Production Engineer Mngr.
    Stockton, CA
    AppWidgetPicker.
     
    colchiro and mortymouse like this.
  3. hasbrobot

    hasbrobot Well-Known Member
    38

    Dec 26, 2009
    286
    15
    38
    EMT
    Florida
    Sorry no link but look on xda and search for "appwidgetpicker" good luck!
     
    colchiro and mortymouse like this.
  4. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    I'm running stock, rooted GB and installed it as well. :D
     
  5. mortymouse

    mortymouse Well-Known Member
    38

    Jun 29, 2010
    246
    24
    38
    Dang, keeps force closing. Ugh
     
  6. bouchigo

    bouchigo Well-Known Member
    313

    Aug 10, 2010
    3,756
    1,026
    313
    Production Engineer Mngr.
    Stockton, CA
    Did you install it to /system/app and set permissions properly? If not it will force close on you every time.
     
    mortymouse likes this.
  7. bigbadwulff

    bigbadwulff Well-Known Member
    143

    Jun 15, 2010
    2,442
    200
    143
  8. mortymouse

    mortymouse Well-Known Member
    38

    Jun 29, 2010
    246
    24
    38
    A lot of kittens died due to my ignorance. LOL. Man, I forgot to do just about everything. I got it fixed up now, works perfect. Thanks for this.
     
  9. bouchigo

    bouchigo Well-Known Member
    313

    Aug 10, 2010
    3,756
    1,026
    313
    Production Engineer Mngr.
    Stockton, CA
    No problem, glad you got it worked out :D
     
  10. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    I installed like a regular apk and it worked for me. :d
     
  11. Trooper

    Trooper Well-Known Member
    213

    Apr 11, 2010
    3,715
    541
    213
    Show off :mad::rolleyes::p

    How is stock rooted GB running for you?
     
  12. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    It's boring, but it works. I've frozen some bloat, but was hoping that Apex would be final (or at least RC3) by now. Not sure CM7 is considered a stable build yet.
     
  13. carracerz14

    carracerz14 Well-Known Member
    163

    Feb 4, 2011
    1,154
    176
    163
    I can't get this to work. I install it per the instructions but even when I turn my phone back on the widget list looks the same as before.
     
  14. mortymouse

    mortymouse Well-Known Member
    38

    Jun 29, 2010
    246
    24
    38
    What did you do to install? Go through it step by step.

    Basically this app is a replacement for the one on the phone so you dont install it at all. you copy it and paste it to the system/app folder then set the permissions to RWRR (Read, Write for the first line, then read on the second and third options for permissions).

    I used Root explorer to make the changes. Remember you need root in order to use this as you are making changes to a system file.
     
  15. carracerz14

    carracerz14 Well-Known Member
    163

    Feb 4, 2011
    1,154
    176
    163
    I have it set up just like that. I didn't hit install I just pasted it, and the permissions are correct. So idk why it doesn't work
     
  16. binary visions

    binary visions Well-Known Member
    313

    May 14, 2010
    3,334
    1,443
    313
    I'm guessing it's a corrupt APK. Try downloading it again.
     
  17. maquina

    maquina Well-Known Member
    36

    Jul 20, 2010
    86
    7
    36
    Los Angeles, CA
    I also tried installing it multiple times, following the directions exactly with root explorer. I'm running GB 2.3.3 Version 4.5.596 Rooted. I have removed the bloatware and nothing more.

    I go through all of the steps and even reboot the phone for good measures and when I go to chose a Widget, the list stays the same showing every possible widget in a list.

    The permissions are set and it's in the correct folder. The only way I could get it work was by installing Launcher Pro. Once in the LP Launcher the app works just as it's supposed to. I wonder if this does not work when using the stock MotoBlur Launcher.

    For those of you that got it working without running a ROM, are you using the stock launcher or something else like LP or ADW?

    I would love to get it working on the Stock MotoBlur Launcher. Any help would be awesome.

    Thanks.
     
  18. bouchigo

    bouchigo Well-Known Member
    313

    Aug 10, 2010
    3,756
    1,026
    313
    Production Engineer Mngr.
    Stockton, CA
    What directions are you following?
     
  19. bouchigo

    bouchigo Well-Known Member
    313

    Aug 10, 2010
    3,756
    1,026
    313
    Production Engineer Mngr.
    Stockton, CA
    maquina likes this.
  20. maquina

    maquina Well-Known Member
    36

    Jul 20, 2010
    86
    7
    36
    Los Angeles, CA

    Thanks for this, I'll give it a shot.

    The instructions that I followed were posted by the developer on XDA-Developers:

    Instructions:
    * Download the attached APK file
    * Rename it to "AppWidgetPicker.apk"
    * copy it to /system/app
    * make sure it has the same file permissions as the other files in that directory
    * maybe reboot.
    * Don't install it just copy it!

    But they didn't work on stock Moto-Blur. When I launched Launcher Pro the app did work. I'll try your zip file and let you know how it went.

    Thanks again.
     
  21. maquina

    maquina Well-Known Member
    36

    Jul 20, 2010
    86
    7
    36
    Los Angeles, CA
    I finally got around to installing the zip file you created. Unfortunately it worked the same as installing it manually. Which allows the app only to work when using a custom ROM or a different launcher i.e. Launcher Pro or ADW.

    The app does nothing when running on stock MotoBlur Launcher, but when I switch to Launcher Pro it consolidates all of the widgets as you would expect it to.

    Kind of a bummer as I like the stock MotoBlur Launcher/Home.

    Thanks for the help though. And if anyone figures out a work around or if there's an updated app, keep me informed.
     
  22. colchiro

    colchiro Well-Known Member
    323

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    Well that explains why it worked for me (running LPP). :D
     

Share This Page

Loading...