Constant error msg 3330 - You have attempted to use a data application without a data plan


Last Updated:

  1. droiduzr2

    droiduzr2 Well-Known Member

    Hello,
    How do I get rid of this message?
    I do NOT have a data plan but almost daily I get this message.
    How do I stop it from occurring? It seems that some applications try to access the web/data. I also have the the 3g feature turned off by using the Quick Setting program.

    I am on the Rogers network. Their tech dept. is under development so I thought I start with folks here.

    THANKS!


    Message-----> 3330- You have attempted to use a data application without a data plan

    Advertisement
  2. Are you on wifi then, since you dont have a data plan?
  3. droiduzr2

    droiduzr2 Well-Known Member

    Yes, I do use wifi BUT it is turned off and yet I still get these messages.

    It seems there are apps that want to communicate out but since I don't have data I get the messages via SMS. The error is in my SMS list of messages.
  4. Well that will happen. If you dont have a data plan, and are trying to use data, you will get that message. Contact your carrier, if they are the ones sending it, maybe they can stop them. Or just pay for a data plan, and be able to use your phone to its full potential.
  5. droiduzr2

    droiduzr2 Well-Known Member

    uhm, thanks for the info but IF I WANTED DATA then I would have it.
    It is currently being used to it's full potential for my current needs.
    It makes and receives phone calls:D
  6. takeshi

    takeshi Well-Known Member

    Have you tried airplane mode? That will be an issue if you want to use BT though.
  7. vikingisson

    vikingisson Well-Known Member

    You need to turn off Mobile Network in the settings. Can't say for sure on yours since I'm not running the rogers rom. There is also an APN tweak/app that keeps the phone from trying to use data. The error is coming from rogers since the phone is still capable of using data. It is happening because WiFI is going into sleep mode and the phone is sending small bits of sync info. For sure you can get rid of the issue.
  8. Mikereg

    Mikereg New Member

    It`s the google apps trying to sync ....so go to settings , Data Synchronization ,and Disable (remove the check mark)on Background Data. When going on the Market,you`ll have to re-check it.
  9. XBrav

    XBrav Well-Known Member

    I understand the situation. I used to get them from Rogers too.

    Since turning off data services applies to both WIFI and 3G on the phone, turning off sync is no good.

    What you want to do is delete the access points for data routing on the phone. If you go into Settings -> Wireless Settings -> Mobile Networks -> Access Point Names, select the one that ISN'T MMS, and delete it. Then, you'll notice the 3G / E icon in the status bar gone.

    What you basically are doing is deleting the routing information, disabling mobile data on your device. It still works as normal on Wifi.

    You may also notice a slight increase in battery life, as a data connection is not being maintained.
  10. Tyson_29

    Tyson_29 Member

    Is there a way to get that delete file back if I ever wanted a data plan?
  11. vikingisson

    vikingisson Well-Known Member

    You would simply add another APN back configured for data.

    FYI, I use mine the other way, data plan only like you might get with those USB stick plans. You can still do voice but they charge big time for it so I never use voice unless I ever needed 911. I use a SIP app and my own PBX and save way more than what a voice plan would cost. With a data only plan you can add texting if you want so at least you have that. But with better data access these days I no longer need to pay for voice and only need data when out of WiFI range.
  12. Bultaco

    Bultaco New Member

    HOWEVER.......you WANT the Google apps to sync, right, to update your calendar and such? (And as a candidate for premature Alzheimers, I SURE as hell don't wanna have to REMEMBER to turn syncing back on every time I'm in a hot-spot.)

Share This Page