1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Constantly getting "Currently unable to download. Please try again later."Support


Last Updated:

  1. brownitus

    brownitus Well-Known Member This Topic's Starter

    Joined:
    Jun 28, 2012
    Messages:
    54
    Likes Received:
    10
    [​IMG]

    From the bottom of the screen (it's faded as I just caught it with screenshot as it was disappearing). I keep getting this randomly, and regularly. I have wifi on, I'm not downloading anything myself, just finished playing a racing game that's locally installed. But nonetheless, it is constant and I'm wondering how I can diagnose it, appreciate any help!
     

    Advertisement
  2. bigyid

    bigyid Well-Known Member

    Joined:
    Jun 3, 2012
    Messages:
    56
    Likes Received:
    5
    Same here.! I thought it might be something to do with drop box syncing?
     
  3. sherlock5545

    sherlock5545 Well-Known Member

    Joined:
    Dec 18, 2011
    Messages:
    1,050
    Likes Received:
    304
    Have you tried a reboot?
     
  4. bigyid

    bigyid Well-Known Member

    Joined:
    Jun 3, 2012
    Messages:
    56
    Likes Received:
    5
    Not sure about OP but this only happens when ive turned phone off and on
     
  5. juddy

    juddy Active Member

    Joined:
    May 23, 2012
    Messages:
    27
    Likes Received:
    1
    yea i have been getting this error aswell.. but not just on the s3.. was getting it on my asus tf300 tablet aswell... i may be wrong, but i think it may have something to load on the servers hosting the update? or it may have something to do with the new updates for jellybean as the issues have been starting since they have been releasing new updates for their apps..
     
  6. greggebhardt

    greggebhardt Well-Known Member

    Joined:
    May 11, 2011
    Messages:
    671
    Likes Received:
    56
    Lots on S3 units being activated, updated and provisioned with software.

    Apple has the same program when they have a new phone.
     
  7. brownitus

    brownitus Well-Known Member This Topic's Starter

    Joined:
    Jun 28, 2012
    Messages:
    54
    Likes Received:
    10
    I still get this pretty regularly, is there any way to discover the process causing the message? Just live with it? It's nothing concerning but if there is something in the background dysfunctional I'd like to know. Thanks.
     
  8. edonaf

    edonaf New Member

    Joined:
    Aug 31, 2010
    Messages:
    1
    Likes Received:
    0
    I recently started suffering with this exact issue, and spent a long time checking all my apps. Finally, I found the culprit (for me at least) - in my MMS picture downloads.

    In my message settings (I'm using the stock messaging app on my Samsung S3), I un-ticked "Auto-retrieve" within the MMS section.

    Problem fixed... :)
     
  9. kelh

    kelh New Member

    Joined:
    Oct 18, 2012
    Messages:
    1
    Likes Received:
    0
    The solution for me was my time and date being set by the network.

    As soon as I changed that from being set by the network to manual the message has stopped.

    Settings -> Date and Time -> untick Automatic date and time, untick automatic time zone..

    problem solved.. (for me anyway)
     
  10. ron912211

    ron912211 New Member

    Joined:
    Jul 30, 2013
    Messages:
    1
    Likes Received:
    0
    is there any solution? my phone still have the same problem. i already bring it to samsung but they always says that the problem is in the aplication.
    any solutions?
     
  11. plasticchicken

    plasticchicken New Member

    Joined:
    Jan 13, 2014
    Messages:
    1
    Likes Received:
    0
    I had this problem and this was caused after a software update
    try switching off phone and remove battery and sim card for 2-3mins replace car/battery and switch back on this worked for me phone now connects to wifi network with out error messages
    Hope this is useful:)
     

Share This Page

Loading...