Contact Icon not being shownSupport

Last Updated:

  1. byrash

    byrash New Member

    Hello All,

    I have recently brought my Huawei Sonic U 8650 Android phone. Im observing an issue with the contact Icon. That, if i set a contact Icon i see it in the contact name and even displayed in the contact list. But, when i call the contact i do not see the contact icon rather a robot (default icon) is appearing. Any help on this would be great ?


  2. Lebo

    Lebo Well-Known Member

    Still having this issue? Usually this sorts out after a sync.
  3. byrash

    byrash New Member

    No i have resolved it.

    The problem is that i can for the same contact number different names in at different locations.
  4. Lebo

    Lebo Well-Known Member

    Got ya, ran into that myself and merged the contacts manually.
  5. Lalola

    Lalola New Member

    I just bought the phone and was having the same problem.
    How do you solve it?
  6. Lebo

    Lebo Well-Known Member

    Caused by duplicate contacts. Reboot the phone then go through and make sure you don't have an extra entry(s).

    For instance you could have Bob in there twice and only one has that creepy clown picture.
  7. Lalola

    Lalola New Member

    I've checked and this is the situation :-
    I've transferred all my contact list in the SIM to my phone.
    The phone did not allow me to add picture at my SIM contact, so I add the picture at the same contact in my phone list.
    But for the display options on choose contacts to display, I 'tick' Phone and 'untick' SIM.

    But I did notice that when I want to compose new message, at the contact list, both SIM & Phone contact appears.. huh?!!

    so I guess the phone 'pull' the contact which listed in the SIM instead of the Phone.

Share This Page