Contact issuesSupport


  1. bdjaddy

    bdjaddy Active Member

    When I go into People, it shows my contacts. But when I go into Phone, it lists the recent call history and then it lists my contacts, twice. How can I get rid of the double contact list under Phone?

    Thank you.

    Advertisement
  2. Savage Shadows

    Savage Shadows Well-Known Member

    It could be that you transferred your contacts over, and Google transferred your saved contacts as well. If you used an android device or some other device that saves your contacts to your Google account, then that probably means that your contacts were transferred twice. MobileGo from Wondershare is a great computer program that has a feature in its free version that will delete duplicate contacts. Its also a great program to manage your phone. It will backup everything you add on your phone, even apps.
  3. kolosus

    kolosus Well-Known Member

    You can select to delete them one by one but then gmail will go bersek because you deleted "too many contacts". I seem to recall seeing a "clean duplicates" option somewhere... Hit menu in the contacts or something.

    You can always go into gmail and manually get rid of duplicates... from your computer/laptop.
  4. durak

    durak Well-Known Member

    Not sure if this is what you mean, but if you looking to get rid of "people" tab in phone menu then open phone, go to call history, menu button, edit tabs. you'll be able to add/remove tabs you dont want.

Share This Page