Contact phone number issueSupport


Last Updated:

  1. mbatson89

    mbatson89 Well-Known Member This Topic's Starter

    Joined:
    Apr 21, 2010
    Messages:
    433
    Likes Received:
    45
    Hi all,

    I've had a quick search and can't seem to find anything on this, so maybe something i've done wrong myself, but appreciate any help and apologize if there's a thread i've missed.

    I've had my (generic) Desire for a few weeks now, and have a really nagging/annoying problem in that, where i've added contacts (on the phone memory) and then synced with facebook, it's pulling in their mobile phone number from facebook, but is defaulting to 447584... and will not let me call the contact without first editing the number to read 07584...

    The only way around this so far as i can tell, is to manually add the number again as a 'Home' number but with a 0 in place of 44, as re-adding as a mobile just defaults back to the 447584... and then assigning the 'Home' number as the primary contact number.

    Does anyone have any ideas whether this is a bug or something i've done myself, and also whether there is a way i can update my whole phonebook to change the 44's for 0's rather than manually going through and changing them?

    Thanks in advance :)
     

    Advertisement
  2. hocturnalsoul

    hocturnalsoul Well-Known Member

    Joined:
    Apr 10, 2010
    Messages:
    104
    Likes Received:
    16
    I actually created a thread about this a few weeks ago lol. I think the only way i found to fix this was to move all contacts from phone/SIMS to Google. Since i done that, i havent had any problems...yet!
     
  3. mbatson89

    mbatson89 Well-Known Member This Topic's Starter

    Joined:
    Apr 21, 2010
    Messages:
    433
    Likes Received:
    45
    Thanks for the reply. Probably me being thick again, but where's the option to do that?

    Cheers
     
  4. riverboat2001

    riverboat2001 Well-Known Member

    Joined:
    Apr 29, 2010
    Messages:
    157
    Likes Received:
    10
    This Works
    Fix for the Facebook +44 number problem

    Click on Phone

    Find a contact with a incorrect number (as mentioned starts 44)
    Long press on the contact
    Then click View contact
    Scroll down and press edit
    Change the mobile (This should have the proper contact number in it) to another option (Fax for example)
    Click Save
    Long press on the changed option above(Fax) and select "Set as primary number"
    Select edit again
    Change the Fax option back to mobile and click save.
    This will make the proper number the default again rather than the facebook number.
     
  5. mbatson89

    mbatson89 Well-Known Member This Topic's Starter

    Joined:
    Apr 21, 2010
    Messages:
    433
    Likes Received:
    45
    Thanks riverboat, at least i know it can be solved then, just wish it wasn't such a manual process!
     
  6. nx1977

    nx1977 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    2,419
    Likes Received:
    172
    You either need +44 not 44, or there is a space before the first number making the number invalid.
     
  7. angelically

    angelically New Member

    Joined:
    Oct 4, 2010
    Messages:
    1
    Likes Received:
    0
    worked for me thanks xx
     
  8. frankbonatelli

    frankbonatelli Well-Known Member

    Joined:
    May 13, 2010
    Messages:
    203
    Likes Received:
    30
    You might want to try contact cleaner found in the market. It will let you correct the lead in numbers (the ones at the beginning of any phone number). Im not certain if or how well it'll work for numbers outside North America but worth a try.
     

Share This Page

Loading...