Contact picture sync wrongSupport


Last Updated:

  1. arluijen

    arluijen Member This Topic's Starter

    Joined:
    May 31, 2010
    Messages:
    5
    Likes Received:
    0
    Strange issue:

    I'm lazy, so I import VCF's with contact details from the company intranet into google contacts to get the details to my Magic (Vodafone, Android 1.6). This works just fine but the pictures get messed up:

    Picture of person A ends up connected to the picture of person B or C. Pictures DON't show up when dialing or incoming calls are received, they only show up when searching. Please note: in google contacts all looks fine.

    Again, I'm quite content with the way it works, the picture handling is just confusing.

    Any ideas ?
     

    Advertisement
  2. tomoreilly

    tomoreilly Member

    Joined:
    Apr 10, 2010
    Messages:
    9
    Likes Received:
    1
    It's more accurate to say that the picture handling is just wrong. ;-)
    I have the same problem running Froyo - so this is a long-standing problem, still not fixed. Very disappointing - how can Android hope to take professional users from Blackberry and iPhone if they cannot even sync with Gmail properly?
     
  3. vikingisson

    vikingisson Well-Known Member

    Joined:
    Nov 13, 2009
    Messages:
    856
    Likes Received:
    24
    This is the fist I've heard of a problem. This is an issue with importing?
    I haven't ever had any picture mismatches but I'm not doing what you are. You could edit the picture from gmail and let it sync again. But lazy has been mentioned already.

    Or if you have some corporate account you're trying to import from why not use the native client like the average blackberry user does? Let the corporate server handle it and just sync that way? The contacts are all in the same list on the phone.
    :confused:
     
  4. tomoreilly

    tomoreilly Member

    Joined:
    Apr 10, 2010
    Messages:
    9
    Likes Received:
    1
    Here is a description of the problem which I observe on my N1 running Android 2.2

    1. On my laptop, I went to Google contacts and edited my own contact info, replacing my picture.

    2. For at least a week, the contact info on my phone did not update. Today I checked the settings in "Contacts" on my phone - both "Background data" and "Auto-sync" were enabled. Yet my contact picture had not updated. I "forced" a sync by tapping my gmail account under the "Manage accounts" label on the phone. I could see the "spinner" turning in the status bar as the sync occurred. But after the sync was complete, my picture had not updated.

    3. I *finally* figured out how to make this happen; I went to my contact info on the phone, which displayed my old picture. Then I selected the "Edit contact" option - now it showed the new picture - yet if I picked "Done" it reverted to the old photo. Again I selected "Edit contact" - again the new picture - and tapped the picture. At that point the phone asked something like "Do you want to use this picture?", to which I replied yes. Now my contact picture is updated on my phone.

    I find this to be an extremely obscure and non-idiot-proof way of synchronizing contact photos. It took me (an average idiot) quite a while to figure it out. Why the heck doesn't it just use the photo it pulled over in the sync operation?
     
  5. vikingisson

    vikingisson Well-Known Member

    Joined:
    Nov 13, 2009
    Messages:
    856
    Likes Received:
    24
    I still don't see the problem. Running Froyo on a Magic 32A. From the laptop I edited a contact picture and by the time I checked the phone it was already synced. Then I did my own contact and again it auto synced within seconds.
     
  6. tomoreilly

    tomoreilly Member

    Joined:
    Apr 10, 2010
    Messages:
    9
    Likes Received:
    1
    Hmmm... Until last week I was running the "Gmail notifier" application. I removed it because it did not seem to notify me reliably when new Gmail came in. I wonder if somehow this caused the problem... otherwise I'm baffled.
     
  7. arluijen

    arluijen Member This Topic's Starter

    Joined:
    May 31, 2010
    Messages:
    5
    Likes Received:
    0
    hmmm, problem fixed; I installed the cyanogenmod (great by the way) and all contacts had to be re-imported again.

    now there seem to be no problems....new contacts get imported ok.

    I would like to point out though that everything on google looked and still looks ok, it's the syncing that caused the problem.

    cheers.
     

Share This Page

Loading...