Contacts and calendar not syncingGeneral


  1. crosspatch

    crosspatch Well-Known Member

    I had been wondering why my contacts never synced after I updated them on the Google Contacts site. I went into menu > Settings > Accounts > Google, and found that the contacts had not synced since 4/30/2012. I noticed this on 8/8/2012, meaning over 3 months had passed!

    When I tapped "Sync Contacts", it worked fine. The circular "sync" icon appeared in the status area, and my contacts got as screwed up as I expected they would now that the site and my phone have gotten so out of sync.

    I haven't frozen or removed "Contacts Sync" or anything...

    Any ideas as to why they're not syncing automatically?

    Advertisement
    :
  2. jpark

    jpark Active Member

    Is your phone set to sync automatically?

    Settings:Battery & data manager:data delivery
    Insure that Background data and Data enabled is checked
    :Email and corporate sync:Email delivery
    Is Data push selected (it should be for Google)
  3. crosspatch

    crosspatch Well-Known Member

    Thanks. BG data is enabled, mobile data is sometimes enabled (i.e. when WiFi isn't in use), but I get a force close when I try going into "email and corporate sync". Probably something I froze... But I didn't start freezing apps until well after 4/30...

    Thanks!
  4. KOLIO

    KOLIO NOTEoriously XPOSED Guide


    Check the TASK MANAGER application,to make sure you don't have an affected application set to close when the screen-on times out.
  5. crosspatch

    crosspatch Well-Known Member

    Solved the problem... I simply had to re-enable the mysterious "Sync" setting.

    I had the "Email" system app frozen, which explains the FC. Defrosted it, no more FC. But the setting I needed was not in "Email and corporate sync" anyway. I had only one email account set up (i.e. there was no "Google" option in there), and it was my own personal email account. I deleted that account, and the "Email and corporate sync" option became grayed out and unavailable.

    I used an app (which I already had installed) called Notification Toggle to enable the "Sync" setting. As soon as I did, my contacts and calendar synced. Now, they're still syncing fine.

    I looked everywhere in the settings, but I cannot find a corresponding "Sync" setting. It's not the same thing as "Background data", I know that much (I had "Background data" enabled all along). I don't know how "Sync" got disabled, but it was probably some other app I used long ago. (Update: I am pretty sure I used the stock "Power Control" widget to disable sync. After a few months of not caring about it, though, I totally forgot.)

    Thanks for the replies.
Loading...

Share This Page