Contacts Losing Assigned RingtonesGeneral


Last Updated:

  1. Centrespectre

    Centrespectre New Member This Topic's Starter

    Joined:
    Aug 18, 2010
    Messages:
    3
    Likes Received:
    0
    This JUST started about a week ago.

    I only have about 5 contacts with assigned ringtones (for the people who call me the most) and ANY incoming call from ANYONE now rings with the default ringer.

    I've tried several things:
    Removing & re-assigning.
    Creating a 'Ringtones' folder and manually selecting the ringtone via contact editor
    Deleting, clearing cache & re-downloading & assigning again

    Nothing works. Just the default ringtone every time

    Any ideas/thoughts? Doesn't seem to be a big enough issue to cause a stir yet, thus I haven't seen any helpful threads on the subject.
     

    Advertisement
  2. Squez

    Squez Member

    Joined:
    May 2, 2010
    Messages:
    9
    Likes Received:
    1
    Are you running 2.1? Are you running a task killer? On 2.1 I believe the ringtones are associated via the "People" app. If you are running a task killer and are killing that app, you will lose those ringtone associations.
     
  3. greenmunky

    greenmunky Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    288
    Likes Received:
    33
    All you have to do is add the "People" app to your Exclude list in whatever task killer you use so that when you "end all tasks" the People app isn't affected. I had the same problem after the 2.1 update, all good now.
     
  4. pkopalek

    pkopalek Well-Known Member

    Joined:
    Dec 19, 2009
    Messages:
    837
    Likes Received:
    117
    That happens.

    Also, sometimes when contacts re-sync from Google, you lose your assigned ringtones.

    It is unavoidable on occasion. I turn off 'Sync Contacts' for my Google account in

    Home > Menu > Settings > Accounts & Sync > Google (my main one) > (uncheck box for Contacts).

    When you add a bunch of new contacts, or once a month (for me), I turn on that Contacts box, sync my Contacts, then uncheck the box. Having the box checked occasionally causes what you're describing.
     
  5. pkopalek

    pkopalek Well-Known Member

    Joined:
    Dec 19, 2009
    Messages:
    837
    Likes Received:
    117
    Oh, and yes sometimes the default ringtone does come through.

    To be honest, I haven't experienced this bug AT ALL since moving up to xtrSENSE ROM, which has the July OTA update.

    Are you using the July OTA update? Rooted? What ROM?

    I definitely experienced the phenomenon that EVEN IF I have a special ringtone assigned, or I have 'Send to Voicemail' turned ON, it ignores that completely, and I get the call anyway, with the DEFAULT ringtone.

    I was thinking the July OTA update has fixed this, but the information you give me will confirm/deny.
     
  6. seagrant

    seagrant Member

    Joined:
    May 17, 2010
    Messages:
    6
    Likes Received:
    0
    I had that proplem. I did the *288 reprogram. It fixed. It.
     
  7. Centrespectre

    Centrespectre New Member This Topic's Starter

    Joined:
    Aug 18, 2010
    Messages:
    3
    Likes Received:
    0
    @greenmonkey & Squez. I've added the 'People' program to the ignore list. No dice. I'll tinker with it some more and see if I can get that to work. Because I'm pretty sure that's on the right track.

    @pkopalek I've got the latest updates. Not rooted.

    @seagrant I'll give that a try if all else fails.

    Thanks everybody for your suggestions.
     
  8. Centrespectre

    Centrespectre New Member This Topic's Starter

    Joined:
    Aug 18, 2010
    Messages:
    3
    Likes Received:
    0
    UPDATE:
    I rebooted, re-assigned my ringtones and double checked to ensure "People" was on my 'Ignore' list.
    So far so good.
     

Share This Page

Loading...