contacts not syncing to gmailSupport


Last Updated:

  1. boroblue

    boroblue New Member

    I have set everything up to sync with my gmail account.

    However, all my contacts are stored as phone so i know i either need to change them all to Google or export them and import into Gmail (a pain but there you go).

    I have no contacts in gmail so i added one and it synced perfectly to my phone.

    However, as a test, i added a new google contact to my phone and synced. It didn't show up in Gmail and I believe this can take some time, and this would be fine but it has disappeared from my phone!

    It seems as if the sync has wiped out the contact from my phone because it doesn't appear on my gmail account. THis means it only syncs one way which is useless for me as the whole reason for me doing this is to get a backup of my contacts in case of emergencies!

    Am i missing a trick somewhere?

    Advertisement
  2. halcyondays

    halcyondays Well-Known Member

    I have the same problem, when i first got my phone about 25 contacts synced to my Gmail account but then stopped, i've tried everything to sort it but no success,My calender syncs fine both ways however. hopefully one of these fine peeps can help us aye?:D
  3. belso

    belso Member

    It should sync both ways, you should be able to add a contact to your gmail account and have it sync to your phone and vice versa, and it should sync more or less immediately, this is how it behaves when it works, BUT, many times it doesn't work as expected, I have had many problems with this where I had contacts getting deleted during sync, I never found out what causes it, software glitch? sync glitch? I don't know, my only way of dealing with this is making regular backups of contacts and restore when needed.
    halcyondays likes this.
  4. JohnnyBravo1000

    JohnnyBravo1000 Well-Known Member

    I think mine has always worked fine. However, after reading some of the horror stories, I suppose there is a chance I may have lost some contacts without realising it as I do have a lot of contacts.
  5. Eris Ed

    Eris Ed Well-Known Member

    I added most of my contacts (30+) to my Desire via bluetooth from my Sony K810i. The transfer worked perfectly but I didn't get the option to save them as Google contacts, therefore they don't sync with my Google account online. The 6 or 7 contacts added manually were saved as Google contacts by default, and they sync no problem.

    Any easy way to change them to Google contacts?
  6. SUroot

    SUroot Well-Known Member Developer

    In people, export to SD card. Then import from SD card. When importing, choose google contacts as the type.
  7. kevinx

    kevinx Active Member

    I am unable to sync my Google Conatacts with my phone any longer. This used to work fine, but when adding/changin/deleting a contact on my phone (HTC Desire) or PC or LapTop, the changes are NO LONGER reflected on the other devices :-(
    Windows XP Pro
    Windows Vista
    FroYo v2.2

    Wonder if anyone has a resolve/answer to this problem??

    Thanks
  8. peter7769

    peter7769 Well-Known Member

    Hi All

    Question, have any of you recently changed your email address from googlemail to gmail??

    Pete
    Hangglider likes this.
  9. chrisrosevilla

    chrisrosevilla Active Member

    My google contacts don't sync phone to pc either. Calendar is fine.

    This is very annoying because I switched from outlook sync to google after froyo because of exactly the opposite problem; contacts synced but calendar phone to pc stopped working.

    Now I notice my outlook business contacts have dropped from 800 to 250 presumably caused by HTC sync; it's taken me years to build up these contacts.

    In short my carefully maintained contacts are now a complete mess. This all worked perfectly for months.

    The Desire? Fabulous hardware now ruined by buggy software which certainly isn't suitable for a business user I'm sorry and annoyed to say.
  10. chrisrosevilla

    chrisrosevilla Active Member

    After all afternoon repairing messed up outlook contacts I've finally got HTC sync/outlook and google contacts/calendar working perfectly by doing a factory reset and starting from scratch. I wish I'd done this as soon as 2.2 arrived and at the first sign of trouble since every other suggested fix just messed everything up even more.

    I'm looking forward to learning to love my Desire again after 2 weeks of chaos!
  11. ianb11

    ianb11 Well-Known Member

    This is exactly what mine does as well.

    I though they were supposed to sync both ways?

    If I add a contact on gmail it transfers to the handset but not the other way round :confused:
  12. Hangglider

    Hangglider New Member

    I've been having this issue aswell - very frustrating... contacts I add to my phone (as a google contact) do not sync with gmail and disappear from the phone altogether after a short while. Contacts added to gmail are fine and sync with the phone with no problems.

    I have found a solution...!

    I had previously changed my google account online from googlemail to gmail. After changing it back (while signed into gmail - click "settings", then "accounts and import" tab. On this screen the second row down will read "send mail as" - to the right of your email address highlighted in blue it will say "switch to @googlemail.com") everything worked both ways again. I can now save new contacts to my phone as a google contact and it will appear online in my google mail contacts - and vice versa.

    Good luck!
    amarilla51 likes this.
  13. ianb11

    ianb11 Well-Known Member

    I don't have that option :(
  14. noodles317

    noodles317 Active Member

    Just to add another problem to the whole Google Mail not syncing issues.

    Mine has a different problem (I think), it only syncs a total of 25 contacts from Gmail to my Desire out of 250(ish) contacts the rest are sitting on my phone memory but when i go to just view Googlemail contacts it only has a total of 25, i am hopeing there is a simple solution as i really don't want to have to do a full factory reset but this is driving me up the wall.

    Any suggestions????
  15. Markus729

    Markus729 Well-Known Member

    My contacts haven't synced since Sept 3. Calendar syncs perfectly. I don't see an option for googlemail vs. gmail in my accounts on my Mac, using Chrome. I've never heard of googlemail... is it a legacy domain, before gmail, or what?
  16. Douzeper

    Douzeper Member

    I fixed mine I hope this helps others...

    !!!!!BACK UP Contacts to SD Card!!!!! then.........

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    "Manage Applications" - "ALL" - "Contacts Storage" - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc"

    Then reload contacts from backup and select Google.

    (this was on HTC desire)
  17. Markus729

    Markus729 Well-Known Member

    I have the Incredible, and within my "Accounts & Sync" I have check boxes next to Background Data and Auto-Sync, but not Background Sync. I want to be sure so i don't assume anything and mess anything up.

    thanks
  18. Zamial

    Zamial New Member

    Thanks mate this was useful. I intially tried it using the backup and restore method you suggested but this just resulted in double the amount of contacts showing up in the view contacts screen. Also ended up with double contacts on web gmail contacts. So I turned off sync, deleted the duplicates from web gmail, cleared the data in contacts storage on the phone, then resynced. Now have 2 way syncing, whoohoo! :)
  19. Markus729

    Markus729 Well-Known Member

    THIS WORKED, THANKS! I exported all my Google contacts on my PC as a backup, and did all the above. It synced, and it worked. I edited a contact on my phone and it changed immediately on my PC. I added a new contact on my PC and it showed up immediately on my phone.

    I second that WOOHOO!
    LarryBrown likes this.
  20. benaTRON

    benaTRON New Member

    thanks danfrance, legend!
  21. deanthemachine

    deanthemachine New Member

    Also, when creating a contact on the phone, make sure the "contact type" is Google (not phone or SIM).
  22. LarryBrown

    LarryBrown Member

    DOOOOOD!!!! You ruuuuuule!!!! So easy and yet 100s of articles and threads that I've read tonight are clueless. So the answer to this problem is "The contacts must be stored to Google when they are added to the phone." You can think of "phone contacts" as contacts that you don't want synced to the Google cloud.

    FYI: when you export the contacts to the SD card, they get saved as a .vcf file. That's a text file that you can read and make sure it looks good. You can also import that into Google contacts, providing another option on getting this job done.

    Thanks dude.

    Larry
  23. eborjas09

    eborjas09 New Member

    Nicely done! It also created the Duplicates for me.. but on the gmail interface there is an option to "match duplicates"
  24. Conzo427

    Conzo427 Member

    I'm nervous! When I backed up to SD it said it was backing up 615 contacts, but when I am now restoring, it says there are only 435 contacts... it will be devistating to me if i lose 200 contacts.
  25. Conzo427

    Conzo427 Member

    Yep, there gone now... thanks for the tip asshole... I am so screwed...

Share This Page