Contacts problemSupport


Last Updated:

  1. caracortada_uk

    caracortada_uk Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    20
    Likes Received:
    0
    Hi all. I do not know how but for some reason the phone numbers in my contacts (People) list are now displayed in US format instead of UK i.e. 123-456-78910 instead of 12345678910. And when when sending an SMS and i load up the contacts list BOTH the US and UK formats are displayed.

    I have tried deleting all my contacts and reimporting them from a back up on the SD card but no change. I have also tried to change the view settings of the list incase its my google contacts showing but it shows 0 contacts for google but 149 for the phone, i only have half that.

    I have used HTC Sync Google sync recently, could these be the problem? If so how do i fix it?

    Thanks
     

    Advertisement
  2. Raggy

    Raggy Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    65
    Likes Received:
    3
    I have exactly the same thing on mine, deleted all my contacts reloaded them but it still changed back so I gave up in trying in the end as they still work correctly.

    The only way I found to get rid of duplicate numbers when texting is to delete all the 'PHONE' contacts but keep the 'GOOGLE' contacts, but this is a pain as well as when it syncs they re-appear so I have now disabled the contact syncing, surely there has to be a way to avoid all this fooking around
     
  3. NineToTheSky

    NineToTheSky Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    371
    Likes Received:
    37
    It's basically what Raggy says, but when this happened to me, I bit the bullet, and converted all my contacts to google. It's much simpler, and means all your contacts are available on any PC or phone, and they sync automatically.
     
  4. caracortada_uk

    caracortada_uk Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    20
    Likes Received:
    0
    The problem is there are no "google" contacts listed, only 148 phone contacts when i should only have 74. The dupilcates are the US format numbers, and oddly a small number of duplicates are in UK format. Also when i log into my google account website there are no contacts listed. That was my first thought, but no luck :mad:
     
  5. NineToTheSky

    NineToTheSky Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    371
    Likes Received:
    37
    That's because you have to convert your phone contacts to google contacts.
     
  6. caracortada_uk

    caracortada_uk Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    20
    Likes Received:
    0
    That may solve the issue but it doesnt explain why it happened. I did not have this problem until i ran HTC and Google Sync. And still persists even after i stopped using and disabled them.

    But im fine with keeping my contacts just on my phone, and keeping a back up on the SD card and my PC. And if i did go down the google contacts route, they are still in US and not UK format.
     
  7. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,304
    To fix the format issue you need to turn google sync off and clear your contacts data.

    In Gmail on your PC, export to csv, edit in excel and re-import (after deleting the existing gmail contacts.

    Then when you turn sync back on, you should have the correct format.
     
  8. caracortada_uk

    caracortada_uk Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    20
    Likes Received:
    0
    Thanks Dan but i do not have Gmail on my PC.

    I have already tried turning off google sync, deleted all contacts (confirmed in both People and the contact list when sending an SMS) and reimported from VCF back ups which are in the correct UK format (I checked the file). Still duplicates appear from somewhere even with 3G and WiFi disabled.
     
  9. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,304
    Yes you need to go into manage applications>contacts storage and clear the data with sync on.

    By gmail on your pc, I mean open up an internet browser and log into your gmail account from a pc.
     
    jbmalta and caracortada_uk like this.
  10. caracortada_uk

    caracortada_uk Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    20
    Likes Received:
    0
    Thanks danfrance!! Clearing the contacts storage and reimporting done it! I was really confused how they kept coming back even with sync off. There is an offline sync back up lol!
     
  11. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,304
    No worries matey. Enjoy the ability to phone your friends ;)
     
  12. arashkhaan

    arashkhaan New Member

    Joined:
    Sep 26, 2010
    Messages:
    2
    Likes Received:
    0
    Hi to all, when I send my contact to car audio bluetooth, still is in US format !! how can I fix this ?
    In my phone local and text is in UK format but when sending contact information it send it in US format (xxx-xxx-xxxx)
     
  13. gr8bovall

    gr8bovall New Member

    Joined:
    Sep 30, 2010
    Messages:
    3
    Likes Received:
    0
    I've got the same problem. Will try the suggestion and see what happens.
    Thanks
     

Share This Page

Loading...